x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Failed to open descriptor file! - Make sure VS is compiled for shipping

Hello,

after successful packing i can´t start the builded myproject.exe!

I only get the error message :

"Failed to open descriptor file ´../../../Myproject-Win64-Shipping/Myproject-Win64-Shipping.uproject´ "

i tried to package and cook again but the same problem

Product Version: UE 4.8
Tags:
more ▼

asked Jul 04 '15 at 08:28 PM in Packaging & Deployment

avatar image

MoonwareGames
36 5 11 15

avatar image Xennon Jul 05 '15 at 10:03 AM

I have the exact same problem. No matter what project I try to build, it always gives that same error. I can only run the game via "Launch" in the editor, but no matter what I do, I can't build a stand alone build. I'm using windows 7 x64 and building a win32 package.

Also - as a side note, how do you exit the game once it's launched? Is there some mystical key-combo that exits or do I have to somehow add this functionality to my projects?

avatar image Roman Gorislavski Jul 05 '15 at 03:56 PM

Have you tried Esc on keyboard if in viewport. If stand alone then Alt+F4.

avatar image Xennon Jul 05 '15 at 05:00 PM

Alt-F4 doesn't work for me. I managed to add an input action to quit game when player presses Esc or Alt-X. It doesn't appear that any built-in hot key is used for exiting the game which seems odd to me. Fortunately adding one was not hard.

avatar image MoonwareGames Jul 05 '15 at 05:24 PM

In stand alone u have to put a own key function to close. I had the same problem and have put it with a menu and the ESC key to close the Stand alone

avatar image Roman Gorislavski Jul 05 '15 at 03:51 PM

I have same problem on Windows 8 x64 Temporary solution is to change built from shipping to development. Hope this will get real fix soon.

avatar image MoonwareGames Jul 05 '15 at 05:02 PM

So its a bug of the engine ? Because of this i can use Dev instead of Shipping until it fixed . If not i hope for a solution

avatar image Xennon Jul 05 '15 at 05:05 PM

Yes, I noticed that also. Development build seems to work fine but shipping build always fails with that descriptor file error. I'm not sure what the differences are between dev and ship - maybe shipping is more compact. In any case, choosing a different build shouldn't break the build if nothing else is changed.

avatar image MoonwareGames Jul 05 '15 at 05:17 PM

No shipping is like a finish game. it make it able for works on and with Steam for example. But u are right. It s only the kind of rendering and building and this cant make it possible or impossible to work

avatar image wittlief ♦♦ STAFF Jul 09 '15 at 04:16 PM

Hi AVARSStudios,

I noticed that you marked this issue with the crash tag, does your packaged project actually crash and bring up the crash reporter, or does it just stop working with the descriptor error?

If the former, can you see if you have crash logs in your project's saved folder and attach to this thread as a txt file?

If you don't experience a crash, can you post your project's successful build logs, along with your packaging process?

Thanks!

avatar image MoonwareGames Jul 12 '15 at 06:17 PM

I haven´t experience some crash files.link text

package.txt (3.4 MB)
avatar image MoonwareGames Jul 12 '15 at 06:23 PM

alt text

settings.png (30.8 kB)
avatar image wittlief ♦♦ STAFF Jul 14 '15 at 04:47 PM

For process I mean more like how do you package, from the editor or from the Project Launcher? Do you use the command line? Are you using binary or source from Github?

avatar image MoonwareGames Jul 19 '15 at 06:30 PM

For normally i open my project editor and package there always (with file->packaging project) and i look with the outputlog always the process and the faults and errors while the packaging works.

All in all i use source from Github. I hope this is more useful than before.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok, have you built Win64 UE4Game with the Shipping configuration in Visual Studio?

more ▼

answered Jul 20 '15 at 07:52 PM

avatar image MoonwareGames Jul 20 '15 at 07:59 PM

What u mean exactly? i have build with standard config of the editor

avatar image wittlief ♦♦ STAFF Jul 23 '15 at 08:58 PM

Hi AVARSStudios,

Are you still unable to package for shipping?

avatar image fdslk Aug 25 '15 at 04:06 AM

I'm having this problem with the launcher version of the engine (4.8.3)

avatar image Samantha Sutton ♦♦ STAFF Aug 26 '15 at 03:30 PM

Hey FDSLK,

In order to better assist you, could you please post a new question to AnswerHub and upload a .txt file of your errors from packaging and also any additional information you may have regarding this error?

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question