x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 (Engine) project won't build

Basically, when i try to compile the Engine inside the solution it always traces this:

1>------ Build started: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------ ========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

But it doesn't compile at all, it just says build succeeded.

Any ideas why? :/

P.S Just wanted to state again that it's not the project, it's the engine.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 05 '15 at 10:06 AM in C++ Programming

avatar image

onathamarat1
10 3 4 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hey onathamarat1-

If you are using the binary version of the engine (Engine from the Epic Games Launcher) then changes to the engine code will not update after changes because only the binary files exist, not the actual source files that are being built. If you are using the source version from GitHub, the compiler will update only the files that have chanced since the last compile. As kishoreven mentioned, creating a plugin or adding/removing something from the code will cause the files to compile again after the change.

Cheers

Doug Wilson

more ▼

answered Feb 17 '16 at 05:09 PM

avatar image Motanum Nov 02 '16 at 08:55 PM

Hi!

So, what do I need to do to get the actual engine to compile after I made changes to a CPP file? I am using the engine from the epic games launcher.

https://answers.unrealengine.com/questions/518358/how-to-compile-engine-from-project-solution.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I don't really get the question. But I think the reason why you aren't seeing any compilations is because the binaries are already compiled and there are no changes made to the editor that will require it to recompile. If you make changes to the editor, like maybe add a new plugin, or add a native actor code, then you can see it recompile.

Like I said, I don't completely comprehend the question, but hopefully that helps you get to the answer

more ▼

answered Jul 05 '15 at 12:08 PM

avatar image

kishoreven
307 13 14 25

avatar image onathamarat1 Jul 05 '15 at 03:29 PM

I already tried editing the engine codes but it still doesn't compile.

To be more specific when i try to compile the project named UE4 which contains all the bass classes such as Pawn, GameFramework. It skips the compliation for some reason and says it succeeded but it doesn't compile anything.

avatar image kishoreven Jul 06 '15 at 03:36 AM

Interesting, which file in specific did you change!? Also how did you get your engine? Was it from Unreal Launcher or did you make a build from github?? If you get it from Unreal Launcher, i don't think you can make changes to those files. Do you have any need to change engine code?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Under normal circumstances your IDE will skip the compilation of Engine Modules, because of your selected solution configuration. For instructions on how to build the Unreal Engine itself from source, I suggest reading this.

more ▼

answered Feb 17 '16 at 12:53 PM

avatar image

SteamyThePunk
68 6 10 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm having the same issue. I've selected the Development editor solution configuration and ensured the engine is selected. Succeeds without building anything.

more ▼

answered May 21 '18 at 08:54 AM

avatar image

BrainCheffSteff
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question