x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] Building Lighting in OS X Editor stays at 0% indefinitely when Lightmass is blocked by firewall

I'm using the OS X version of the UE4 editor, running on OS X Mavericks 10.9.2.

Earlier today I had removed several applications from my computer's Firewall Options... menu, which is where you mark an application as being Allowed or Disallowed incoming network connections; I must have gotten too enthusiastic and removed UnrealLightmass.

Later, I was working in a level in the Editor, and Lighting would not build; when trying to build Lighting in a scene the Lighting Build would stay at 0% and not proceed any further. On a scene that took less than a minute to build lighting yesterday, today I left it for 20 minutes and it stayed at 0%. After restarting my computer and trying again, I got a system dialog/pop-up window asking if I wanted to Allow incoming network connections for UnrealLightmass. I clicked Allow, and the Lighting Build worked immediately.

After some quick tests, I discovered that if the built-in Firewall in OS X is turned on, and 1) UnrealLightmass not on the list of applications allowed to have incoming network connections; or 2) UnrealLightmass is disallowed incoming network connections; or 3) there is a system dialog box/pop-up asking if you want to Allow to Disallow incoming network connections and you haven't chosen Allow; then Lighting Build will sit at 0% and not proceed further.

Now that I have the Firewall set to Allow incoming network connections for UnrealLightmass, Lighting Builds work perfectly fine.

I'm not sure if this is really a bug, or a side-effect of some OS X quirk, but I wanted to report it anyways.

Product Version: Not Selected
Tags:
more ▼

asked Apr 06 '14 at 02:26 AM in Bug Reports

avatar image

JonathanADaley
644 37 49 78

avatar image gmpreussner STAFF Apr 07 '14 at 01:12 AM

This is expected. Lightmass is running in a separate application that communicates with the Editor through a network connection. We are planning to rewrite that application in C++ at some point, and then we will likely also add an option to communicate through so called Named Pipes instead of a network connection, so that a firewall exception is not needed when running Lightmass on your local computer only.

In the meantime, please configure a firewall exception for Lightmass. If you don't run any other Lightmass computers on your network to distribute the workload then it is sufficient to grant access to localhost only - no communication with other computers is required in that case. If you use multiple computers to build lighting then you have to grant access to the network as well.

avatar image JonathanADaley Apr 07 '14 at 02:09 AM

Thank you for the response. This makes perfect sense now.

avatar image yazybones Jun 09 '14 at 12:03 PM

I'm experiencing the same issue using Unreal Engine 4.2 and OSX 10.9.3. I've got my firewall disabled and when I start the build process I can see the UnrealLightmass process gets started (using ps auxww | grep -i unreal) however the build sits at 0% forever.

Any thoughts / suggestions?

avatar image bobht Sep 01 '14 at 06:39 PM

this is a real issue. Did anyone solved that problem?

avatar image JonathanADaley Sep 01 '14 at 06:55 PM

You have to configure a firewall exception for Lightmass on OS X.

avatar image TigerCoding Mar 04 '15 at 05:57 PM

I hope this is a VERY high priority for the UE team. Epic is trying to attract new people, and everyone with a Mac that has a firewall on will instantly not be able to use build, causing them to possibly run back to Unity or some other engine that works correctly.

In the meantime, to make the firewall changes:

  1. Open System Preferences

  2. Select security and privacy

  3. Select firewall

  4. Click the lock in the bottom right to allow changes

  5. Click firewall options

  6. Turn off block all incoming connections

  7. If #6 was enabled, make sure "automatically allow signed software" is unchecked and steal mode is checked.

  8. Click the "+" button

  9. This is where it gets fun.

  10. Navigate to Hard drive > Users > Shared > UnrealEngine > 4.7 > Engine > Binaries > Mac

  11. Select UnrealLightmass.app

  12. Click add

  13. Repeat step #10

  14. Select UE4Editor.app

  15. Click add

  16. Click OK

  17. Click the padlock to prevent further changes

avatar image JonathanADaley Mar 04 '15 at 09:04 PM

There are pop-ups that come up asking you to Allow network connections; clicking Allow will prevent the issue.

You can go through the steps you outline to ensure you don't have to click Allow every time you open the Editor or do a Lighting Build.

In this case it really isn't an issue with the Editor, but a side effect of how OS X handles its network security.

I haven't had any issues since allowing the connections.

avatar image TigerCoding Mar 05 '15 at 10:56 PM

It's a very inconvenient thing for people new to Unreal (such as myself). Things is, it should be as easy as possible for people to use without problems like this. Epic has already said they were going to change it; I'm just hoping it's sooner rather than later. :)

avatar image sinay Jun 25 '15 at 01:15 AM

Same here. I was all excited to finally get a new Mac, mainly to be able to use Unreal Engine, and I'm baffled by all the illogical counter-intuitive problems I run in, like this one.

avatar image sincitycyclops Oct 08 '15 at 12:21 PM

I did all this and it still doesn't build the lights UGH!

Version: 4.8.0-2710036+++depot+UE4-UT-Releases

Mac OSX 10.10.5

avatar image CHADALAK1 Dec 09 '15 at 02:45 AM

I too have this issue as well even when my firewall is completely turned off :/ . running Mac OSX El Capitan

avatar image AndrewHurley Dec 09 '15 at 05:14 PM

Hey CHADALAK1,

Would you mind sharing which engine version you are experiencing this issue with so I can test this on a Mac with El Capitan here?

Thanks,

Andrew Hurley

avatar image javoire Jan 17 '16 at 04:14 PM

I'm experiencing this issue with the OS X firewall turned off.

  • Yosemite Version: 10.10.5 (14F1021)

  • UE editor: 4.10.2-2818068+++depot+UE4-Releases+4.10

avatar image Steve Hardister ♦♦ STAFF Jan 20 '16 at 03:05 PM

I was able to repro this in Yosemite running the same version above UE4.10 CL2818068 with OS X firewall off: To fix, you have to follow steps provided by TigerCoding above precisely, specifically steps 10-17 so you end up with these firewall preferences: Firewall Preferences

macfix.png (222.6 kB)
avatar image TigerCoding Jan 24 '16 at 07:37 PM

For clarity, you only need the bottom two ones, not remote login or screen sharing.

avatar image koralred Jun 21 '16 at 10:23 AM

Still experiencing this issue...

OS X El Capitan 10.11.5

UE: 4.12.3-3013449+++UE4+Release-4.12

Tried with following configurations:

• Firewall off

• Firewall on, exceptions for UE4Editor and UnrealLightmass;

  • Automatically signed... ON / Stealth mode OFF and ON

  • Automatically signed... OFF / Stealth mode OFF and ON

... and still can't get past 0% on the build for lighting.

Any news regarding this?

avatar image ThePumaman Jan 29 '16 at 09:13 PM

I'm also experiencing my project unable to progress past 0% when building lighting. I'm using UE 4.10.2 on a late 2013 Mac Pro with El Capitan 10.11.3, and I've done all the firewall and cache clearing as described elsewhere, even reinstalled UE.

My project was created on the Windows 10 version of UE 4.10.0, upgraded to 4.10.2 there, then brought over to the Mac via Perforce to build to iOS. On the Mac, the project can Launch in a new window, but trying to build the lighting has it hung at 0 %.

I can build a new template project successfully, which means it's a project issue, but before I try and rebuild are there any caveats to doing the Windows-Mac project transfer that might be causing the hang?

avatar image AndrewHurley Jan 31 '16 at 10:10 PM

Moving from one platform to another can be a bit dangerous and can cause things like this to happen. Try deleting your DDC folder as well as the Saved folder and then rebuilding your lighting. Be sure to make a copy of your project before deleting the folders in case it causes an unexpected issue.

As you mentioned, you are able to build successfully on the Mac within template projects. This means there is a variable within your own project that is causing lightmass to hang. Quick question, how large is your scene you are building, and can you still build the same project on your Windows machine?

I usually don't suggest alternating between different platforms when working on a project, as these kinds of things can tend to happen. Typically you want to remain on an engine version and platform from start to finish, unless there is a need to shift.

Thanks,

Andrew Hurley

avatar image ThePumaman Jan 31 '16 at 10:34 PM

My scene's tiny- everything is spawned in including the lighting, so it's basically an empty level with some spawn controllers. Since directional lighting doesn't work on mobile, every object has a point light as a component of its blueprint for illumination.

avatar image AndrewHurley Jun 21 '16 at 01:44 PM

You wouldn't happen to have Avast Mac Security 2015 installed on your machine?

We do have a software conflict with Swarm Agent and Avast Mac Security 2015. Perhaps this is what is causing your issue?

Software Conflicts

Have you attempted to uninstall and re-install the engine?

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

avatar image sincitycyclops Jun 21 '16 at 03:07 PM

This was actually fixed a few builds ago but is back again. I added a dual boot to my machine and use Windows for u4e and ut now. I was going to go back to Mac osx for it but alas the problem has returned.

avatar image koralred Jun 21 '16 at 03:25 PM

Please check the update to my comment, the issue was with Freedome VPN after all. Mild inconvenience, but I'll have to live with that for now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

No anti-virus software installed, but I do have Freedome VPN. I did try all configurations with the VPN off, though, and still lags at 0%.

And yes, I had to uninstall and reinstall due to another issue, which didn't resolve either (I'll post a separate thread regarding that one later today).

If you need to know hardware here's a screenshot, but I doubt that this setup couldn't handle such a task as building some lighting.

hardware

UPDATE: I finally managed to get the lighting to build, and it seems like the issue was with Freedome VPN, after all. After restarting the computer, I turned off Freedome and launched UE4 Editor, after which the build ran with no issues. Still verified that this was the issue by turning on Freedome, and alas the build stayed at 0%, and turning it off again made the build work again. Not sure why this didn't work the first time around, but at least now it works fine (as long as the VPN is off).

hw.png (38.2 kB)
more ▼

answered Jun 21 '16 at 02:55 PM

avatar image

koralred
26 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question