x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Audio Bug In NavModifierVolume?

I'm playing footstep sounds through a line trace Blueprint, and sound is cutting off when I enter a NavModifierVolume. I changed collision to IgnoreOnlyPawn and my sound worked.

I need to have the pawn recognised as I enter, so is this a bug or can I solve this somehow? I've replicated the bug with another volume to check it wasn't a one off.

Thanks for your time :) NJ

Product Version: UE 4.8
Tags:
more ▼

asked Jul 06 '15 at 02:48 PM in Bug Reports

avatar image

NJ Apostol
1 2 3

avatar image AndrewHurley Jul 06 '15 at 03:16 PM

Hey NJ Apostol,

Would you mind providing me with some reproducible steps in a blank empty project so I can test and verify this issue on my end as well?

Some screenshots of your blueprint graph on how you are setting up the line trace and getting the sound to play would be very helpful as well.

Thanks,

Andrew Hurley

avatar image NJ Apostol Jul 06 '15 at 04:03 PM

Thanks so much for getting back to me.

This is the Blueprint in the character Anim Graph. If you drag and drop the NavModiferVolume in the world, by default the sounds cut out when you walk through it. When I change the collision from block all to ignore only pawn then it doesn't cut the sound out.

I hope this helps,

Cheers, NJ

[1]: /storage/temp/49269-u0-weu-d2-f4cc8c33baa47fb4c51cc742517f7a41^pimgpsh_fullsize_distr.jpg

avatar image AndrewHurley Jul 07 '15 at 07:30 PM

Hey NJ Apostol,

I am attempting to reproduce the issue you are reporting, but need a bit more information. I have followed the set up you provided, but it seems you have added a custom event called 'AnimNotify_Run' which I do not have the information on what this custom event is doing.

Would you mind showing me how you have your custom event set up, as well as the set up for your scene within the editor when testing with the Nav Volume?

Thank you,

Andrew Hurley

avatar image NJ Apostol Jul 09 '15 at 10:47 AM

Hi Andrew,

Sorry the picture isn't great. Here is where I have the event. Its an anim notify in the my character animation.

It calls every time the foot contacts the ground and the trace looks for the the physical material. All of this works perfectly. it's just that when I walk through the volume that all sound cuts out. the footsteps are just one example but on testing it further, no sounds work in the world.

Does this help at all?

Cheers, NJ

[1]: /storage/temp/49605-image.jpeg

image.jpeg (2.4 MB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

We are almost there as far as information needed. I need to see the process you took when creating the custom event 'AnimNotfy_Run' so that you were able to call this within your event graph of your Animation Blueprint. There are various ways to set this up and each way functions differently as mentioned in the documentation below.

Animation Notifies

https://www.unrealengine.com/blog/crash-course-in-animation-notifies

I just tested a simple 'EventHit' within the CharacterBlueprint to play a sound at location when entering a volume, and I had no problems with my sounds within the level. Although this test is not the exact same set up, the problem could lie within the way you are calling the sound to play within the Animation Blueprint.

Thanks,

Andrew Hurley

more ▼

answered Jul 09 '15 at 07:24 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question