x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.8.1 engine crashes after importing animation fbx

Whenever I try to import an animation fbx file, I get a "failed attempt" message. The second time I try to import, there's no options box, and it attempts to import, and proceeds to crash the engine. I'm using the ART export tools provided for Maya. Also, I just updated to 4.8.1 today.

alt text

Product Version: UE 4.8
Tags:
screenshot (7).png (942.7 kB)
more ▼

asked Jul 06 '15 at 07:37 PM in Bug Reports

avatar image

aaron_saluk
66 7 13 21

avatar image Lovecraft_K ♦♦ STAFF Jul 07 '15 at 01:43 PM

Hi aaron_saluk -

Can you share the Maya asset file for us to test this issue with? We are currently unable to reproduce this message with assets we have on hand.

Thank You

Eric Ketchum

avatar image aaron_saluk Jul 07 '15 at 02:52 PM

I've been trying to attach the fbx files to this comment, but this site won't allow me to upload them. Is there some other way I could share the files with you?

avatar image Ben Halliday STAFF Jul 07 '15 at 03:00 PM

Hi aaron,

If it's small enough, you can zip it and attach the zip file here. Otherwise, you can upload it somewhere like Dropbox or Google Drive (both free) and give us a download link. Thanks!

avatar image aaron_saluk Jul 07 '15 at 03:12 PM

this is the rig file link text

these are some of the animations link text link text link text

avatar image Lovecraft_K ♦♦ STAFF Jul 07 '15 at 05:43 PM

Hi aaron -

The Animation FBXs you sent are empty, I tried opening them in Max and Maya and there is nothing in them. Can you double check to make sure that they have the correct assets saved into them?

Thank You

Eric Ketchum

avatar image aaron_saluk Jul 07 '15 at 06:00 PM

I double checked and exported another fbx using the ART toolset, and there does seem to be a problem. The joints are initially visible and show keyframes when the file is reimported, and then immediately dissappear once they're clicked off of. I've been using the "export animation" dialogue box. I'm going to try to export an fbx the manual way and see if I get better results.

avatar image Jeremy Ernst STAFF Jul 24 '15 at 04:16 PM

Not a problem, that is how it's supposed to be!

avatar image aaron_saluk Jul 07 '15 at 06:25 PM

Ok, I was unable to export an fbx using the manual joint selection method, because the referenced files used by the ART toolset don't allow me to select the joint hierarchy normally. I'd rather not tear apart the rig file and risk breaking something at this point. It would seem that the "export animation" options built into the ART tools aren't working correctly. I don't know how else to explain this.
Its worth mentioning that this is my third post that has lead me back to a reevaluation of the UE4 rigging tools for Maya. As much as I love the ease of use that these tools offer, I've also encountered problems that I as a user was not able to directly address. That being said, the support from Epic on these tools has been excellent each time, and has lead to a careful resolution of each problem.

avatar image Lovecraft_K ♦♦ STAFF Jul 09 '15 at 02:01 PM

Hi aaron -

If possible can you share your Maya Scene File so I can take a look at your model with the ART settings in Maya? If you would like to keep it private feel free to send a link to the file to me via the Private Message system in the Forums.

Thank You

Eric Ketchum

avatar image aaron_saluk Jul 09 '15 at 03:26 PM

here are the files. I don't know how to send a private message, so once you've downloaded them, please tell me, and I'll deactivate the links.

this is the ART rig export file exportfile

this is the ART animRig file animRig

this is the walk animation maya scene SkylarWalk

this is the dive roll animation maya scene SkylarDiveRoll

I don't know if its needed, but heres the bitmaps generated by the ART tools

large largeBitmap small smallBitmap

avatar image Lovecraft_K ♦♦ STAFF Jul 09 '15 at 04:29 PM

Done, feel free to remove the links.

avatar image aaron_saluk Jul 14 '15 at 10:02 PM

Has there been any progress on this? Did I make a mistake in the way I used the ART tools?

avatar image Matt.Williams Jul 20 '15 at 04:50 PM

Hey Aaron,

I'll be looking into this issue for you. We had a similar bug reported, but there was no crash involved.

Is the editor giving you a crashreporter window with a callstack?

-Matt W.

avatar image aaron_saluk Jul 20 '15 at 05:33 PM

![alt text][1]

Hey Matt, This is the crash report it sends. If you need anything else, please feel free to ask. I'd love to get to the bottom of this problem. [1]: /storage/temp/50806-screenshot+(9).png

screenshot (9).png (311.1 kB)
avatar image Matt.Williams Jul 20 '15 at 06:34 PM

Can you copy/paste everything in the callstack window into a txt file for me? This way I can look it up in our system and see if we have any other users with it and also check if it's been bugged before.

avatar image aaron_saluk Jul 20 '15 at 06:55 PM

here's the text. I hope it helps.link text

avatar image aaron_saluk Jul 22 '15 at 04:45 PM

I hate to be the squeaky wheel, but are there any updates on this?

avatar image Jeremy Ernst STAFF Jul 24 '15 at 04:18 PM

I really don't think this is a rigging toolkit bug at all. I will take a look at the files, but an FBX crash on the engine side is likely not an issue with the maya tools.

avatar image Jeremy Ernst STAFF Jul 24 '15 at 04:35 PM

still looking into it, but my first guess is that this only opens in maya 2016, so I think it's the fact that the fbxs are 2016 version. I need to test this theory, but I need to go eat lunch :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok, I've finished digging into this, and the issue is definitely not with the Animation and Rigging Toolkit, but rather with the FBX version. When I tried to open the provided FBX files, they would only open in 2016 for me, which was a red flag, as I don't think UE4 has 2016 FBX fully supported yet. I simply re-exported the FBX using FBX 2014/2015 file format, and presto!

I recorded the process here: https://www.dropbox.com/s/6ledknvsprcp87m/FBX_Import_Issue_RESOLVED.mp4?dl=0

more ▼

answered Jul 24 '15 at 06:52 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

open the fbx you want to import and make sure the amount of bones and names match those in skel file.

more ▼

answered Jul 06 '15 at 07:42 PM

avatar image

Reanimathor
20 3 6

avatar image aaron_saluk Jul 06 '15 at 08:20 PM

The skeleton is the same one that was generated by the "export file" using the Maya ART toolset. But to be on the safe side, I checked the fbx side by side with the skeletal rig, and the bone names all line up.

avatar image Reanimathor Jul 07 '15 at 06:58 AM

The same happens when you want to import the animation as a skeleton?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question