x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't "Alpha" test from google play

This doesn't work with 4.8.1 the game keeps crashing when opened/started

Native crash at /system/lib/libdvm.so

in /system/lib/libdvm.so, /system/lib/libhoudini.so.4.1.0_y.45074

Here are some CRASH/ANR reports of the problem

1

Build fingerprint: 'acer/b1750_ww_gen1/vespa2:4.4.4/KTU84P/1418292109:user/release-keys' Revision: '0' pid: 22332, tid: 22346, name: main >>> com.dnatoxicgames.balloonypoprevised <<< signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0000002c eax 00000000 ebx 6d413c30 ecx 00000000 edx 36555dd0 esi 72031008 edi 72031008 xcs 00000023 xds 0000002b xes 0000002b xfs 00000073 xss 0000002b eip 6d2bfb32 ebp 36555cf8 esp 36555a20 flags 00210246

 backtrace:
 #00 pc 00090b32 /system/lib/libdvm.so
 #01 pc 001ae472 /system/lib/libhoudini.so.4.1.0_y.45074

2

Build fingerprint: 'acer/b1750_ww_gen1/vespa2:4.4.4/KTU84P/1418292109:user/release-keys' Revision: '0' pid: 18623, tid: 18638, name: main >>> com.dnatoxicgames.balloonypoprevised <<< signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000018

 backtrace:
 #00 pc 0009241e /system/lib/libdvm.so
 #01 pc 001ab16a /system/lib/libhoudini.so.4.1.0_y.45074

3

  Build fingerprint:
   'acer/b1750_ww_gen1/vespa2:4.4.4/KTU84P/1418292109:user/release-keys'
   Revision: '0' pid: 18540, tid: 18554,
   name: main >>>
   com.dnatoxicgames.balloonypoprevised
   <<< signal 11 (SIGSEGV), code 1
   (SEGV_MAPERR), fault addr 00000018
 
   backtrace:
   #00 pc 0009241e /system/lib/libdvm.so
   #01 pc 001ab16a /system/lib/libhoudini.so.4.1.0_y.45074

Anybody got an idea what's going on?

Product Version: UE 4.8
Tags:
more ▼

asked Jul 06 '15 at 10:52 PM in Bug Reports

avatar image

KillerSneak
151 10 12 17

avatar image KillerSneak Jul 08 '15 at 09:34 AM

I think it has to do with the game now being put into a folder UE4Game.

So even when you're able to build a "For Distribution" / Shipping game it will not work from the app store or installing it locally. For now you're stuck with a non Distribution / Shipping game

Working: (can install locally via batch / Google won't work due to the signing)

Build configuration: Shipping

Full rebuild

Not Working: (can not install locally via batch / Google will allow upload but game will crash on start)

Build configuration: Shipping

Full rebuild

For Distribution

A full shipping for distribution build will give the error:

Failed to open descriptor file

https://answers.unrealengine.com/questions/193172/failed-to-open-descriptor-file-2.html

avatar image KillerSneak Jul 08 '15 at 10:33 PM

wittlief ♦♦ STAFF 2 hours ago Hi KillerSneak,

Failed to open descriptor file is a common error caused by many things. Do you have your Google Play keystore setup?

Yes I have otherwise you can not upload to google at all. The descriptor file isn't common imho as all other builds don't cause this error only "Shipping / For Distribution" causes this error and to me it seems related to the UE4game folder that is now used to place everything in.

Ben Halliday ♦♦ STAFF 33 minutes ago

Hi KillerSneak, We will be tracking the issues you are experiencing on the post that you made:

https://answers.unrealengine.com/questions/253779/cant-alpha-test-from-google-play.html

Please refrain from posting your issue on multiple threads on AnswerHub. We will address the issue on your post. Make sure you include any logs you can, as requested by wittlief.

What kind of logs would you like to have?

The below link contains the only relevant info I could log while running the game -> seeing it crash instantly

https://forums.unrealengine.com/showthread.php?75369-Can-t-Alpha-test-from-Google-Play&p=326654&viewfull=1#post326654

avatar image Ben Halliday STAFF Jul 08 '15 at 10:41 PM

I think wittlief was looking for output logs, and any logcat logs. Also, which devices are you seeing this with? Thanks!

avatar image KillerSneak Jul 08 '15 at 10:49 PM

acer iconia one 7

acer z220

Samsung galaxy S5

The topic I posted above holds the logcat log as there's not much to catch as it crashes instantly. Ill do another run on the tablet now and upload the whole thing to a file server and post the links

avatar image KillerSneak Jul 08 '15 at 11:01 PM

Log: http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/log.txt

launched the game 2 times (and crashes) to be sure.

avatar image Bobvodka STAFF Jul 09 '15 at 02:59 PM

Hey there,

I'm currently looking into this issue and I have an idea what might be happening.

For each of the devices listed could you say which version of Android they are running? And just to double check; are they all crashing as indicated in the log below when being run from the store based install?

avatar image KillerSneak Jul 09 '15 at 03:39 PM

Hi Bobvodka,

I'm not at home right now. But all devices crash with a build from the Play Store (Shipping / For Distribution)

Installing the game locally works fine on at least the: acer iconia one 7 and acer z220 as these are owned by myself and I use them to test the games myself.

Once I get home Ill run both devices again and post the logs for both devices (should be around 22:00 GMT+1 , my time) based on a App store release and a local release.

As for the logs: Both from a run on my Tablet (Acer iconia one 7)

App Store: Shipping / For Distribution

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/log.txt

Local: Shipping (not For Distribution)

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/log_shipping_non_distribution_local_.txt

The acer iconia one 7 (tablet) runs Android 4.4.4

The acer z220 (phone) runs Android 5.0

For the Galaxy S5 I will have to ask my "co developer" Once I get home.

avatar image KillerSneak Jul 12 '15 at 09:18 AM

Any news on this with the new logs provided below?

avatar image Bobvodka STAFF Jul 15 '15 at 08:34 AM

Sorry, for some reason I didn't get an email saying there was a reply in the topic so hadn't checked; I'm looking over the most recent information now.

avatar image KillerSneak Jul 08 '15 at 11:12 PM

And a local installed version (via batch) With Shipping enabled / but for distribution disabled.

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/log_shipping_non_distribution_local_.txt

Works fine on the same device

avatar image KillerSneak Jul 15 '15 at 08:14 AM

So with 4.8.2 things change, I can't test further until later today but:

launching the game from the engine to my Tablet fails to start the game on my tablet and it crashes.

Package Android All: install via batch also fails.

Both in development mode, where with 4.8,1 i could atleast install via batch or launch to the device to make it work.

Full crash / reports will follow (hopefully) later today.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I'm working on this right now, however if you want to track the bug to see if it has been completed then I've entered it as UE-19190

The aim is to get it done for 4.10.

more ▼

answered Jul 27 '15 at 10:30 AM

avatar image KillerSneak Jul 29 '15 at 02:14 PM

Sorry to ask this but where can I find/track this? It's not on trello?

avatar image Bobvodka STAFF Jul 29 '15 at 02:47 PM

It is on our JIRA board which isn't public right now I'm afraid.

avatar image Bobvodka STAFF Aug 07 '15 at 11:11 AM

So an updated on things.

I'm still working on this and I'm not having any luck reproducing it with a small test case (120 achievements, 1 leader board) so I'm going to try and reproduce it with the version you sent me (all be it updated to our mainline code, at least for now).

I'll update as/when I have any other news to give.

avatar image KillerSneak Aug 07 '15 at 02:43 PM

Okay hope you can find what's going on.

I did find a topic about the Cache Achievements Descriptions causing a crash here:

https://answers.unrealengine.com/questions/216450/cache-achievement-descriptions-crashes-on-android.html

Maybe it's something similar. I'm working with 4.9 Preview2 and the issue remains. I have added print string to log nodes everywhere and it seems as soon as the "Cache Achievements" Node is run the project crashes so maybe the fix of the above topic can be applied to problem "I'm" having as well?

If needed I can upload the current build I'm working with for you (4.9 Preview2 based project although the problem remains the same).

EDIT1

Can you tell me your defaultengine.ini if it has:

[OnlineSubsystem] DefaultPlatformService=Null

Or?

[OnlineSubsystem] DefaultPlatformService=GooglePlay

I have read somewhere that changing it to Null instead of GooglePlay can fix some issues?

avatar image Samantha Sutton ♦♦ STAFF Aug 13 '15 at 06:47 PM

Hey KillerSneak,

The issue that you linked has already been fixed, it was committed back in April and it would've been fixed in 4.8. Also, in order to better assist you, I've requested another developer to look into your issue further. Would you mind providing me a link to your project through a private message in the forums?

Also, your defaultengine.ini file should read as [OnlineSubsystem] DefaultPlatformService=GooglePlay if you'd like to incorporate GooglePlay services.

Thank you!

avatar image KillerSneak Aug 13 '15 at 07:10 PM

yeah that's what I had as [OnlineSubsytem] but thought it might have made an difference (No matter if I set it to GooglePlay or NULL it still crashes on Google Play Services Login)

I can send you my latest build based on 4.9 Preview3, how can I find you on the forums?

EDIT: Packing the file now (didn't know you meant the normal forums.unrealengine.com.) You can expect a PM soon

avatar image KillerSneak Aug 14 '15 at 08:50 PM

Hi Samantha,

I have send you a PM on the forums on (08-13-2015 09:23 PM) but up till now I have had no response at all. Just want to know/make sure you received my PM and was able to download the project?

avatar image KillerSneak Aug 11 '15 at 12:36 PM

So i'm working on one of my other games and only made 5 achievements and 2 leaderboards and it seems to work perfectly (strange enough) So I have been checking all the files and settings to compare them and everything seemed identical (only difference was in the DefaultEngine.ini - so I made sure they are both identical now)

i even checked all files to make sure everything is the same and it it's (was a pain to check with so much libraries and files) so it's not a random left over file or setting that's different. I really think I have to much achievements some how, or maybe some achievement names are to long?

I'm still looking at it to see if I can spot anything different between the project/settings/files but up till now everything seems the same.

avatar image KillerSneak Aug 15 '15 at 10:24 AM

So I can confirm 100% it's mot my project but unreal engine not handling Incremental Achievements from Google Play Services right.

I'm working on my 2nd project (Fishy blub Blub) and it was working fine (tested on several devices) when I had only 12 Incremental Achievement's

Today I added more Incremental achievements's (Now a total of 57) and it crashes in the same manner as Balloony PoP Revised.

So please stop looking at my project files as it's not an error on my side (2 games crashing with the same error is hardly a user error) It's in the way UE4 is interacting with the google libraries in a wrong way.

I also think Bobvodka was testing normal achievements (non incremental) even though I told him several times it wasn't an issue with normal achievements. This is a major let down as I have spend more than an hour to implement all the achievement's into google play and now have to delete them all as they can't be used as intended.

EDIT:

The most annoying part is that again I have a useless game now as even changing all the incremental achievements back to normal ones don't seem to work anymore (somehow it's still caching the old stuff). This is getting really annoying, seeing all the over bloated features getting added with each new release but a simple Google Services FIX is no where to be seen.

I'm really thinking about moving to another engine now as this seems endless. I have been more busy posting here about all the error's and bugs than actually developing a working game with UE4 and Android!

EDIT2:

So I'm down to 59 achievements again and the Google Play Alpha build (that you actually download from the store) seems to work again... This is all really frustrating being stuck to anything with less than 100 achievements for the games I'm working on.

avatar image Terence.Burns Aug 17 '15 at 12:30 PM

Hey KillerSneak,

I'll look into this. Thanks for the info, there is certainly more than enough to go with.

I'll let you know when I have a fix. Hopefully soon.

/Terence

avatar image KillerSneak Aug 17 '15 at 01:04 PM

Thanks, and sorry for my previous "rant" needed to get that off my chest.

I got the game released and working correctly with 79 achievements and 3 leaderboards. 32 of them are incremental achievements.

https://play.google.com/store/apps/details?id=com.dnatoxicgames.FishyBlubBlub

I'm afraid to go any higher as it will break the game/engine again.

avatar image KillerSneak Aug 24 '15 at 07:05 PM

Any news on this Terence?

avatar image Terence.Burns Aug 25 '15 at 07:34 AM

Hi KillerSneak, this is on my todo list for this week :-) The fix wont make 4.9 but I will link you to the GH change once it's in for you to grab and build yourself if it's urgent.

/Terence

avatar image Terence.Burns Aug 28 '15 at 08:19 AM

I dunno why this got marked as answered, bumping to keep open. I'll keep you posted KillerSneak.

avatar image KillerSneak Aug 31 '15 at 08:42 AM

Did you manage to find the "source" of the problem or did you make any progress? I haven't used the engine/build from source so Ill probably have to wait for #1: The 4.10 engine release, #2: A hotfix for 4.9 (would be nice) #3: a fix in the form of a plugin.

avatar image Terence.Burns Sep 01 '15 at 09:21 AM

Hey killersneak, we use the GPS helper libs to handle achievement syncs and it seems to be going wrong in here. I'm working on getting a 100% repro setup and will look at upgrading the gps lib.

This likely won't be a part of any 4.9 hotfixes. When I get it fixed I'll send you the GH commit details that you can use to upgrade your source build. Otherwise this will be a 4.10 fix.

/Terence

avatar image KillerSneak Sep 01 '15 at 02:07 PM

Cool and thanks for the update. I can give you access to the project files I also gave to "Samantha Sutton" and "Bobvodka" if needed (send me a PM on the forums) it's quite easy to repo. Set up 104 achievments with proper naming and description (at least 25 chars) that will cause the error.

avatar image KillerSneak Sep 08 '15 at 07:40 PM

Hi Terence,

Hope you don't mind me asking if there's any news on this.

avatar image Terence.Burns Sep 09 '15 at 12:49 PM

Hi Killersneak,

Sorry for the delay, I've been trying to look at this through my current workload. I will be able to look properly on Friday :-)

/Terence

avatar image KillerSneak Sep 19 '15 at 08:40 AM

Any update on this? Or didn't you have the time? This topic has been going on since (Jul 07 '15 at 12:52 AM).

avatar image Samantha Sutton ♦♦ STAFF Sep 22 '15 at 07:30 PM

KillerSneak,

I've spoken with Terence regarding this issue. Currently, it's still an ongoing issue and we hope to have additional information soon.

Thank you!

avatar image Terence.Burns Sep 23 '15 at 08:45 AM

Hey Killersneak, apologies for the latency in the replies. This has been tasked like all other workload, but shifting workloads mean that sometime we have to prioritise other work.

I have a project setup and am awaiting some google account setup from IT to allow me to test the app. Ill make sure you dont wait much longer before you hear back from me.

I do believe this is an issue with GPS however, so if there is a fix it will involve an upgrade of the GPS services library.

/Terence

avatar image Terence.Burns Sep 28 '15 at 02:08 PM

Hey killersneak,

An update. I have been able to repro and am now looking at upgrading the GPS lib as a possible fix.

/Terence

avatar image Terence.Burns Oct 06 '15 at 09:21 AM

Hi Killersneak,

An update, upgrading the gps lib hasnt fixed the issue, so we need to look deeper at what it is doing. We should treat this as a limitation of the google play lib and workaround as much as you can.

Other goals with UE4 means this isnt getting the focus and attention it warrants, but we will get round to it.

We have it added as a JIRA in our tracking system, so this wont get lost, I assure you.

/Terence

avatar image Abnewstein Dec 13 '15 at 04:24 PM

So is it fixed yet?

avatar image Samantha Sutton ♦♦ STAFF Dec 16 '15 at 10:25 PM

UE-19190 is still unresolved and on our to do list.

avatar image Distul Dec 30 '15 at 07:45 PM

Was this resolved in the latest 4.10.1 release? Previously in 4.9 my incremental achievements were updating properly and now in 4.10.1 they are not. The write achievement progress node returns successful but the progress doesn't update on Show Platform Specific Achievements or on Cache Achievement Progress.

Example: If my achievement was to start the game 50 times and the player has started the game 30 times I would write 30 as an increment.

avatar image Samantha Sutton ♦♦ STAFF Dec 31 '15 at 08:38 PM

UE-19190 is still unresolved.

avatar image Distul Jan 01 '16 at 06:09 AM

Okay. I'm not experiencing the crashes but previously in 4.8/9 incremental achievement updates were done by pushing the completed value to Google Services, now in 4.10.1 it's done by pushing the percentage value on a 0 - 100% scale (not 0 - 1). For example: If an achievement takes 10 steps to complete before you would push each step they have completed (1, 2, 3 so on..); now you would send (10, 20, 30, so on.. 100 being completed in full). Easiest way to do this is Progress / Goal * 100.

If you need to complete an all or nothing (non incremental) achievement you just send 100 as the progress.

Hopefully this may help out someone.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Working Local Build Crash Google Build

Device(s) Info

Acer iconia one 7 (Tablet) runs Android 4.4.4

Acer z220 (Phone) runs Android 5.0

Game Info

Name: Balloony PoP Revised

Package Name: com.dnatoxicgames.balloonypoprevised


I have logged as much as I can for you Bobvodka, if there's anything else you need/want please let me know


Logs Local Shipping Logs - Screenshot 1 (Working build)

Engine Build Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/local/Android_all_Local_Build_Log.txt

Phone Local Install Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/local/Phone_Android_all_Local_Install_Local.txt

Phone Local Run Game Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/local/Phone_Android_all_Local_Run_Local.txt

Tablet Local Install Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/local/Tablet_Android_all_Local_Install_Local.txt

Tablet Local Run Game Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/local/Tablet_Android_all_Local_Run_Local.txt

Logs Local Google - Screenshot 2 (Crash build)

Engine Build Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Android_all_Google_Build_Log.txt

Phone Local Install Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Phone_Android_all_Google_Install_Local.txt

Phone Local Run Game Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Phone_Android_all_Google_Run_Local.txt

Tablet Local Install Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Tablet_Android_all_Google_Install_Local.txt

Tablet Local Run Game Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Tablet_Android_all_Google_Run_Local.txt

Logs Google Play Store - Screenshot 2 (Crash build)

Phone Google Play Store Install Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Phone_Google_Play_Install.txt

Phone Google Play Store Run Game Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Phone_Google_Play_Run.txt

Tablet Google Play Store Install Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Tablet_Google_Play_Install.txt

Tablet Google Play Store Run Game Log:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/google/Tablet_Google_Play_Run.txt

Not an answer:

couldn't post this as comment as It would be to long and I had to break it all up. Hope you understand as It's much easier to read/follow this way

more ▼

answered Jul 09 '15 at 09:46 PM

avatar image

KillerSneak
151 10 12 17

avatar image Bobvodka STAFF Jul 15 '15 at 09:25 AM

Just to rule something out sooner rather than later; you have correctly configured the application for Google Play access, yes? (Enabled, all relevant keys added.)

I'm only asking because from the working log there is a line which says it isn't configured. I'm going over the code now to see if it not being configured could be the reason for the crash, we shouldn't be crashing in that situation anyway so that's on us.

Also, and this tripped me up during testing, assuming you have some OBB data, has that file been successfully upload to the Google Play store AND downloaded with the app? There is a known problem with uploading which means you need to upload the APK twice before you get an option to add an OBB, and I've also had it fail to associate an OBB with an APK thus failing to download (although this shouldn't crash but I'd like to rule it out as a problem all the same).

avatar image KillerSneak Jul 15 '15 at 10:25 AM

Hi Bobvodka,

you have correctly configured the application for Google Play access, yes? (Enabled, all relevant keys added.)

Yes I have

I'm only asking because from the working log there is a line which says it isn't configured.

It generates that line because I have not released the Google Play Services publicly yet. This is needed for Alpha testing and allows me to give Alpha and Beta stage testers the chance to test the achievements / play services before actually releasing it.

Also, and this tripped me up during testing, assuming you have some OBB data, has that file been successfully upload to the Google Play store AND downloaded with the app?

Yes I'm at APK version 5 and know the first APK doesn't allow a OBB to be attached.

com.dnatoxicgames.balloonypoprevised

Version code 5

Version Name 0.0.1

Size 39,18 MB

Expansion file (obb) main.5.com.dnatoxicgames.balloonypoprevised.obb (18,3 MB)

Yesterday I re-installed UE4 (4.8.2) so now I have a clean system with only 4.8.2 installed.

So with 4.8.2 things change, I can't test further until later today but:

launching the game from the engine to my Tablet fails to start the game on my tablet and it crashes.

Package Android All: install via batch also fails.

Both in development mode, where with 4.8.1 I could at least install via batch or launch to the device to make it work.

Full crash / reports will follow (hopefully) later today.

  • OBB file downloading has always worked for me even without the new manifest tags added

https://play.google.com/store/apps/details?id=com.epicgames.BaloonyPoP

That's an old version based on 4.2 or 4.4 of the engine. The game I'm working on now is a rebuild/revised version that version also uses an APK and OBB file. That's why I don't get it why newer builds (once the engine started automating the manifest.xml / signing options / after 4..6 builds I believe) are not working anymore.

avatar image Bobvodka STAFF Jul 15 '15 at 01:16 PM

OK, I've had a look over the crashing logs and the main thing to jump out at me is that 'can not find ' stuff in the logs which is related to Google play etc. so it would seem that it can't find a bunch of classes which seems to be causing it to die.

Looking over your build log and comparing it to one from a test project I just made two things jump out at me; - My SDK tools are slightly newer (22.3.0 vs 24.0.2 & 19.0.1 vs 19.1.0), but I doubt that is a huge problem - We have different output when building the jar files.

Firstly my log has notes about entry points which are being kept which yours lacks; these are the same entry points your crash log complains are missing.

Next, and related, is a difference in post-obfuscation kept classes with yours showing 1302 and mine showing 1938 - a reasonably large differences.

So, I suspect the problem is that a bunch of classes are being stripped from the Jar file which is going to cause your problem.

I suggest taking a look at the proguard-project.txt files related to the project and the engine to see if they march.

Your project's should be in \Build\Android The engine one can be found in UE4\Engine\Build\Android\Java

These files should probably match, or at least the project one should have the same subset of entries as the Engine one does.

If they do match then could you post a link to one of them here so that I can compare them to the reference copy I have.

avatar image KillerSneak Jul 15 '15 at 02:08 PM

Hi and thanks for responding.

Ill look at the proguard-project.txt files once I get home later today.

Like I said above, yesterday the 4.8.2 update failed so I was forced to re-install the UE4 engine so I'm running a clean system/UE4 engine now with only 4.8.2 installed. So checking the files shouldn't be to hard.'

Question(s)

My SDK tools are slightly newer (22.3.0 vs. 24.0.2 & 19.0.1 vs 19.1.0), but I doubt that is a huge problem - We have different output when building the jar files.

How to obtain newer versions? As I'm running what UE4 is shipped/released with?

Next, and related, is a difference in post-obfuscation kept classes with yours showing 1302 and mine showing 1938 - a reasonably large differences.

What does this mean "Post-obfuscation kept classes"?

Once I get home, Ill upload the proguard-project.txt to my server and try to update the SDK Tools? (UE4 comes with 2.08r I believe?)

avatar image Bobvodka STAFF Jul 15 '15 at 02:12 PM

I updated using the SDK Manager; I can't recall if it was from the NVPACK shipped version or one downloaded directly from Google - its likely this is a minor difference and not worth worrying about however.

As part of the shipping process Proguard is run over the Jar files used to make the app; this both obfuscates and strips unreferenced classes from the Jar file - the 'kept classes' are the ones it didn't strip out of the Jar file (and thus the final apk) during the process. Yours seems to strip around 600 more than me but has roughly the same starting count indicating that more are being removed which would be consistent with the crash log output and an out of date Proguard Project file.

avatar image KillerSneak Jul 15 '15 at 02:32 PM

Thanks for the clarification.

Ill get back to you as soon as possible. Should be around 22:00 GMT+1 that I can get back behind the PC.

Ill keep you updated and informed on the "proguard-project.txt" files and updating the SDK (just so we are both on the same level and using the same tools/sdk versions)

avatar image KillerSneak Jul 15 '15 at 06:49 PM

proguard-project.txt Both files are identical

Local project http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/proguard/local/proguard-project.txt

Engine -> \Epic Games\4.8\Engine\Build\Android\Java http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/proguard/engine/proguard-project.txt

So there's no error in there.

I'm now updating the SDK to see if it will launch on the Tablet after the SDK is updated

avatar image KillerSneak Jul 15 '15 at 07:24 PM

Launching to Device still fails

So I updated:

Android SDK Tools Revision 24.3.3

and

Using latest Build Tools: 19.1.0 - although never version were available

Output log below

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/new/local/Launch_To_Tablet.txt

inside the log file I also noted the:

Project Settings - Packaging

Project Settings - Android

Settings just in case

Is there anything else I can do? Provide you with? Do you have a Google+ account so I can give you access to the whole project so you can load it up in UE4 ?

avatar image Bobvodka STAFF Jul 16 '15 at 09:32 AM

Whenever you post something to do with the crash I need the runtime logs as well as the build logs as the latter gives no indication as to why it has crashed.

avatar image KillerSneak Jul 16 '15 at 08:17 AM

SO I managed to do make it Launch on the Tablet

It's the google play services :( that stops the game from launching.

I edited the file in UE4Game\BalloonyPoPRevised\Engine\Config\Android\AndroidEngine.ini

I altered this part:

[OnlineSubsystem]

DefaultPlatformService=GooglePlay

to

[OnlineSubsystem]

;DefaultPlatformService=GooglePlay

disabling google play and now the game runs fine on my tablet

It seems you can not (like the topic states) Alpha test the way Google describes it with the Unreal Engine.

I'm yet to make a shipping build and upload it to google without the google play services enabled (as last time even with it Disabled it still didn't work)

avatar image Bobvodka STAFF Jul 16 '15 at 09:35 AM

Setting it disabled does not stop the subsystem coming up - it only stops it trying to talk to the servers which this crash is not related to.

I am, however, becoming confused as to what state things are in when you are posting these things. I need you to slow down and be clear as to what you are doing. In this instances I have no idea what the state of the build is (debug? release? development?), the build output or the runtime output. Trying to debug from logs means I need this information provided clearly - I understand this is frustrating however throwing posts at me devoid of information isn't going to get an answer any quicker.

avatar image KillerSneak Jul 16 '15 at 10:12 AM

I'm sorry for this (I thought I was clear enough)

The above is from launching from the UE engine to the device, I edited the ini file described afterwards to disable the GooglePlay services, then the game worked on the tablet.

Ill be more clear once I have done some more troubleshooting later today. Sorry for posting in the wrong manner.

avatar image Bobvodka STAFF Jul 16 '15 at 11:06 AM

As a test can you try deleting the folders;

\Intermediate\Android \StagedBuilds \Cooked\Android

That'll clean out any lingering files which might help things out if this is a strange build config problem.

avatar image KillerSneak Jul 16 '15 at 11:18 AM

I did so already, it seems Google Play Services is the main problem.

I can build shipping -> for deployment builds and install them via the batch file on my Tablet now when I have unchecked "Enable Google Play Support"

Later today I will upload a build with "Enable Google Play Support" disabled and see if it will work from the store then.

avatar image Bobvodka STAFF Jul 16 '15 at 11:33 AM

Yes, it is the problem the question is why is it a problem for you as I can build a test app here which gets to the point of trying to connect to google play before dying (no app ID so expected), but doesn't show any of the problem you are seeing.

I just noticed the 4.4.4 device is running ART not the normal 4.x run time. What PRECISE version of Android 5 is your other device running?

avatar image KillerSneak Jul 16 '15 at 01:15 PM

Tablet:

Acer Iconia One 7 (B1-750)

Android-version: 4.4.4

Kernel-version: 3.10.20+

Phone:

Acer liquid Z220

Android-version: 5.0

Kernel-version: 3.4.0-g0bfd807

Both stock (not rooted or anything)

I can confirm that a Shipping-> For development build with "Enable Google Play Support" disabled works on both devices by installing the game with a batch file..

avatar image KillerSneak Jul 16 '15 at 08:49 PM

So I managed to get a bit further with a

Shipping-> For distribution build with "Enable Google Play Support" enabled.

inside

\Unreal Projects\Balloony PoP Revised 4.8\Build\Android\res\values\

there's a file \GooglePlayAppID.xml (don't know how it got there or should be there?) and the app_id part was empty

 <?xml version="1.0" encoding="utf-8"?>
 <resources>
     <string name="app_id">750896181789</string> <- should contain your APP ID !
 </resources>

I added my APP_ID there and I added a list of all achievements and leaderboards called game-ids.xml (like google play services describes)

I can now install the game and run it one time where it logs me into google play services but still crashes.

See the following log file of the local install + login

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/1607215_2244/StartAndCrash.txt

avatar image Bobvodka STAFF Jul 17 '15 at 09:21 AM

That file is updated/setup when you configure the application for Google Play, which you said you'd done already when I asked you a day ago? This is the same part of the editor which you can use to setup achievements and leader board information.

So, to ask again, have you setup the application correctly for Google Play support via the Project Settings -> Android section? Because it sounds like you haven't.

As for the test; which device was this run on? The logs mention 'Dalvikvm', but previous logs from the phone and tablet are both using 'ART'. Is this the same device or devices you tested on before? Or is this a different one? If so what device is it and what is it running? Is that also the raw log? Android logs tend to contain a lot more than that and I'd rather see a raw log. If you are not already doing so then I recommend capture logs by using a command window to run 'adb logcat > log_file_name.txt' - running this just before you start the app and existing via Ctrl-C just after it closes/crashes (once you have dismissed the crash box).

avatar image KillerSneak Jul 17 '15 at 09:56 AM

I did the file doesn't always write your ID in there. I had to check and un-check the "Enable Google Play Support" a few times to get the ID to show up or fill it in manually (maybe a BUG?)

Trust me when I say everything in the editor is set up as it should, you make it sound like it's not setup right and I'm not willing to discuss this each few comments Bobvodka

I released a game to the app store with 4.2 or 4.4 of the engine and followed the exact same steps it's not the problem.

I have uploaded all the logs I can and lost more hours on logging and talking here than actually building the game in UE4.

I don't want to sound rude but ever since the engine is making the manifest / signing file automatically things get screwed up. I'm thinking about reverting to a pre 4.6 engine release so I can do it all manually again so I know for a fact that it will work.

We know for a fact that google play services is causing a crash, something that shouldn't happen in the first place.

If the developers / coders would actually build in a Google Login button (blue-print) maybe all this could be tested more easy. By pushing a button to login instead of the auto login.

avatar image KillerSneak Jul 17 '15 at 10:02 AM

I will do one last test run later today and upload all kinds of logs for the last time as this seems to go nowhere. I also offered you access to the whole project if needed so you can have a close look at the project itself.

All goes well and runs with google play services disabled, as soon as it's enabled the game crashes after the logging into Google Play Services

avatar image Bobvodka STAFF Jul 17 '15 at 10:29 AM

if you can share the project files via google drive or some such then the email address which should work is .

avatar image KillerSneak Jul 17 '15 at 12:43 PM

Don't think it's needed anymore, after more bug testing in the morning I now have a build on the app store that does work when I don't sign in to "Google Play Services" (where it asks for the rights etc the first time you start the app).

If I do choose to sign in it crashes at a point where I think I start the [Poll Achievements] and [Force Achievements Update] (borrowed from Tappy Chicken).

I think polling / going through 104 achievements and 3 leaderboards is to much.. I will do more testing by adding more delay between the [Poll Achievements] and [Force Achievements Update]

Is there any way to use the Print String -> to log to actually show in the logs somewhere? The project is a Blueprint only project so I can't use debug builds and am stuck with development or shipping builds.

If I can some how get the print string to show in a log somewhere It would be more easy to trouble shoot.

Again I'm not sure if the polling / force achievements part is the actual part where it crashes but ill do some more testing and keep this topic/you updated.

Hope you can tell me how I can get print string to show up in logs?

avatar image Bobvodka STAFF Jul 17 '15 at 12:55 PM

If you expand the 'print string' node it has an option to output to the log. We might however be suppressing log output in a release build.

avatar image KillerSneak Jul 17 '15 at 08:49 PM

So even with the polling disabled and just letting the game login there seems to be a bug with UE4 concerning the

 07-17 22:42:22.540: E/dalvikvm(18561): JNI ERROR (app bug): local reference table overflow (max=512)
 07-17 22:42:22.540: W/dalvikvm(18561): JNI local reference table (0x7245a018) dump:
 07-17 22:42:22.540: W/dalvikvm(18561):   Last 10 entries (of 512):

So it's not clearing / cleaning local references as it should? See the below log: I'm at a loss here:

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/17-07-2015_2242_Login_Only.txt

I didn't save your e-mail so I can't send you the project via drive.

The above log is on my tablet as you can see in the log:

07-17 22:42:07.420: D/UE4(18561): Android version is 4.4.4

07-17 22:42:07.420: D/UE4(18561): Android manufacturer is Acer

07-17 22:42:07.420: D/UE4(18561): Android model is B1-750

07-17 22:42:07.420: D/UE4(18561): OS language is set to nl_NL

So it's not the achievements polling or updating, it seems the "local reference table has an overflow issue" although I could be wrong it it's not the main issue.

Hope the new log will shed some light.

It's a development build installed locally via the batch file. And yes google play services is setup right linking 2 apps (shipping and Debug with the default android key that a development build uses to access achievements testing.

EDIT: same thing happens on the phone (android 5.0) poll game center and achievements update are enabled in this log, but causes the same error

07-18 00:00:30.712: D/UE4(21258): Android version is 5.0

07-18 00:00:30.712: D/UE4(21258): Android manufacturer is Acer

07-18 00:00:30.712: D/UE4(21258): Android model is Z220

07-18 00:00:30.712: D/UE4(21258): OS language is set to nl_NL

http://dnatoxicgames.com/development/balloony-pop-revised/epic-logs/18-07-2015_0003_Phone.txt

avatar image Bobvodka STAFF Jul 20 '15 at 09:30 AM

OK, so it looks like the references problem might be an engine bug; chances are a large number of achievements haven't been tested and we are doing something wrong so I'll see what can be fixed there.

If you still want to share the project then the email address is

avatar image KillerSneak Jul 20 '15 at 11:10 AM

Nice, let me know.

I'm runnig a blueprint only project but if needed I'm willing to take a step into porting/migrating it to a code project.

You can delete your e-mail from your comment now just in case a spam/bot get's it. I have noted it down this time.

Ill upload my whole project to drive once I'm home and send you an invite/share link for it.

avatar image Bobvodka STAFF Jul 21 '15 at 06:54 AM

It is looking less of an 'engine bug' and more of a case of 'unintended interaction' going on here; a fix might take a little while as it might require a rethink/rewrite of how we interact with Java from C++ to prevent this problem.

avatar image KillerSneak Jul 21 '15 at 12:02 PM

Okay maybe look at some code from the 4.3 version engine then. As I had 103 achievements with a released game and it doesn't have any issues on loading / unloading them. I really think it's something simple as not destroying/clearing an local reference after creating it

DeleteLocalRef on the cls reference should work when getting the achievements (after reading a lot on the Inet)

http://stackoverflow.com/questions/11109497/android-jni-error-app-bug-local-reference-table-overflow-max-512

http://jaljale.com/blog/titanium-appcelerator-crossing-the-bridge-dalvikvm-jni-error-app-bug-local-reference-table-overflow-max-512/

http://stackoverflow.com/questions/17033438/android-expand-jni-local-reference-table

If you can point me in the right direction with a code project as where the achievements get cached I can have a look at it myself and see if I can get a local fix working

avatar image Bobvodka STAFF Jul 21 '15 at 12:16 PM

Since 4.3 the way we deal with achievements has completely changed to use a Google library. The problem is caused by an interaction between how we deal with JNI and the library. There isn't a quick and easy fix for this as it is a fundamental issue which requires some rethinking and rewriting of that interaction layer.

avatar image KillerSneak Jul 21 '15 at 12:25 PM

Okay so for now it's not possible/useless to release/build a game with achievements.

Well at least we found the source/problem (I hope)

If there is anything else you need please let me know.

avatar image Bobvodka STAFF Jul 21 '15 at 12:27 PM

It seems to be part of your problem yes; it might not be related to others but one thing at a time I feel.

I should let you know that a fix is unlikely to make it until 4.10 due to timing with the planned 4.9 release date. Depending on the extent of the fix I might be able to get it moved up however at this point I wouldn't like to give an false impression of when it will make it out.

avatar image KillerSneak Jul 21 '15 at 12:52 PM

Thanks for the update, for now Ill start working on a new project and see what happens when I only add 5 to 10 achievements.

avatar image Bobvodka STAFF Jul 30 '15 at 11:31 AM

Is there any chance you can give me some more details (screen shot or project access?) as to how you are querying and setting up things when this happens.

I've got a local test application with 110 achievements (title + description only) and using 'cache achievements' and 'get cached achievement progress' to get and loop over them (much like how Tappy is doing so) isn't causing things to crash out.

avatar image KillerSneak Jul 30 '15 at 04:44 PM

Ill upload the project to Google drive and send you the link when I get home later today.

I have the same setup as tappy as well with the only difference that I have more progress based achievements ( the ones that show how many % you have done before unlocking)

Ill also post some screenshots once I get home.

avatar image KillerSneak Jul 31 '15 at 10:26 AM

From my 104 achievements 57 are Incremental achievements, and as far as I can see from the crash logs these are the achievements causing the:

 07-31 12:21:38.247: E/dalvikvm(29394): JNI ERROR (app bug): local reference table overflow (max=512)
 07-31 12:21:38.247: W/dalvikvm(29394): JNI local reference table (0x7220d170) dump:
 07-31 12:21:38.247: W/dalvikvm(29394):   Last 10 entries (of 512):
 

Error, I don't know if they are handled differently from normal achievements or not (in UE4).

avatar image Bobvodka STAFF Jul 31 '15 at 10:28 AM

We don't do anything different that I can see; however based on the call stack the error seems to be coming from inside a Google supplied library.

Hopefully the supplied project will let me get to a point where I can repro it and thus get things fixed.

avatar image KillerSneak Jul 31 '15 at 04:57 PM

It's hard for me to understand why it's "working" for you locally,

I updated the old 4.3 original project "Balloony PoP" to 4.8 and recompiled it with the new 4.8 engine, uploaded it to Google play

https://play.google.com/store/apps/details?id=com.epicgames.BaloonyPoP

And yet again it fails after the Google play services login. The 4.3 version worked fine. So it's hard for me to believe that it's an error on my side as going from 4.3 to 4.8 went without problems except for redoing the "Set Text" blueprint nodes, I left all other things intact and filled in the new 4.8 project settings (keystore / etc)

So I can now certainly say it's not an error on my side but really an error with 4.8. So I would love to know how you get it working with a 4.8 engine build and 100+ achievements.

I now have to re-compile the project yet again with 4.3 when I get home and re-upload it.

EDIT:

  1. preview still has the same issues. Even with the new sign in blueprints that let you sign in manually. Although I love the feature and UE4 actually complies with the google "rules" now (not signing in automatically) it's a shame it still crashes after signing in (haven't done logcat yet, but I guess it's the same issue)

avatar image Bobvodka STAFF Aug 03 '15 at 10:43 AM

Yeah, it is very confusing. I'm hoping it is just a setup difference between my simple test case and your game, which is why I asked for a copy of it.

Hopefully now with both I can figure out why I can't reproduce it and in doing so find a fix for it - the only fundamental change to how it works has been the introduction of a Google Library between 4.3 and 4.8 to handle achievements, which is the source of the problem in the stack trace in the logs.

avatar image KillerSneak Aug 03 '15 at 02:49 PM

Thanks for the update. Like I said going through the error's it seems that the Incremental Achievements are what's making it crash.

catch 100 zebra balloons etc (0 to 100% - 100 balloons must be popped) I have 50+ incremental achievements set up for the game Maybe there's a limit?

avatar image Bobvodka STAFF Aug 03 '15 at 02:59 PM

No, I don't think it's a limit like that, I think we are just interacting badly with a Google Android lib (it expects to be used in a certain way, we aren't doing that), which might even be fixed in a later version, however until I have a reproduction case that can't be tested.

avatar image Bobvodka STAFF Aug 03 '15 at 02:31 PM

Can I ask how many entries you have in your leader boards?

As with 110 achievements being cached, queried and updated I can't create the problem, however it looks like leadboards get updated first, so I'm wondering if maybe that is factoring in to things in some way.

avatar image KillerSneak Aug 03 '15 at 06:51 PM

I have 3 leader boards setup, one for each difficulty level (Easy Normal Hard) Although it was already producing the above error's when I only had one.

As you can see from my project It's an copy of the Tappy Chicken achievements (at least the blueprint setup).

I could make a new build where I hook up the leaderboards caching to once the button is pressed.

EDIT: Still crashes for me with 4.9 Preview1 even with all LeaderBoards related entries disabled (PollGameCenter - not running in blueprints)

Still crashes when ever I start the game on my Tablet.

EDIT 2: So same issue with 4.8.3 even if I unhook all the "PollGameCenter" nodes so it doesn't check the leaderboards. Make me believe that it's actually not the Blueprint nodes functions but the entries for the engine itself in the project settings "Achievements Map" / "Leaderboatds Map" I'm making a new build that doesn't map them as everything is already mapped in the blueprints as well (Tappy Chicken Way).

Ill let you know what happens

EDIT 3

on 4.8.3 even without the achievement and leaderboards maps in the project settings it still crashes with the same issues.

EDIT 4

On 4.9 preview 2 the issue remains. Also without leaderboards polling. Again I think it's the mapping in the project settings itself that is handled wrong and not the blueprints setup.

EDIT 5

maybe this will help:

http://jaljale.com/blog/titanium-appcelerator-crossing-the-bridge-dalvikvm-jni-error-app-bug-local-reference-table-overflow-max-512/

http://stackoverflow.com/questions/11109497/android-jni-error-app-bug-local-reference-table-overflow-max-512

EDIT 6

Changed all incremental achievements to normal achievements and still have the same issue. I'm totally out of ideas now.....

avatar image KillerSneak Aug 04 '15 at 07:20 PM

EDIT 7

It does seem the leaderboards aren't read

08-04 21:13:23.428: D/UE4(16803): [2015.08.04-19.13.23:439][52160]LogBlueprintUserMessages: [BP_MainGame_C_1] Leaderboard Update Failed (HARD)

08-04 21:13:23.428: D/UE4(16803): [2015.08.04-19.13.23:440][52160]LogBlueprintUserMessages: [BP_MainGame_C_1] Leaderboard Update Failed (NORMAL)

08-04 21:13:23.428: D/UE4(16803): [2015.08.04-19.13.23:441][52160]LogBlueprintUserMessages: [BP_MainGame_C_1] Leaderboard Update Failed (EASY)

I also noticed google hands out achievments and leader boards with the same code strings but the case sensitivty is different.

CgkIneSZp-0VEAIQAg - achievement

CgkIneSZp-0VEAIQag - leaderboard

CgkIneSZp-0VEAIQAw - achievement

CgkIneSZp-0VEAIQaw - leaderboard

avatar image Samantha Sutton ♦♦ STAFF Aug 06 '15 at 09:34 PM

Hey KillerSneak,

I've informed Bobvodka of your reply. It may be a couple of days before you hear back. I will update you if I'm updated first.

Thank you. :)

avatar image KillerSneak Aug 07 '15 at 08:49 AM

Thanks for the update. Hope we can get this resolved soon.

avatar image KillerSneak Jul 23 '15 at 04:08 PM

Is this reported as a bug now so I'm able to track it? Or will you just keep updating this topic? I would like to keep on top of this if possible.

avatar image KillerSneak Jul 31 '15 at 09:17 AM

I have send you the e-mail to the google-drive share. You should be able to download the source now.

avatar image KillerSneak May 05 '16 at 12:42 PM

So I have been away for some time and would like to know if 4.11 has fixed the issues? The main issue being you can not have more than 100 achievements.

avatar image Samantha Sutton ♦♦ STAFF May 11 '16 at 08:54 PM

UE-19190 is being worked on currently. It's set as a priority 2 bug, which is considered major. We do not know when it'll be released yet.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question