x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Camera toggle not working in Standalone mode

Hello, I'm new to the UE engine and I am currently watching a ton of video tutorials in order to learn how to use it properly and I face my first problem.

I followed this tutorial in order to make a toggle switch between the third person camera and a first person camera. However when I use the Standalone Game mode in order to test it, the toggle isn't working at all as if the blueprint isn't included.
Everything is working fine in the PIE and I can't understand why this isn't working in Standalone Game.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 07 '15 at 03:01 PM in Using UE4

avatar image

Hask
1 2 4

avatar image rjvm Jul 07 '15 at 04:33 PM

in the camera options set auto ative one camera and other set no auto

alt text

camera.png (160.5 kB)
avatar image Hask Jul 07 '15 at 06:08 PM

I changed it as you said, I have two outputs :

  • The Third Person Camera only is auto activated, nothing change, my toggle don't work

  • The First Person Camera only is auto activated, the toggle is working but not as intended, when I press my toggle button the camera only moves back a bit like the picture

camera.png (805.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

For standalone mode, you need setup auto activate in your cameras.

If FPSCamera first - check Auto Activate in FPSCamera and uncheck in FollowCamera.

If FollowCamera first - check Auto Activate in FollowCamera and uncheck in FPSCameras.

After this, you need set up a toggling for both cameras.

alt text

camswitch.png (242.4 kB)
more ▼

answered Jul 08 '15 at 08:13 AM

avatar image

svv3dUDN
8.5k 254 42 400

avatar image Hask Jul 08 '15 at 12:36 PM

Thanks for the further explanations ! The problem was due to the fact that I didn't setup a toggling for both cameras.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question