x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Disable Eye Adaptation from Widgets Only?

My 3D Widgets are getting darker when i'm outside in lightened area.. i want to keep the eye adaptation for rest of the stuff except 3D Widgets.. So how can i disable it only for 3d widgets..??

I tried it in First Person Character Project.. and its still effecting the widget! Steps i gone through are:-

  • Create new First Person Character Project

  • Create New widget blueprint and add a button and text inside it (button default, text pure white)

  • Fill canvas panel with button and set text size to 3000

  • In First person character BP.. Add new widget component and set it to newly created widget

  • Move it in front of player > Draw size 2000x1000 scale 0.1 , 0.1 > rotate toward player

  • In post processing volume set Auto Exposure max brightness to 10

  • Change Light Source intensity to 500 (just to see the effect clearly)

  • At this point if you play the widget will appear darker, even white text wont look white..

  • But you can also create a shaded area in scene to see how eye adaptation makes the widget go bright again after going inside that darker area!

alt text

alt text

Product Version: UE 4.8
Tags:
widgetdark.jpg (210.0 kB)
widgetlight.jpg (199.4 kB)
more ▼

asked Jul 08 '15 at 10:24 AM in Rendering

avatar image

VeerChidar
143 30 33 94

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

FYI what you are asking for is not really possible so I have closed this request. You cannot disable select post process effects for select pixels on the screen nicely. Post Process affects the entire screen. Our plan is to allow 3D widgets to render after post process because it is unlikely you want any of the post effects to be applied to widgets. Please keep in mind that 3D widget drawing is experimental because we do not feel it is up to quality bar yet. This post processing issue is one of those reasons.

more ▼

answered Jul 14 '15 at 03:26 PM

avatar image

Matt STAFF
451 11 4 8

avatar image Rudy Q ♦♦ STAFF Jul 14 '15 at 01:59 PM

Hello VeerChidar,

I have written up a feature request ( UE-18585) to allow users to have objects opt out of this feature. I have sent this report to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Edit: Feature request was canceled see above answer

Make it a great day

avatar image zaksi Oct 03 '17 at 09:35 AM

This maybe an old thread but still relevant. Is there any news on making the 3D widgets render after the post process??

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Also having this problem. I find it hard to believe that many people are not experiencing this too... The only way i could find to work around it was to

1) turn the opacity way down on everything in your umg to about 0.2 (if your umg is translucent and against a black background). You could also turn the brightness down but that interferes with the colors.

2) put a PostProcessing volume in when you are viewing your 3d umg. Set your Bloom to 0.05 or lower, and you can also mess with the Min/Max brightness and speed up values for Auto Exposure.

3) setup a timeline to crank up the light intensity (of the lights in the backgroun) at a speed that matches the auto exposure adjustment. The way i have it setup, the background exposure doesn't look like it changes, and the foreground 3d umg looks good.

Granted i no longer have a working Bloom for the lights in the background while viewing my monitor.

before:

alt text

after:

alt text

Thought i'd offer my workaround. Good luck!

before.jpg (41.8 kB)
after.jpg (60.5 kB)
more ▼

answered Sep 12 '15 at 03:02 PM

avatar image

rob.never9
36 1 4 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question