x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Install Android development build without USB connection

I'd like to send an .apk to a friend, who is not a developer in any way, to test my development build on their device. I've successfully launched the game on my device via adb. I've also successfully created the .apk with .obb and .bat as well. I know the .bat can be ran to install, providing you have the Android SDK and all, and are connected via USB, but I want to be able to send them one file to install. Obviously, I don't have the app on the app store, so they can't get it from there. I'm used to creating an .apk from eclipse/Android Studio that can be directly installed as an app (for example, I can email it to anyone to install). Trying this would not work though, since it can't get the OBB. I tried the options "Package game data inside .apk" and "Disable verify OBB on first start/update" figuring this would give me one file to install from rather than an OBB along with the APK, but after a full and seemingly successful install, I just ended up with a black screen on launching the app.

Is there any way I can email/upload an .apk for easy download/install without needing the user to connect via USB and have the Android SDK/adb?

Product Version: UE 4.8
Tags:
more ▼

asked Jul 09 '15 at 04:54 AM in Packaging & Deployment

avatar image

BioeJD
18 4 7 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Aug 10 '16 at 05:55 PM by Steve Hardister for the following reason:

Problem is not reproducible or outdated


1 answer: sort voted first

Hi!

I would recommend you use APK+OBB. It is more stable.

Before install, you need enable "unknown sources".

http://www.ubergizmo.com/how-to/how-to-install-apk-files-sideloading-on-android/

For manually install without adb and USB, you need to do the following:

1 Open in file browser sdcard0/Android/obb and create folder with name like your OBB.

For example, my OBB file has a name main.1.com.YourCompany.Test48.obb and I create a folder with a name main.1.com.YourCompany.Test48

2 Copy in this folder OBB and APK and start APK. Choos use Installer. After the installation, start your app.

more ▼

answered Jul 09 '15 at 11:48 AM

avatar image

svv3dUDN
8.5k 255 43 400

avatar image BioeJD Jul 09 '15 at 03:40 PM

For sideloading, I already did enable "unknown sources" in my first attempt. As mentioned in my question, it seemed to have installed successfully, but opened as a black screen (may be the instability issue you referenced).

For the manual install, I did that via file browser on my own device successfully, but I was hoping to make it extremely simple for the user receiving the files.

Are there other methods of distribution to "test" users that would be virtually one-click type installs? Can I do private alpha release on one of the app stores or something?

avatar image Arjo_5 Apr 05 '16 at 11:06 AM

Hey im having the same problem here... and i dont know how to solve it... in the main name says its already solved but i dont see the solution here, did u find it out how to do it by yourself? can you share how to do that with me?

Tahnks a lot!

avatar image Steve Hardister ♦♦ STAFF Aug 10 '16 at 05:55 PM

Hi Arjo_5,

Due to the large volume of questions and comments concerning the Engine, we did not have a chance to respond to your post at the time you submitted it and, thus, the issue is now outdated. If you are still experiencing this issue in the current release of the Engine, please make a new post for assistance.

Steve H.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question