x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Landscape seams visible

Hello,

I created a landscape and applied a very simple shader but I can see the different chunks they seem to have different illumination properties : alt text

Could someone point me to the settings I need to change to remove the visible seams ?

Thanks a lot, Max

Product Version: UE 4.8
Tags:
more ▼

asked Jul 09 '15 at 10:17 AM in Rendering

avatar image

yamashi
3 1 3 6

avatar image Logan Bailey ♦♦ STAFF Jul 09 '15 at 02:01 PM

Hello yamashi,

So before you build your lightmaps, assuming that you are using static lighting, you will see seams on the landscape where the grid tiles. Under the option build at the top of your HUD change the lighting quality settings to production and then build lighting only. This should go away.

Logan

avatar image yamashi Jul 09 '15 at 02:02 PM

The picture above is a production quality after building the lights, that's why I am concerned :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey yamashi,

I have recreated what you are experiencing inside of UE4. Whats happening is the static light maps in your scene are creating some artifacts where the terrain has seams. Unfortunately there is no way to hide these seams like you would on an imported mesh where you can choose where you want the seams to be. When you use static lighting, the maps and shadows are baked onto whatever the light or shadow is being cast on. Wherever you have seams there will always be a slight amount of artifacting because the lightmap is trying to calculate a space that essentially has no RGB information. Thats why in games/movies there are different techniques used to hide these from the viewer/player. The quick fix is to change your lighting setting in whatever lights you have in the scene.

Best quality for reducing lighting artifacts is movable, medium stationary, and worse static.

Try changing your lights to movable and bake them out again.

Logan

more ▼

answered Jul 09 '15 at 02:45 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question