x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launcher crash while updating

Hello! I have a really odd problem. I was using UE4 and nothing strange happened. So far!

Since the last update (4.0.2) my launcher crashes. To be specific: It downloads everything, takes a bit time, but works. After that at 90% the text changes to "Verifying Installation". The launcher is working, I can stop and pause any time, but after like one hour of processing it crashes with this:

alt text

I have no idea what could this mean. This never happened before, everything was running smoothly (except when I opened Blueprint, It takes some time to load that up, but it works every time.)

I already tried reinstalling UE4, didn't help. I'm using Windows 8 Pro.

Thanks for any help!

Product Version: Not Selected
Tags:
error.png (389.4 kB)
more ▼

asked Apr 06 '14 at 07:40 PM in Installation & Setup

avatar image

CREFFER
1 4 5

avatar image Stephen Ellis ♦♦ STAFF Apr 06 '14 at 08:01 PM

Hi CREFFER,

We haven't seen this issue before.

  • Can you confirm that your Launcher is version number 1.0.0-2039063? (found in the bottom-left corner)

  • Have you already tried restarting your computer?

  • Please upload the log, in a Zip file, from C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs

Thanks

avatar image CREFFER Apr 07 '14 at 02:01 PM

Hello!

Yes, my launcher is version number 1.0.0-2039063. I tried restarting my PC, didn't help.

Today I gave it another try. Something strange happened: alt text

As you can see my version is correct. I started the update; Then it crashed with that error message. I assumed Betrayer.exe belonged to a game called Betrayer. It was made in UDK, I played it in the last few days. It wasn't running, it's not intalled on my PC anymore.

My logs: link text

logs.zip (346.5 kB)
crash.png (250.9 kB)
avatar image CREFFER Apr 07 '14 at 05:30 PM

After another reinstall, It gives me the error it did first time, this is what happens: alt text

My log this time: link text

logs.zip (376.9 kB)
error 2.jpg (374.3 kB)
avatar image leighswift STAFF Apr 08 '14 at 08:17 AM

Hi Creffer! Just wanted to let you know I am looking into your issue now. In the meantime, it would be helpful to see a dxdiag from the system you are running on if that is ok?

avatar image leighswift STAFF Apr 08 '14 at 10:23 AM

Update: I'm still looking into the crash you are seeing, but I have noticed something I want to warn you about in advance. Some of your logs contain examples of output that suggest a device problem. I'd recommend - just in case - backing up any important data you have on your machine. The output suggests potential issues with drive E:. I'm not saying there's definitely a problem, but I have not seen those in other peoples' logs before and it would be a shame if you lost any data.

In more detail, there are some file copy issues that report Windows Error Code 1117 (ERROR_IO_DEVICE), and also some file read issue that report "Error=I/O eszközhiba miatt nem lehetett a kérést végrehajtani."

avatar image CREFFER Apr 08 '14 at 02:09 PM

Hi Swifty!

I think the easiest way might be to reinstall my whole Windows. If there is no other way, I might do that on the weekend. Oh yeah, here is my dxdiag. Thanks for your time! link text

dxdiag.txt (74.4 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Thanks for that. If you are not having problems with anything else, there's probably no need to reinstall windows :). Especially if you were able to install and use Unreal Engine 4.0.1 just fine. I haven't managed to find the root of the issue yet. But if you like one thing you could try is to make sure the Launcher tries to install the latest editor as a fresh copy:-

  1. Close the Launcher

  2. Delete the folder "E:/Program Files/Unreal Engine/Launcher/PatchStaging"

  3. Delete the folder "E:/Program Files/Unreal Engine/4.0"

  4. Delete the file "C:/ProgramData/Epic/UnrealEngineLauncher/Data/Manifests/40003.manifest"

  5. Run the Launcher again

  6. Press the Install button

more ▼

answered Apr 08 '14 at 02:31 PM

avatar image

leighswift STAFF
1.8k 38 136 42

avatar image CREFFER Apr 08 '14 at 03:37 PM

Thanks for the answer. I deleted PatchStaging, I still need to delete the 4.0 folder, but I can't do that somehow. It starts up the deleting process, but when the window closes it's still there. Oh well, I'll figure out something!

avatar image leighswift STAFF Apr 08 '14 at 03:39 PM

Hmm that is odd! Can you rename it instead?

avatar image CREFFER Apr 08 '14 at 03:40 PM

Yeah I can!

avatar image leighswift STAFF Apr 08 '14 at 03:42 PM

Ok, might be a workaround for now then! Don't forget step 4.. And then try the install!

It might be good to check TaskManager for any rogue exe from editor/launcher that is stuck running, probably unlikely though

avatar image CREFFER Apr 08 '14 at 06:11 PM

Yay! That solved it finally, thanks for your help! :)

Edit: Holly cow, What else, It fixed the BluePrint loading time too! Many thanks!

avatar image leighswift STAFF Apr 09 '14 at 08:12 AM

Great news! Glad you're up and running again. Remember to keep an eye on that E: drive of yours, it still concerns me a little that you were having so many device IO errors :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question