x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Light as if Static" don't save with scene

How to reproduce:

1.Place moveable object at scene

2.Check "Light as if Static" flag

3.Save scene, restart editor. After editor start, "Light as if Static" flag is unchecked on object.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 10 '15 at 05:57 AM in Bug Reports

avatar image

BorodMorod
137 14 19 23

avatar image Logan Bailey ♦♦ STAFF Jul 15 '15 at 09:21 PM

Hey Borod,

I haven't heard from you for several days.

Are you still experiencing this issue or has it been resolved?

Thanks, Logan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey BorodMorod,

I have attempted to reproduce the issue you are experiencing. I was unable to recreate the flag becoming unchecked upon relaunch.

There are a few bits of information I would like to get from you so I can track it down.

  1. What operating system are you on? Max or Windows?

  2. What are your specs? Video Card? Etc?

  3. Are you sure you are going through all the steps like the ones above? You haven't switched on any settings in the world settings or currently have something switched on inside of the project settings?

  4. Try a new blank project with no starter content and attempt to recreate.

After I have all of this it should narrow down the possibilities.

Thanks, Logan

more ▼

answered Jul 10 '15 at 01:55 PM

avatar image pax invictus Jul 15 '15 at 08:53 PM

I am experiencing this too. It happens when there are multiple static mesh actors referencing the same static mesh. It might have something to do with how the actors and the mesh are named. For example, if I have a static mesh called SM_Door referenced by actors Door, Door_01, Door_02, then Door would fail to preserve Light as If static, whereas the rest would have it on even after reload. Everything about those actors is exactly the same, except for their name, location and orientation. This is at least what my initial observations were, but I may not be remembering correctly and right now I can't verify.

avatar image pax invictus Jul 15 '15 at 08:56 PM

To add a little more detail, this started happening on 4.8, and is still an issue after the upgrade to 4.8.2.

avatar image Logan Bailey ♦♦ STAFF Jul 15 '15 at 09:07 PM

Hey Yanko,

If you would like to make a post in the bug report section then I can certainly look into this matter for you.

In the case of Borod, I would like to eliminate the possibility of it being an error on his end.

Thanks, Logan

avatar image pax invictus Jul 15 '15 at 09:22 PM

Thanks for your response Logan! From what I gather, I am experiencing the exact same issue as BorodMorod. I am adding this information mostly to try and help you resolve the problem. I'll keep an eye on this one, and if it turns out it is indeed user error, then I'll create a new bug report. Let me know if that sounds sensible and if there's anything else I can do to help push this forward.

avatar image Logan Bailey ♦♦ STAFF Jul 15 '15 at 09:30 PM

I appreciate that. That will allow me to recreate a test scene with these specifications.

The best thing for you to do is to open up another post so I am able to specifically handle the issue you are experiencing.

Thanks again, Logan

avatar image pax invictus Jul 16 '15 at 10:19 PM

Posted as a new question here

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question