x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Particle system scaling issue

I'm having issues with scaling in particle systems. I've made a flame thrower particle system, basically, using spheres and stretching them as needed, which resulted in this;

Image https://drive.google.com/file/d/0BxJkHJNJnNIpZlNEWXBnNWtiTjg/view?usp=sharing

however, it only works when pointed along the X axis. if i turn it, it looks like this;

Image https://drive.google.com/file/d/0BxJkHJNJnNIpa2tDejc3eHhRTDQ/view?usp=sharing

It seems the scale for the meshes doesn't rotate with the actor. I was wondering if there was a fix, or at least a workaround for this.

Thanks in advance for anyone who can help, and in case it matters, here's the modules used in the particle system.

image https://drive.google.com/file/d/0BxJkHJNJnNIpaEFlMjN2Q1FOQW8/view?usp=sharing

Product Version: UE 4.7
Tags:
more ▼

asked Jul 11 '15 at 12:07 AM in Using UE4

avatar image

Traviesimo
1 1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Traviesimo -

You will need to go into the Mesh Type Module in your Emitter and set a locked axis for the mesh, so it knows to not rotate about that particular axis.

Thank You

Eric Ketchum

more ▼

answered Aug 05 '15 at 06:27 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image iLegacy Aug 14 '17 at 04:26 PM

SOLVED:

  1. Mesh must Point Z in 3Ds Max (aligned with the ground)

  2. Required Node: Screen Alignment: PSA Type Specific

  3. Mesh Data: Face Camera with Roll or Spin / Axis Lock Option: Z / [X] Camera Facing / Velocity Aligned (any of the 4 options work) / Apply Particle Rotation as Spin

I have another issue regarding mesh particles and scaling.

Here you see my little circle-meshes. They work well until I SCALE the Particle System. All the particles are now squashed:

Options (since the mesh is already aligned horizontally, i don´t need any lock-axis or camera-facing options):

Mesh Data:

  • Mesh Alignment: Face Camera With Roll

  • Axis Lock Option: None

  • Camera Facing: Disabled

Required:

  • Screen Alignment: PSA Square

Note: Even setting the Required-Screen-Alignment to PSA Type Specific and in Mesh Data setting Axis Lock Option to Z doesn NOT help.

Only when I use Camera Facing the particles are NOT scaled anymore - but then they are not locked anymore so that they stay aligned with the ground.

alt text

As a comparison: Using normal particles (with a axis lock) it looks like that. The spawn-area gets scaled but NOT the particles themselfes:

alt text

Does anyone know how to prevent the mesh-particles from scaling?

avatar image iLegacy Aug 15 '17 at 04:45 PM

Here's a tutorial about this issue: https://youtu.be/W1LmTMH-XVI

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question