x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

SceneDepth Blendable ignores translucent objects

Hi All,

I'm trying to render a depth pass for my matinee image sequence export for further post-processing in a compositing app. I set up a Post Process domain material and applied it as a blendable, then attached the SceneTexture:SceneDepth node to the output. This works pretty well for rendering a depth map.

However any object with a translucent material does not show up in the depth map at all. That means things like leaves which use image maps as cutouts disappear entirely. So in the end it is not usable. Is there something obvious that I am missing here that would make this work?

I've already tried all the Blendable Location options.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 10 '15 at 11:56 PM in Rendering

avatar image

jstarrdewar
191 6 10 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi jstarrdewar -

Translucent Objects are treated in a different pass of the rendering thread than the Opaque Objects. If you are only rendering out the Depth Pass for a separate application I would recommend temporarily making the objects opaque for your depth pass then revert for other passes. Alternatively you can place the Translucent Object in a Blueprint, duplicate the object and assign an opaque material to it and in the rendering options of the mesh's details panel uncheck Render in Main Pass and Check Render in Custom Depth. By doing this the opaque object will not be rendered in the final scene but will be rendered in Depth Passes.

The one limitation is you will never get a Depth Rendering through a Translucent Object, but in most cases this is unimportant to depth maps.

Thank You -

Eric Ketchum

more ▼

answered Jul 16 '15 at 02:10 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image gardenlee_27 Mar 11 '17 at 11:31 AM

Hi Eric, I can render an object into Custom Depth, and that object will not appear in the final scene. But I can not access Custom Depth when shading an opaque object. Is it possible to pre-render sth (just) into depth buffer and access that buffer in main rendering pass? I am in this trouble for a long time. Thanks a lot.

avatar image acajic Sep 19 '18 at 08:59 AM

Are you Ash Ketchum's brother?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question