x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Custom Camera In Network

Hello All,

I have created a custom camera in blueprint. I add the Camera Blueprint to the scene. When I start the game single player the Camera Blueprint is working great. However, when I start in network the camera on the server is working as normal but the Client is only showing the default camera which Is at the origin.

I have no replication on the Camera Blueprint hoping that this would be available for every scene when joining a Server.

I have also tried Creating a Camera Blueprint in the controller and setting the "Set View Target With Blend" node but this also fails.

I know I'm missing something on the way UE Cameras work.

Currently I've only tried using the "Set View Target With Blend" not sure if there is any other nodes I could use.

I will keep trying various methods and reading more on the docs to see if I can figure this out, however, all suggestions are welcome thanks.

Regards Lyrical

Product Version: UE 4.8
Tags:
more ▼

asked Jul 11 '15 at 02:10 PM in Blueprint Scripting

avatar image

Lyrical
75 7 8 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After converting the blueprint into C++ I found that the issue was down to the InputComponent->BindAxis when using Binding constant.

I changed to:

 InputComponent->BindAxis("LookUp", this, &AVehicle::SetCameraPitch);
 InputComponent->BindAxis("LookRight", this, &AVehicle::SetCameraYaw);
 

This cured the problem but I would still like to know why I had the issue if possible.

more ▼

answered Jul 16 '15 at 09:27 AM

avatar image

Lyrical
75 7 8 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question