x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Packaging is not working

Hello I tried to build my Project using the Engine in Version 4.8.1. I already searched for this Issue, and people say that u need to create a Keystore file or update the Android SDK - i tried both and none did fixed this issue - then i tried using the Enviroment Variable _JAVA_OPTIONS setting it's Memory to 512Mb and setted it up to 2Gb but it also doesn't helped. Then i thought it may be a problem with Java version 8, so i installed JRE 7. but this also did not help. I have no more Ideas what i could try to solve this problem.

May someone here knows how to fix it.

down below i have a couple of lines from my output log - you can see much more on http://pastebin.com/e9kJxiY1

Output Log

    K\JavaLibs\downloader_library\bin\classes.jar
 -> classes-a49c087ad0ddab592ede1b635801eac0.jar
     **LogPlayLevel:        [dx] Could not create the Java virtual machine.
     LogPlayLevel:        [dx] Error occurred during initialization of VM
     LogPlayLevel:        [dx] Could not reserve enough space for object heap**
     LogPlayLevel: BUILD FAILED
     LogPlayLevel: C:\NVPACK\android-sdk-windows\tools\ant\build.xml:888: The following error occurred while executing this line:
     LogPlayLevel: C:\NVPACK\android-sdk-windows\tools\ant\build.xml:890: The following error occurred while executing this line:
     LogPlayLevel: C:\NVPACK\android-sdk-windows\tools\ant\build.xml:902: The following error occurred while executing this line:
     LogPlayLevel: C:\NVPACK\android-sdk-windows\tools\ant\build.xml:283: null returned: 1
     LogPlayLevel: Total time: 15 seconds
     LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
     LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
     LogPlayLevel: Program.Main: ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args /c "C:/NVPACK/apache-ant-1.8.2/bin/ant.bat" debug
     [...]
     LogPlayLevel: BUILD FAILED
     PackagingResults:Error: Error Launch failed! Unknown Error

Product Version: UE 4.8
Tags:
more ▼

asked Jul 11 '15 at 10:57 PM in Packaging & Deployment

avatar image

Marki217q
6 1 2 4

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I Solved this issue by reinstalling the JDK (Now using Version 8 Upadate 20) - also i reinstalled the whole NVPACK as said above. Then i set all the Enviroment variables (or checked them) and i also setted all the paths in the Project Settings in point "Android SDK". This worked fine for me.

If my answer doesn't help go here: https://answers.unrealengine.com/questions/234817/packaging-problem.html

more ▼

answered Jul 12 '15 at 09:55 AM

avatar image

Marki217q
6 1 2 4

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question