x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Join/Host session

Hi,

I asked this already with no luck.

I followed every youtube video,twitch livestream ( Multiplayer Shootout) and I had no luck with Host and join session.Hosting is working,searching is working but joining is not. Please help :)

Here is my blueprint:

Product Version: UE 4.8
Tags:
more ▼

asked Jul 12 '15 at 06:49 PM in Blueprint Scripting

avatar image

Blue man
181 7 13 19

avatar image eXi Jul 12 '15 at 09:21 PM

First of all, why are you using Replicated Events for the simple Join and Host things? Leave these Events as normal events.

Also Steam is not active in the Editor. When playing in the Editor you are always using the NULL Subsystem.

I would also not use a replicated event to tell the client that he should create the menu, but since this is also working, you can leave it for now.

Try to turn the host and join event to normal events.

And don't use a FOR EACH loop for the find sessions array. Check if the arrays length is greater than 0 and then GET the 0 index to join!

avatar image Blue man Jul 13 '15 at 12:46 PM

I set host and join to Not replicated and this time I did not used For each loop and it did not work.I can see how many players are in session,name of the session but I can t join. Thanks for the help

Edit: I have the same problem with Multiplayer Shootout game. - http://i.imgur.com/40iF7LR.png?1

avatar image eXi Jul 13 '15 at 12:58 PM

Ok let's try to recreate this in a new project.

Please create a fresh project and creste your own GameMode and PlayerController. Then add 2 Key press events, like H and J. Behind H, you simply put the host logic, like creating session and opening a Level (can open the same Level or just leave that out).

Behind J, you search for a session, check if it s > 0 and join the Get 0 of the result Array.

Don't create anything else and don't change anything!

Now start the Game with 2 Players. In the server window (which is normaly the editor one) press H and wait a few sec. In the additional window, press J.

Check if this basic setup works.

avatar image Blue man Jul 13 '15 at 01:24 PM
avatar image Enlo Jul 14 '15 at 12:26 PM

add an print string to the success output pin too or you won't know if it ever runs

avatar image Blue man Jul 13 '15 at 03:22 PM

I think that this is maybe engine bug or something what do you think?

avatar image eXi Jul 14 '15 at 12:23 PM

Hm, if that doesn't work, then this is more or less an error on your end. Because this is the most basic setup and this SHOULD work.

You did not change anything besides the things i told you above, right? So you did not change some config files for the new project?

If the above is really the only thing you changed, then it should work.

I assume you did not forget to actually set the GameMode and PlayerController in the world settings, did you?

avatar image eXi Jul 14 '15 at 12:29 PM

Need to correct something:

Seems to be that new projects are also missing this in the GameEngine.ini file:

 [OnlineSubsystem] 
 DefaultPlatformService=Null 

I am sorry, i though that at least this was in there, because i checked my projects before i answered.

Try adding this to the test project (with H and J).

avatar image eXi Jul 14 '15 at 12:33 PM

Also make sure that you try to create a server with the original server and join with the original client. Because in the Editor, if you start with 2 or more Players, they will directly have a network connection. I had problems in the past when i wanted to let the Client create a server and the Server join it.

avatar image Blue man Jul 14 '15 at 12:41 PM

I will upload a video, I will put link for download becaues I don t have youtube channel.

avatar image Blue man Jul 14 '15 at 03:11 PM

I m not sure if I should make a bug report or if this is something on my end.

avatar image Blue man Jul 14 '15 at 07:30 PM
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question