x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My unreal engine is breaking so annoyed...

I've spent hours on blueprints saved it all last night.. Load up my editor test run my game to check what needs doing and no Ai moves... Confusing so I go into behaviour tree and in red on two nodes "class not found make sure it's saved"... So I'm thinking they have been deleted somehow?! I go into my project folder and they are there?? So I thought it'd be a simple drag and drop them in maybe they didn't get loaded up... "unknown extension "u.asset""... The hells going on? All I did was saved my project last night and load it all back up today and it's randomly corrupting my files?

Product Version: UE 4.8
Tags:
more ▼

asked Jul 12 '15 at 10:00 PM in Bug Reports

avatar image

Scottc91
139 18 19 26

avatar image Scottc91 Jul 12 '15 at 10:18 PM

So I tried to make new blueprints to replace the older ones with the same name and I get this error

alt text

error.jpg (122.4 kB)
avatar image Rudy Q ♦♦ STAFF Jul 13 '15 at 04:37 PM

Hello Scottc91,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps in order to reproduce this issue on our end?

  3. Could you provide screen shots of the blueprints involved?

  4. Have you tried using the back up files that are automatically generated(Default path: C:\Users\YourUserName\Documents\Unreal Projects\YourProjectName\Saved\Backup)?

  5. Are you currently using any source control?

avatar image Scottc91 Jul 13 '15 at 06:00 PM

No its never happened before and not happened since I literally just saved my project closed it down and day later opened it up again and blueprints couldnt be opened but are still in my project folder.. Just not recognised so I've just finished remaking them :\ Yes I tried the back up files the latest ones said the same error so had to use older map file and no I don't use source control but i really should start

avatar image Scottc91 Jul 15 '15 at 06:19 PM

alt text

This is the lovely sight i got when I opened my engine up. The folders aren't even in the project folder they have just been completely wiped.. please get this fixed!!!

message screen.jpg (501.3 kB)
avatar image Scottc91 Jul 15 '15 at 06:25 PM

Just gone through it all.. literally every blueprint or material I edited in the past has deleted it's folder, so ASP_Character, all blueprints folder, Maximo Mortimer folder etc everything I haven't edited or have just used is still there :S

avatar image Scottc91 Jul 15 '15 at 06:41 PM

I thought it may have been git source control deleting everything.... But the files that are still remaining where in my list in the "to commit" list so it would of surely deleted them as well

avatar image Scottc91 Jul 16 '15 at 12:27 PM

Seriously what is going on. I set up source control other night and began uploading everything to the git hub (I was doing it in sections so a folder at a time as it was too big to do at once). I only uploaded four folders the main settings, saved and intermediate... come on today and the whole blueprints folder has been deleted and other assets I was working on?! weeks of work gone! Think its time to say goodbye to Unreal engine not doing weeks of work for it to be deleted over night.. take Some folders and assests are still there... basically the ones I haven't been using everything I have been working on is gone.

avatar image Rudy Q ♦♦ STAFF Jul 20 '15 at 01:46 PM

Hello Scottc91,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

avatar image Scottc91 Jul 20 '15 at 08:46 PM

Verifying and updating the engine may of helped becauae it hasn't happened again but all them files are still lost

avatar image Rudy Q ♦♦ STAFF Jul 21 '15 at 01:21 PM

Hello Scottc91,

Unfortunately if the files cannot be retrieved from the back up files there is nothing we can do to retrieve the lost data. However I am happy to hear that it appears that the solution has prevented further loss of information.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Scottc91,

Usually when dealing with file corruption the first thing that I do is run an engine verification. Could you try verifying your engine and then provide the results. Until then I would recommend creating a copy of the project to help prevent further loss of data.

Steps to verify your engine:

  1. Open the launcher

  2. Click the drop down arrow for the engine version that you are using

  3. Click Verify

alt text

more ▼

answered Jul 16 '15 at 01:43 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

avatar image Scottc91 Jul 16 '15 at 01:55 PM

Well I upated engine version last night so issue may bit better but j will try it when I am home. Luckily I made a copy of the project when I moved from 4.7 when 4.8 came out just lost a few hours work

avatar image Rudy Q ♦♦ STAFF Jul 16 '15 at 05:22 PM

Hello Scottc91,

Please let us know if updating/verifying your engine resolves the issue for you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question