x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fatal Error on Lightning Building

I got this Error

Error === Lightmass crashed: === Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 53] Ran out of memory allocating 991100736 bytes with alignment 0

But i dont have a "D" HDD = D is a DVD rom ..

i dont found to chance the path of this

Product Version: UE 4.8
Tags:
more ▼

asked Jul 14 '15 at 09:10 AM in Using UE4

avatar image

Kosrona
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Kosrona,

The error is that you're running out of memory.

There are a few options you can do to fix this: - Have you tried lowering the lightmap resolution of meshes? - Have you tried adding a Lightmass importance volume around your playable area? (this is not intended to cover significantly large areas) - Have you tried reducing the number of meshes in your scene that need to have lighting built?

These are some thing that can help, but at lot of this depends on your system specs as well. Light building is a very intensive process and can use a lot of RAM depending on the things mentioned above. Alternatively you can try increasing the amount of RAM in your system. If you already have a lot (24, 32, or more GB of RAM), it's possible that static lighting is not something that would work best for this large of a scene.

Thank you!

Tim

more ▼

answered Jul 14 '15 at 02:05 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 877

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question