x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Navigation Mesh Rebuild At Runtime causing 20-40 fps loss

Branch: Binary

Build Version: 4.8.1-2591939

Description: Navigation mesh gets fully rebuilt as soon as the game is played, causing a huge fps drop on a big map with a large nav mesh. With "Runtime Generation" set to "Dynamic".

Repro:

  • Make a large level with a very large nav mesh

  • project settings-> nav mesh -> runtime generation -> dynamic

  • Reload the editor, and make sure the "building navigation" message lasts at least 10 seconds

  • construct a reasonably complex scene that takes the fps below max on your machine

Result: A 20-40 fps drop just after begin play until the nav mesh is fully built. Instead I was hoping the engine could use the initial state of the pre-built nav mesh (like the Static option) and then continue working like Dynamic after that. As opposed to having to rebuild the mesh from scratch.

Notes:

This issue seems to be the exact same as one found a while ago in 4.5: https://answers.unrealengine.com/questions/118670/45-navigation-mesh-rebuild-at-runtime-causing-20fp.html

I've also tried using the new option "Dynamic Modifiers Only" on "Runtime Generation". But wasn't able to get any navigation working at all. Same issue as this unanswered thread: https://answers.unrealengine.com/questions/246236/navigation-fail-with-dynamic-modifiers-only.html

I read the description of "Dynamic Modifiers Only" in: https://docs.unrealengine.com/latest/INT/Support/Builds/ReleaseNotes/2015/4_8/index.html That's all the documentation I could find on it. And it sounds like it's supposed to work exactly like the "Static" option when there are no nav modifiers in the map. But in practice it doesn't work this way and I can't figure out how to use it.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 14 '15 at 07:45 PM in Bug Reports

avatar image

Mastodon
83 6 9 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Mastodon,

After reading over your post I found that the setting "Dynamic Modifiers Only" works with little to no frame rate drop and my characters are able to navigate as expected. However, I was able to reproduce the frame rate drop that you are seeing with the dynamic settings. I have written up a report ( UE-18627) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available.

Make it a great day

more ▼

answered Jul 14 '15 at 09:18 PM

avatar image

Rudy Q ♦♦ STAFF
48.1k 542 125 507

avatar image Mastodon Jul 14 '15 at 09:43 PM

Thank you so much for looking into it.

Could you please direct me to some documentation on how DynamicModifiersOnly works?

For me it just doesn't work: (at least in the way I'm trying to get it to work)

  • Created a new project from the top-down template

  • Changed setting to DynamicModifiersOnly

  • Hit play and can't move

avatar image MieszkoZ STAFF Jul 15 '15 at 10:28 AM

DynamicModifiersOnly mode has been fixed very recently and the fix is not in 4.8. Sorry!

avatar image Mastodon Jul 16 '15 at 07:44 PM

I pulled the latest promoted version and verified that it works.

I think DynamicModifiersOnly will fit nicely with what I'm trying to do.

Thank you for adding this functionality. It makes the nav system a lot easier to work with.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question