x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level select system hud bug

hi I am having trouble with doing a level select feature. I have a simple level select hud. if I play the map normally without the HUD it works fine spline collision works and all. but if I go in level select HUD then select the level my player model goes through the spline. my level select is the correct on click event open level. copied and pasted level name. please take a look at my spline blueprint and see if there is something wrong with thatalt text

Product Version: UE 4.8
Tags:
more ▼

asked Jul 15 '15 at 11:00 AM in Bug Reports

avatar image

j_tan
45 1 2 3

avatar image Rudy Q ♦♦ STAFF Jul 15 '15 at 03:20 PM

Hello j_tan,

I have a few questions that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screens shots of the issue that you are experiencing?

  4. Could you elaborate on the desired result and how that is inverse to what you are experiencing?

avatar image j_tan Jul 16 '15 at 10:48 AM

alt text

I have a level select system which is a level map that on actor begin play opens up the blueprint and adds is to the viewport. the button lvl 1 opens up a map called lvl 1. when I open the map directly the spline works fine collision and all, but when I level select level 1 I fall through the spline and it doesn't work. atrtached is my level select screen and the spline fail.alt text

hudviewport.png (574.1 kB)
collisionfail.jpg (568.9 kB)
avatar image j_tan Jul 16 '15 at 10:50 AM

my desired result is to be apple to go up and down the spline in a simple ball game where the spline is like a track or path. but with level select hud system it seems to not detect the collision model

avatar image Rudy Q ♦♦ STAFF Jul 16 '15 at 02:59 PM

Hello j_tan,

After running through some tests I was able to find that there was a difference when using the open level node. I have a test I would like for you to try.

Test:

Could you make it so that your player does not move for the first .2 seconds of the game? I believe that the collision for your spline mesh is not being calculated for the first few frames that the level starts.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello j_tan,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Jul 20 '15 at 01:53 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question