x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Setting of Hole Material on Landscape Crashes UE4.8.2 editor

I have tried to, many times, and each time it crashes and I send in the bug report.

According to the error report, it appears to be in the shader compiler...

This is extremely frustrating because At first I reported an issue with the landscape foliage not working but it appears to be this instead.

The foliage isn't working because the shadercompiler crashes at some point.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 15 '15 at 06:03 PM in Bug Reports

avatar image

Plorax
11 1 3

avatar image AndrewHurley Jul 15 '15 at 08:07 PM

Hey Plorax,

Would you mind providing me with some reproducible steps so I can get this crash to occur in a new blank project?

Could I also get the logs and .dmp files generated from the crash reporter, as well as your 'dxdiag'? Simply put all of these files into a zipped folder and attach them to your response here on the answerhub.

If you need further instructions on how to report a bug or find these logs navigate to the 'How to Report a Bug' forums page found here.

Thank you,

Andrew Hurley

avatar image Plorax Jul 16 '15 at 05:20 AM

Hi Andrew! Thanks for replying.

I worked out a "fix" for it.. Delete your entire landscape, re-import it, then re-apply the materials.

For some reason, this worked.. I'm very baffled but thrilled that I could get some work done last night.

If I come across this issue again I'll be sure to report it with the crash debug and dmp files.

Right now though I think this is easy enough to work-around should someone experience the same issue.

Feature Request:

I think what would be a nice feature though is to be able to save any landscape changes to a file so that we can re-apply them by importing a file instead of manually having to go re-paint the landscape with foliage and textures..etc.. So, something that would keep the settings stored for each object separate so that you can re-apply them after re-creating the asset.

avatar image Plorax Jul 16 '15 at 05:22 AM

"...for each object separate.." - What I mean by this is per asset, not per object in the asset.

just thought I'd clear that up a bit.

Thanks for the great support guys!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I worked out a "fix" for it.. Delete your entire landscape, re-import it, then re-apply the materials.

more ▼

answered Jul 16 '15 at 05:23 AM

avatar image

Plorax
11 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question