x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Light as if Static" setting not persisted

Steps to reproduce in UE 4.8.2:

  • Create a blank new project with starter content included

  • Once in the editor, find the Table static mesh actor and click on it

  • Make the Table actor Moveable

  • Check the Light as if Static checkbox on it

  • Save the project and everything

  • Reload the project

Expected: Light as if Static on the Table static mesh actor should appear checked after reload.

Observed: Light as if Static is unchecked on the Table static mesh actor

NOTE1: While the steps above should be sufficient to reproduce the bug, it might be worth pointing out that when multiple movable static mesh actors reference the same static mesh, only one of them will fail to preserve the Light as if Static setting while the others will keep it.

NOTE2: This bug report seems to be a duplicate of that other one but I was asked to post mine as a separate question.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 16 '15 at 10:17 PM in Bug Reports

avatar image

pax invictus
8 2 5 6

avatar image Lovecraft_K ♦♦ STAFF Jul 17 '15 at 01:22 PM

Hi Yanko Yankov -

Thank you for your report. We have assigned this issue to a member of our support staff, and they will begin investigation as soon as possible. If we are unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide: https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

Thank you -

Eric Ketchum

avatar image Logan Bailey ♦♦ STAFF Jul 17 '15 at 01:55 PM

Hi Yanko,

So here are the steps I've done to recreate what you have.

  1. Open new project with starter content

  2. Make new Default Level

  3. Go to content Browser and find the table.

  4. Bring Table Into scene

  5. Go to Table Detail panel

  6. Change from Static to Movable

  7. Go to Lighting tab under the Details panel

  8. Go to the Light as if Static Option and check the box for this

  9. Save this project and name it "___"

  10. Go to File and click Exit.

  11. Reload the project

  12. Go to the level I created

  13. Check to see if Light as if Static is still checked on or not

After these steps I still have the Light as if Static check on.

If there is any specific step that you have done differently let me know.

Thanks, Logan

avatar image pax invictus Jul 17 '15 at 06:10 PM

Hey Logan, thanks a lot for looking into this. I am really in a hurry right now, so I just recorded a quick video (sorry, no narration) that should hopefully help to clear things up: http://youtu.be/DlzcgHNfIlg

avatar image vinque Apr 22 '16 at 04:14 PM

Same bug here. 4.11.0.

avatar image pax invictus Apr 24 '16 at 07:50 PM

I don't know about 4.11.0 but I just tested in 4.11.2 and it works as expected, no problem there.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Yankov,

I have created the steps you did inside of your video. You are right, in that this is a bug. It has been reported to the development team and it will be considered for revision. The ticket number is UE-18823.

The work around would be, as you demonstrated, to copy that object and repeat your steps.

Thank you again for reporting this, Logan

more ▼

answered Jul 17 '15 at 07:15 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same problem. I checked UE-18823 and it says "by design". What is that supposed to mean? It is clearly not a behavior anybody would expect. I need objects to use that flag and now I can't use it? What good is a flag I can set that is reset every time a project is loaded?

more ▼

answered Aug 21 '16 at 09:10 AM

avatar image

Wallenstein
627 34 44 76

avatar image Tim Hobson ♦♦ STAFF Sep 06 '16 at 01:59 PM

This is the ticket you should follow instead: https://issues.unrealengine.com/issue/UE-30080

Issue is no longer reproducible in 4.13.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question