x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my AMD Driver crashing?

My driver is crashing for no reason. I start UE4 4.8 and make couple things there. After some minutes it crashes, sometimes it crashes 1min after start and sometimes after 30min. I have no error message because UE4 closes itself and i cant open any bug report or the UE Console. All i see is "AMD Catalyst driver has stop working." thats all.

  • My system specs:

  • i7 4790K 4x4.4Ghz

  • R9 380 Gaming 4G 4GB

  • 2x4GB 2400Mhz CL10 RAM

  • 240GB SSD M500

  • 240GB SSD HyperX 3K

  • 1TB WD Purple

  • Bequiet Dark Power Pro 10 650Watt PSU

All drivers are up to date because i'm using Advanced Systemcare PRO and i make all windows updates each day.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 17 '15 at 01:35 AM in Bug Reports

avatar image

DerPolacke
1 1 1 2

avatar image Ben Halliday STAFF Jul 17 '15 at 01:23 PM

Hi DerPolacke,

I've assigned someone to look into this for you, and they'll post here if they need any more information from you. Thanks for your patience!

avatar image Lovecraft_K ♦♦ STAFF Jul 17 '15 at 01:57 PM

Hey DerPolacke -

So as I am reading your report, it looks like the Crash Reporter for the engine never appears, but when the Driver Crashes the engine fails and closes. If you wouldn't mind, please open the Windows Event Viewer (you can run a search in Windows for Event Viewer) and look at the Error and Critical warning that are generated around the time you experienced the crash of the engine. Save these error messages out (you can copy and save it out as a txt or save from the event viewer as a *.evtx file) and post them here (you might need to zip them up for file type compatibility with the site). And finally as a base line can you also upload a copy of your DXDAIG?

Thank You -

Eric Ketchum

avatar image RapturingReaper Jul 21 '15 at 11:10 PM

Hello, I've been having an identical problem with the same GPU and I'm willing to post my error messages and DXDAIG if you'd like

avatar image Lovecraft_K ♦♦ STAFF Jul 22 '15 at 02:24 PM

Hi RapturingReaper -

Yes, please. Feel free to post them as a comment here.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Guys -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you -

Eric Ketchum

more ▼

answered Jul 27 '15 at 02:17 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image teak421 Aug 08 '15 at 04:07 AM

Eric,

I am getting the exact same error...happens out of the blue. I'm running the latest version of the AMD driver...BUT, I'm on Windows 10. Not sure if that's the issue. Also, on 4.8.3.

Hope this helps....link text

unrealcrash.zip (15.6 kB)
avatar image teak421 Aug 08 '15 at 11:23 PM

Eric,

I think its Chrome! I was watching some tutorial videos on one monitor and following long inside UE4 on another. I just had a hunch and I tried some tutorials in IE 11 and I did not get a crash for over 3 hours. 3 hours is pretty short, but before it would happen much more frequently. I'm up to date on Chrome, so....

I'll let the group know if I continue to be crash free... Thanks.

  • Teak

avatar image teak421 Aug 10 '15 at 06:38 PM

I spent about 6 hours watching tutorial videos (and following along) on IE 11 and I had no AMD Driver crashes. Not sure why the combination of UE 4.8.3 and Chrome 44.0.2403.130 causes driver crashes, but something is odd....

avatar image Lovecraft_K ♦♦ STAFF Aug 12 '15 at 04:16 PM

Hi teak421 -

Thank you for the additional information. Unfortunately it still looks to be an issue with the AMD Drivers which are causing the crash. With your most recent information, I would guess that Chrome and UE4 are using the same resource and the Windows Driver does not not how to manage it correctly in relation to your Graphics Card and OS. IE probably uses a different resource. You could also look at whether your IE and Chrome are running in 64 bit or 32 bit mode.

Eric Ketchum

avatar image BobSlay Aug 15 '15 at 02:31 AM

meant to reply here, but please see my other comment about my constant crashing on ati r9 380

avatar image teak421 Sep 01 '15 at 05:29 PM

There is a new beta driver out, maybe that will fix the issue. I got my son's 280 and I am not having the issue. Couldn't take it anymore.

avatar image TJ V ♦♦ STAFF Sep 17 '15 at 06:53 PM

Has anyone tried the Beta driver yet to see if that fixes the issue?

avatar image BobSlay Sep 20 '15 at 04:24 PM

i tried it [15.8 beta], soon after teak421 made me aware of it's existence with this post, the issue is not fixed.

i've tried to make AMD aware of this via this thread: https://community.amd.com/thread/187240

no answer so far.

avatar image John Alcatraz Oct 14 '15 at 06:51 PM

The newest AMD Beta driver seems to have fixed the issue :)

avatar image BobSlay Aug 15 '15 at 02:30 AM

I have the same video card. it has been crashing since i have the card when i bought it mid-july. I did not bother to send crash report yet as it was a newly released videocard, and the driver i had at the time were not even part of the catalyst package.

I am able to code and make progress in blueprint without too much hassle, but as soon as i try to touch anything in the viewport it tends to crash very quickly.

i have been able to reproduce 100% with 3 tries by trying to place a static mesh recently imported in .fbx format. it imports fine, then as soon as i drag it in the viewport, videodriver crash.

however, trying the same steps on a new project doesn't [ yet ] crash the application.

i've managed in the past to crash it only by changing the scale value of a lightmass importance volume.

the editor dissapears after the video driver crash, and the launcher becomes unresponsive. If i try to close it the crash report window appears for the launcher.

i do not have chrome installed on my machine.

a note about my computer: my previous computer had a harddrive failure mid july and i decided to upgrade at that moment. i called microsoft support to get another activation for my windows 7 license [ which was not tied to a computer ] and they said they couldn't help me activate my license on a new computer....

so i now have a pirated win7 until i go buy win10. i was planning to keep win7 until win10 got going smoothly. If you'd prefer having everything up to date and genuine on win10, i'll go buy it and send back reports with a freshly installed OS.

zip file containing dxdiag and what i think are the windows event logs

edit: i went ahead and bought win10.

fresh install. updated what was needed to be updated. same crashes are happening in what seems to be the same circumstances.

link text

avatar image TJ V ♦♦ STAFF Aug 18 '15 at 01:35 PM

Hi BobSlay,

Try the suggestions in this section of the troubleshooting guide. Particularly the 'OpenGL' workaround.

If it doesn't work, follow the steps here to generate your Debug Logs. Then create a new report in the Installation & Setup section of AnswerHub and include that info as well as what you have posted above..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey everyone,

We have investigated this on our end and it seems to be directly related to the graphics card driver. If you haven't already, make sure that you post on the AMD forums to help get traction on this issue.

Cheers,

TJ

more ▼

answered Sep 29 '15 at 02:36 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image Burnrate Nov 14 '15 at 08:22 PM

Have you hear any more on this? I have read the AMD forum and posts and most people seem to have resolved everything with newer drivers. I have tried using the most up to date drivers and the beta drivers with no luck.

One thing that does seem to work is removing all debug spheres/lines. If I don't have them in there it doesn't crash at all. Perhaps something they are doing graphically causes the conflict?

I'll continue to work without debug drawing :( and looking for driver updates but if there is any new info someone leave a comment for me :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question