x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Build Failed 4.8.2

I am able to connect a Galaxy Note 4 to my PC and launch this project on the device.

I am as yet unable to package a development build of the game. The process always fails and I really don't know what the cause is. I cannot package the project for Windows either.

Can anyone please offer some direction in how to resolve this. I had to restart this entire project from scratch once already as I could never get it to package, and now I've taken an entirely different approach and it still doesn't work. I'm almost ready to throw my hands up and start learning C#

I have had the same problem after making a clone of the game and removing all unneeded assets, but just in case I've attached the log files from the non-stripped-down version.

I also can't get the game to scale at all to other window sizes, but that's another issue that I'll address afterwards.

Apologies for the frustrated tone. I'm just done in by what should really be a really simple project.

[1]: /storage/temp/50598-cook.txt

Product Version: UE 4.8
Tags:
cook.txt (826.6 kB)
more ▼

asked Jul 17 '15 at 06:34 PM in Packaging & Deployment

avatar image

Atonnis
43 11 13 17

avatar image Atonnis Jul 20 '15 at 03:46 AM

I cleaned up the project again and tried building using almost every variant.

I now can't even get the game to launch on the device using the Project Launcher, always with the same error:

Unable to read full header.

The image attached labelled as such shows the error after attempting to launch on the device from the Project Launcher, and after once trying to run the game manually on the device whilst still attached to the PC.

I've also attached the cook.txt and UAT_Log.txt from the latest run. Looks very familiar.

Is Unreal capable of creating projects for Android devices?

link text link text link text alt text

avatar image Atonnis Jul 20 '15 at 04:00 AM

I also tried to build for Windows. Log files are attached to this comment.

Same problem.

link text link text

cook.txt (203.4 kB)
uat_log.txt (257.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Jul 20 '15 at 07:03 PM

Hey Atonnis,

I will continue to look over the logs provided but first of all, I want to know whether or not you've been able to successfully build a unmodified template from the Epic Games Launcher to Android without any complications? If you are unable to, I would highly suggest reviewing this documentation about Mobile Game Development!

Looking forward to hearing back from you, thanks!

avatar image Atonnis Jul 21 '15 at 11:30 AM

Thank you, Samantha. I created a fresh build of the Top Down template and successfully first Launched the game on the device directly.

I then successfully packaged the project for ASTC, which seems to be correct for the Note 4, and the build was successful. The log file is attached to this comment.

I ran the batch file and the game installed on the phone and I can play it, so there seems to be nothing wrong with my setup for the build process and the problem must be in the project.

If you can continue to look into it I would be grateful. I'm going to see if I can migrate my content into the template I just created and see if that works at all.

avatar image Atonnis Jul 21 '15 at 11:32 AM

Oops, forgot to add the log file attachment, here it is.link text

tdlog.txt (1.8 MB)
avatar image Atonnis Jul 21 '15 at 12:26 PM

OK, I tried a migration and attempted to launch on device, but that fails even faster. I've attached the log for that attempt as well.

link text

Best regards Paul 'Atonnis'

tdbw.log (99.4 kB)
avatar image Samantha Sutton ♦♦ STAFF Jul 21 '15 at 07:36 PM

Hey,

Please delete your Intermediate/Android/APK and Build/Android/src folders from your project folder. It's possible when you migrated that you migrated some folders you didn't need in this project over. Once you've done that, please try again and let me know what happens.

I appreciate your patience, have a great day!

avatar image Atonnis Jul 22 '15 at 10:44 PM

Hi Samantha,

Thank you for continuing to look into this.

I did a proper cleanup, then did everything asked. It still fails. Here are the logs:

link text link text

cook.txt (195.1 kB)
uat_log.txt (249.3 kB)
avatar image Samantha Sutton ♦♦ STAFF Jul 23 '15 at 05:02 PM

Hey Atonnis,

After reviewing the logs provided I see the following issue with one of your blueprints.

 Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\CoreUObject\Private\Templates\Casts.cpp] [Line: 11] 
 UE4Editor-Cmd: Cast of Class /Script/Engine.BlueprintGeneratedClass to BlueprintGeneratedClass failed

Do you have any blueprint that has a cast of a class within it? If so, look over that blueprint and ensure there aren't any errors with the nodes, you may want to recreate the node just to be sure.

Also, looking through Jira I noticed report UE-15988 which seems to have the same error that your project is displaying. The developers need reproduction steps to replicate this error so if you could please provide us screenshots, or your project that would be really helpful in correcting this error.

I appreciate your assistance and hope to hear from you soon!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Atonnis,

I have not heard from you in quite a few days and for that reason, I will be closing this thread as resolved at this time. However, if you have any further questions regarding this topic, do not hesitate in replying back as your comment will open this thread back up for additional assistance.

Thank you and have a nice day!

more ▼

answered Jul 27 '15 at 02:38 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question