x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 4.8.2 crashes randomly with no minidump (APEX_DestructiblePROFILE_x64.dll)

Hi, everyone

This issue is blocking me from proceeding with my work entirely. It occures once in a 1-5 minutes and is pretty much random. Much more often it happens when hitting "Play" or switching between tabs in animation BP. The editor just crashes with no minidump whatsoever on my main PC and with a dump on my laptop. When i try to debug it with VS it shows "Unhandled exception at 0x000007FEDD18EE45 (APEX_DestructiblePROFILE_x64.dll) in UE4Editor.exe: 0xC0000005: Access violation reading location 0x0000000000000000." and since i'm not so good with code i can't proceed further

I've gone through topics and tried what people do in this case: reinstall FMOD, engine and drivers. Clean reinstall of these gave nothing

Did anyone encounter stuff like this?

Product Version: UE 4.8
Tags:
more ▼

asked Jul 18 '15 at 08:47 AM in Bug Reports

avatar image

Roland_Price
12 15 14 19

avatar image Roland_Price Jul 18 '15 at 09:40 PM

UPDATE: 100% reproduce is trying to play the scene without compiling the animation BP and saving it first

avatar image Logan Bailey ♦♦ STAFF Jul 20 '15 at 01:54 PM

Hey Roland,

It sounds like you have already gone through a few trouble shooting steps to ensure that it's not an issue on your end :).

There area few things that I would like to know so that I am able to narrow this issue down even further.

  1. What OSX are you on.

  2. Are you on a Windows or a Mac?

  3. What is the video card that you have installed?

  4. Do you have any add-ons that you use inside of the editor other than FMOD

  5. After all of that. Try uninstalling FMOD. If that still doesn't work uninstall UE4 and reinstall without FMOD.

Thank you Logan

avatar image Lovecraft_K ♦♦ STAFF Jul 20 '15 at 01:09 PM

Hi Roland_Price -

Thank you for your report. We have assigned this issue to a member of our support staff, and they will begin investigation as soon as possible. If we are unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide: https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

Thank you -

Eric Ketchum

avatar image Roland_Price Jul 20 '15 at 02:50 PM

Hi, Logan

Sorry, about the config - slipped my mind :)

  1. Win7x64 Professional

  2. First one kinda says it all :)

  3. MSI 780Ti

  4. No

  5. Tried this, nothing changed

But i've tried rolling back a couple of revisions earlier from p4 depot and by excluding stuff i narrowed it down to character BP - it seems that it's broken. And then it got just weird: this faulty character BP is working for me (well, except for crashes:) ), it lets me run around, shoot and do stuff in the game. But for the other team member it shows as a broken one and the Editor blocks him from adding this BP it to the map. I'll make a diff of the faulty one and the one i've rolled back to and try to get to the bottom of this mysterious case :)

avatar image Logan Bailey ♦♦ STAFF Jul 20 '15 at 03:01 PM

Yeah,

If you are able to narrow it down on your own more power to you and your team. It doesn't sound like a graphical issue then it sounds more like something within that blueprint is causing the engine to reject it.

I will link you the wiki page for CharacterBP and Blueprinting in general. Hopefully this will allow you to narrow down your list of suspects.

https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/CharacterMovement/Blueprints/index.html

Logan

avatar image Roland_Price Jul 20 '15 at 03:41 PM

Thanks, we'll need it :)

As for the BP rejection - exactly. We'll also try to see why it's ricocheting to Apex this way, maybe it'll be useful for other guys

avatar image Roland_Price Jul 20 '15 at 06:57 PM

I'm affraid i've missinterpreted the signs of fate and i'm off to where i started - no clues of what's happening :( Turned out that it's not connected to the BP: i've tried to work on older revision of the files and now crashes occur when doing stuff like deleting a state from anim BP, switching between tabs in it and many more

avatar image Logan Bailey ♦♦ STAFF Jul 20 '15 at 07:10 PM

Sorry to hear that Roland,

Without it actually giving you a log file there is little else I can think of doing.

You have the specs on your computer and your video card does support DirectX11 so I am inclined to think it is not a hardware issue.

Last resort before I pull another engine support in on this is to save a back up of your project and then to uninstall UE4 again. This time go through local files and documents and make sure there isn't a shred of UE4 on your machine and then reinstall.

Logan

avatar image Roland_Price Jul 29 '15 at 10:14 AM

Done. And no, that didn't help. I keep digging in the animBP section by eliminating nodes

avatar image Roland_Price Jul 20 '15 at 08:48 PM

I've rebuilt the project by generating an sln from uproject and launch it with debugger attached. Now it's giving me 100+ of AnimNode_StateMachine.cpp errors with different descriptions, like for example:

85 IntelliSense: expected a ';' c:\Program Files\Epic Games\4.8\Engine\Source\Runtime\Engine\Private\Animation\AnimNode_StateMachine.cpp 653 9 UE4

And crashes with Unhandled exception at 0x000007FECBAD96E0 (UE4Editor-Engine.dll) in UE4Editor.exe: 0xC0000005: Access violation reading location 0x000003B7000003E3.

avatar image Logan Bailey ♦♦ STAFF Jul 21 '15 at 01:28 PM

Hey Roland,

Judging by that line it seems that inside of that AnimationBP, there is something you are calling that is causing the engine to crash. Likely, an unsupported variable that the engine is trying to resolve but can't.

The one true troubleshoot I know for this is to recreate systematically what you have inside of that blueprint in another project. After everything you create, check to make sure that it actually compiles. That way you can isolate the issue even further.

At this point this is a blueprint issue. Keep me posted and let me know what you find out. If this problem persists open another ticket inside of the blueprint section and link that to me. That way we have expertise on both sides with eyes on this issue.

Thanks, Logan

avatar image Roland_Price Aug 03 '15 at 08:50 PM

An update in a form of crashdump:

Fatal error!Unhandled Exception: EXCEPTION_ACCESS_VIOLATION writing address 0x000003d0UE4Editor-SOB_prototype.dll {0x000007fed85f83ef} + 0 bytesUE4Editor-SOB_prototype.dll {0x000007fed85fb6d0} + 0 bytesUE4Editor-Engine.dll!AActor::TickActor() {0x000007fee338a78e} + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!FActorTickFunction::ExecuteTick() {0x000007fee3341e5e} + 31 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!FTickTaskSequencer::FTickFunctionTask::DoTask() {0x000007fee3b29535} + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!TGraphTask::ExecuteTask() {0x000007fee3b3b20f} + 16 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Core.dll!FTaskThread::ProcessTasks() {0x000007fee648651e} + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Core.dll!FTaskThread::ProcessTasksUntilQuit() {0x000007fee648674d} + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Core.dll!FTaskGraphImplementation::WaitUntilTasksComplete() {0x000007fee64abc02} + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!FTaskGraphInterface::WaitUntilTaskCompletes() {0x000007fee3b9bc80} + 16 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!FTickTaskSequencer::ReleaseTickGroup() {0x000007fee3b7d2ac} + 180 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!FTickTaskManager::RunTickGroup() {0x000007fee3b8a1a9} + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!UWorld::RunTickGroup() {0x000007fee37c0f24} + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\souUE4Editor-Engine.dll!UWorld::Tick()

That's all i can post here

avatar image Logan Bailey ♦♦ STAFF Aug 05 '15 at 03:06 PM

Hey Roland,

Whenever you experience a crash. If you would report it and then link me your machine ID.

I will then be able to go into our database and review the crash and decipher it from there.

Thanks,

Logan

avatar image Roland_Price Aug 05 '15 at 07:09 PM

Just send another report: MachineId:D27984BA457B97ED75DC2AAF676A68CB

avatar image Logan Bailey ♦♦ STAFF Aug 06 '15 at 09:22 PM

Hey Roland_Price,

I have been attempting to find your crash report in our system and I am unable.

Whenever you experience a crash you need to send the report not just close it out. This is due to privacy.

Secondly make sure that is your machine ID printed on the crash report.

Lastly if you look in this folder

C:\Users\UserName\AppData\Local\Microsoft\Windows\WER\ReportQueue

UserName will be your name. Open your project folder. You can send the whole sub directory to me but what i am looking for is a .log file and a .dmp file that reports all of your crashes that are associated with your project.

Thanks,

Logan

avatar image Roland_Price Aug 07 '15 at 07:37 PM

I did sent like 20+ of them, every time the crash reporter window appears i press "Send". Machine ID was copied from the report's body actually.

C:\Users\UserName\AppData\Local\Microsoft\Windows\WER\ReportQueue is empty at the moment. But i'll attach the .log and .dmp file next time directly to this topic

avatar image Roland_Price Aug 09 '15 at 10:52 AM

Sent another one with MachineId:D27984BA457B97ED75DC2AAF676A68CB EpicAccountId:76e2e33cc1b04510b570bfd150264ef0

It looks like the WER folder is empty, that's why it's written "no minidump available" in the crash reporter

avatar image Logan Bailey ♦♦ STAFF Aug 10 '15 at 02:16 PM

Hello Roland,

I still am unable to access your crash report through our system.

At this point, I am going to submit a crash for you with your crash logs .

If you would send me your crash logs then I will send this in and then I will hear from the dev team and be able to give you more feedback.

Thanks,

Logan

avatar image Logan Bailey ♦♦ STAFF Sep 16 '15 at 06:06 PM

Hey Roland,

Working through the logs on my end. In the meantime are you able to reproduce this in 4.9.

Hopefully it's fixed but if not I'm pulling in some developers on this one.

Thanks,

Logan

avatar image Roland_Price Sep 07 '15 at 09:34 PM

Latest info: crashes still occur and now i'm getting them on every branch (that's 11 separate project files). Getting harder to work - it's like a landmine field ballet :) Compiling and saving before each launch seem to help, but doing so is very annoying

avatar image Ben Halliday STAFF Sep 15 '15 at 03:49 PM

Hi Roland,

Sorry about this question getting marked as Resolved. I think it was an accident; when Staff comments, sometimes an existing "answer" will be marked as accepted, and we don't always catch that. I've converted everything back to comments on the original question so it's easier to follow, and I'll make sure we re-investigate.

The main thing we need in order to get any further is to see the crash logs. It looks like submitting the crash through Crash Reporter isn't going through (likely because it's not creating a minidump) but we should still be able to pull clues from those logs. You can find them in the project's \Saved\Logs folder, just zip them up and attach them here, please.

It may also be helpful to look at the actual project if the logs don't give us enough information. If you're willing to let us see it, you can zip it up and upload it someplace like Dropbox or Google Drive and send us a PM on the forums with the link, for privacy.

avatar image Roland_Price Sep 15 '15 at 09:43 PM

link text

Attached the logs

logs.rar (999.2 kB)
avatar image Logan Bailey ♦♦ STAFF Sep 17 '15 at 03:31 PM

Hello Roland,

I am currently investigating these logs. In the meantime, could you link me your .uproject, content folders and config folders from your project files.

I will also try to reproduce the crash.

Thank you,

Logan

avatar image Roland_Price Sep 17 '15 at 04:54 PM

I can't find you on forums and i don't know if it's possible to give a link via PM here. Please advise

avatar image Logan Bailey ♦♦ STAFF Sep 17 '15 at 05:09 PM

What you can do is send me a dropbox. I'll download it and you can delete the post.

avatar image Roland_Price Sep 17 '15 at 05:17 PM

Please don't get me wrong but that's not the secure way i want to share my current work in. Ben Halliday there wrote that i can PM you the link and password. Can you please give my your forum alias?

avatar image Logan Bailey ♦♦ STAFF Sep 17 '15 at 05:21 PM

Not a problem. You can go to the forums and go to the advanced search. There you can type in my name and hit search. You should be able to find me then.

Logan

avatar image Roland_Price Sep 17 '15 at 05:30 PM

Done. Please tell me when download is finished

avatar image Logan Bailey ♦♦ STAFF Sep 17 '15 at 07:18 PM

Hello Roland,

I am sorry. These do not have the source files in them. Unfortunately I cannot rebuild them on my end.

alt text 99% of the time this will work. However if this is a code project there is not way for me to build content specific I am unable to build. I was unaware of this issue as it is the first time I have run into it.

I will need your content, config, source, and .uproject.

I know this is becoming frustrating at this point. I appreciate all of your patience regarding this matter.

Logan

no_files.png (153.5 kB)
avatar image Roland_Price Sep 17 '15 at 07:47 PM

Sent you the link to the sources. In case that helps solving the problem - it's ok to do some juggling with the files :)

avatar image Logan Bailey ♦♦ STAFF Sep 17 '15 at 08:16 PM

Thanks, testing it now.

avatar image Logan Bailey ♦♦ STAFF Sep 18 '15 at 02:24 PM

Hello Roland,

I troubleshot using your original description your project. I tried pressing play and then randomly moving between tabs inside of your animation BP.

I was unable to reproduce the crash. The only thing that I noticed was a compile error in the BP. It was on the "Example Map." I believe these are reference issues from where I downloaded the game and I may not have all of your local files.

I was still able to play your game and kept it open for a while, periodically moving around in PIE and switching between BP tabs.

I really have no idea why this is happening. As I am unable to reproduce this on my end I would like to see if you are able to reproduce this on another computer.

I will continue to look through your crash logs in the meantime.

Thanks,

Logan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Roland,

I am still unable to reproduce this crash on my end. I am not sure why this is happening but it is not reproducible on my end.

As I cannot reproduce the crash I cannot enter this as a bug. The only thing I can recommend is to individually import your assets into a fresh project. Systematically try and play with each imported asset. That way you will know for sure exactly where the problem is and work from there.

Logan

more ▼

answered Sep 21 '15 at 02:44 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question