x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG?] Float values mashup - Timeline or Finterp To

Hey guys! I stumbled on very irritating problem with maybe both of the nodes Timeline or Finterp To. I have two "Transform controllers" - the first one is the location transform controller where I can change the location of an actor to a chosen target actor in level. The second one is the rotational controller where I can look around an object. And here is the problematic part. I have made a reset rotation to original rotation build when there has been changes on rotation. The problem is that when the values goes through "Finterp" To it doesnt come out as I am expecting like -90 but it comes out like -89,9989797 which blocks my workflow. Is it me missing something crucial or I am doing things wrong?

Here are some screenshots with descriptions: The first one is the location changing controller. alt text The second one is the rotation changing controller. alt text And the problematic one - reset rotation when a key is clicked alt text

I really hope that there is some solution to this. :)

Product Version: UE 4.8
Tags:
more ▼

asked Jul 21 '15 at 02:44 PM in Blueprint Scripting

avatar image

NasteX
35 4 8 10

avatar image NasteX Jul 22 '15 at 11:34 AM

Hi again guys, I made a few more screenshots to visualize better the problem which I couldn't fix it yet. Here is the starting rotation which is yaw = -90 alt text Here is when I rotate the object and it perfectly as I am expecting. alt text And here happens the weird thingy with the float values. It should come back to -90 but it comes with different value every time... alt text And the last screenshot shows that the output is correct but if I get the rotation of the object the value is different as you can see in the pictures over. alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question