x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Closed] Rsync: Remote Certificates Not Found

I'm trying to package a test iOS project from my Windows computer to my Mac. I've managed to install DeltaCopy on my PC and setup an RSync daemon on my Mac. I've exported both certificate and mobileprovision from Xcode, and imported them into the project on the PC via Project Settings->iOS.

Remote seems to work and files get copied to the Mac. But then I run into this;

 Packaging (iOS): UnrealBuildTool: Build settings from command line:
 Packaging (iOS): UnrealBuildTool:     CODE_SIGN_IDENTITY = iPhone Developer
 Packaging (iOS): UnrealBuildTool:     CODE_SIGN_RESOURCE_RULES_PATH = /Users/USERNAME/UE4/Builds/PC_NAME/C/UE4/TestIOSProject/Binaries/IOS/CustomResourceRules.plist
 Packaging (iOS): UnrealBuildTool:     IPHONEOS_DEPLOYMENT_TARGET = 6.0
 Packaging (iOS): UnrealBuildTool:     SDKROOT = iphoneos8.4
 [...]
 IPP ERROR: RPCCommand MakeApp failed with return code Error_RemoteCertificatesNotFound
 [...]
 UnrealBuildTool: Code Sign error: No code signing identities found: No valid signing identities (i.e. certificate and private key pair) matching the team ID “(null)” were found.
 [...]
 ERROR: System.Exception: ** BUILD FAILED **IPP ERROR: RPCCommand MakeApp failed with return code Error_RemoteCertificatesNotFound

However I have this further up in the log;

 .. .. Installed certificate 'iPhone Developer: Firstname Lastname (ABCDE12345)' is valid (choosing it) (range '2015-07-20 23:42:01' to '2016-07-19 23:42:01')

 Picked 'xx12x345-x67x-89x0-x123-4567x8xx9x01.mobileprovision' with AppID 'A1B2C3D4.com.XXXXXgames.appName' and Name 'iOSTeam Provisioning Profile: com.XXXXXgames.appName' as a matching provision for the game 'TestIOSProject'

... so it seems that the mobile provision and certificate successfully load on the PC but I still have certification issues on the Mac, even though they've been copied from the Mac?

Product Version: UE 4.8
Tags:
more ▼

asked Jul 22 '15 at 10:42 AM in Packaging & Deployment

avatar image

bzxo
141 6 17 21

avatar image Ravlek STAFF Jul 25 '15 at 01:49 AM

When using the SSH build for IOS you will need to make sure the signing identity certificate is installed on the remote Mac in the System keychain. We can't access the login keychain without asking for a password, but if the identity is in the system keychain, Xcode will find it properly.

-Pete

avatar image bzxo Jul 26 '15 at 05:06 PM

I've imported the certificate into Keychain Access, and then exported it as a .p12 (tried .cer as well) to a USB stick, brough it to the PC, and tried importing it there through the editor, and IPP.

It seems like it won't load when importing through the editor - importing through IPP "sorta" works (then crashes) and it pops up in the list of certs, but that's when I get the above error.

avatar image bzxo Jul 27 '15 at 03:29 PM

To be clear - is this the workflow for getting certs to work with Mac + PC?

  • Add Apple Dev Account in Xcode

  • Export iOS Development certificate (.p12) from Xcode

  • Xcode > Apple IDs > Details > Provisioning Profiles > "Show in Finder" > Copy to PC

  • UE4 Editor Prefs > iOS > Import ^ Provisioning Profiles

  • > Import Certificates > ^ .p12 file

As noted before, this is where the editor hangs on "Importing Certificate. Please wait..."

avatar image Ravlek STAFF Jul 27 '15 at 03:45 PM

So, yes, that is the workflow as it currently stands. The point where it is hanging for you is where you should be seeing a dialog asking for a password. That dialog could be behind the main editor window. In the end tho, the editor is just calling iPhonePackager.exe to do the import, so utilizing IPP would be the equivalent of what the editor is doing.

-Pete

avatar image bzxo Jul 27 '15 at 04:22 PM

Alright. When I use IPP, I can import the .p12 file and input the password, but when I try to do something else, IPP crashes. Maybe that's an indicator?

When pressing "Ready To Package", IPP straight crashes without any messages.

When trying to open "Other Deployment Tools"; System.IO.FileNotFoundException: Could not load file or assembly 'DeploymentInterface, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

avatar image bzxo Jul 31 '15 at 01:18 PM

Hi Pete, I'm at a loss here. Attaching a picture of what's confusing. I have a valid cert and a valid mobileprovision, IPP seems to recognize this, but I still get the "null" error further down when packaging.alt text

nullteam.jpg (305.3 kB)
avatar image Ravlek STAFF Jul 31 '15 at 01:22 PM

Are you building on a remote mac? If so, you need to make sure you have the certificate installed there as well. We don't transfer it over (we would have to ask for a password to send across the network) and so you need to ensure it is installed on the mac which is building your game. It looks like your certificate is relatively new, so make sure that one is on the mac itself as well.

-Pete

avatar image bzxo Jul 31 '15 at 03:34 PM

Hi Pete, yes, I'm building on a remote Mac, and I exported it from the Mac (Xcode) as per the list I wrote further up, and then imported it into the PC. Is that correct?

I'm working on this with another user and neither of us get the password box when importing the certificate through the editor.

avatar image Ravlek STAFF Jul 31 '15 at 03:36 PM

The other time I've seen the No valid signing identity message was when we updated the certificate on our remote mac builders, but didn't update the provision to be generated from that certificate. Just making sure you updated that provision as well. I'm sure you have, but just checking.

As far as the no password dialog, that is a bit odd as it should be asking you for one. I'll see if we can reproduce that one here.

-Pete

avatar image Ravlek STAFF Jul 31 '15 at 03:37 PM

Oh, which Keychain is your certificate in on the mac? If it is in the login keychain, it might need to be in the system keychain (and vice versa).

-Pete

avatar image bzxo Aug 01 '15 at 02:44 PM

That did it! Wow, I didn't notice how Xcode put the key in the login keychain instead of the System one.. dang.

Thanks for all your help!

Edit: I still don't get the password box though, importing through IPP instead

avatar image FacePalm.exe Nov 23 '15 at 03:36 AM

As @bzxo states, it should be looking in the login keychain instead (As that's where XCode stores them)

The UnrealRemoteTool was able to pull them correctly from the login keychain, and doing a build locally also pulls them from the Login Keychain.

Why is RSync different? I shouldn't have to manually maintain 2 sets of certificates. (3 if you count the one on my local machine)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jul 01 '16 at 09:10 PM by Samantha Sutton for the following reason:

Issue is now outdated. If you are still experiencing this issue, please make a new post for assistance. Thanks!


1 answer: sort voted first
more ▼

answered Jul 22 '15 at 10:56 AM

avatar image

ppetermann
14 2 3 4

avatar image bzxo Jul 23 '15 at 03:26 PM

Thanks, I've seen that and tried the suggested solution. Still can't import the Cert through the editor - hangs at "waiting" (I previously imported using IPP but I think that was part of the problem).

avatar image ppetermann Jul 23 '15 at 03:35 PM

which of the solutions have you tried?

avatar image bzxo Jul 26 '15 at 05:03 PM

I've tried the top 5 solutions (imported into keychain, exported from keychain to PC, checked Apple Dev page to see if missing something, re-exported everything, and refreshing in Xcode.)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question