x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Pawns push objects even with DISABLED Physics Interaction

Hey guys. How can I make it so that my character pawns will stop pushing physics objects? I have these little guys and some cubes and a bridge, which when they come into contact they just push away with ease. alt text

i tried disabling the Physics Interaction option in the Character Movement component, but it does nothing, same results. I also tried to set the Initial push Force Factor to 0 and the Push Force factor to 0 (from 750,000), and they still just walk through objects. alt text

I want my pawns to not be able to push, I am going to push for them. The Add Movement Input for the little pawns not set to Force. alt text

Product Version: UE 4.8
Tags:
more ▼

asked Jul 22 '15 at 03:53 PM in Using UE4

avatar image

Motanum
620 58 63 306

avatar image LordMorin Aug 11 '15 at 05:37 AM

I'm wondering the same thing. I'm planning to use destructible physics crates as a blocking gate but since the player can just nudge them out of the way it defeats the purpose.

avatar image Xiomax Sep 26 '15 at 11:47 AM

Bumping as I am having the same problem but haven't found a solution so far.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

For me, the problem was that the static meshes I had added to my character had blocking collision enabled. They were what was actually pushing the physics object, not my character. Once I set all my other components to No Collision, then I could see that unchecking Enable Physics Interaction was actually working.

more ▼

answered Oct 21 '16 at 01:40 AM

avatar image

CleanCut
2.1k 66 84 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I ran into this problem and I found I had to change the player's physical material. The friction in particular had to be set to zero because otherwise objects would be moved as the player brushed past them.

Like other people I started by clearing the Enable Physics Interaction box, and that stopped the player pushing things directly. I think the point here is that controller inputs don't normally work through physics. When the player presses the forward button, it just moves the player, it doesn't put a force on the player and allow the physics engine to move the character. Because of this, there is a fudge so that the player can push physics objects, and the checkbox turns the fudge on or off.

If the player is already moving, or the player is struck by a physics object which is moving, this doesn't apply. In this case the controller inputs are irrelevant, and the interaction is driven by the physical material which is assigned to the player character.

more ▼

answered Oct 07 '15 at 10:04 PM

avatar image

PeteX
173 5 9 13

avatar image Daverex Feb 03 '16 at 06:18 AM

That didn't help me much... I can still sprint-jump into large steel cubes, punting them into the distance with my head. Perhaps there are more ways than one to get these results?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi,

i have taken a little time to solve your issue. It is quite easy, but it is always once you have the anwser :D

Go into your character BP and select the Movement Component.

Then in the Details Panel there is this section (view the picture):

alt text

What i did is: Change the "Initial Push Factor" from 500 to 0. That solves your problem.

You can dive deeper into this and you can try changing the other values, but for now this works.

Cheers :D

unbenannt.jpg (29.7 kB)
more ▼

answered Feb 03 '16 at 02:42 PM

avatar image

Raidfire.Net
637 61 54 116

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The last days i also had some work that crosses this theme. I do not see it in your picture, but: Is there a checkbox for gravity? If it is then uncheck this. Is there a Physics constraints tab? If it is: Lock the location and rotation.

Maybe that helps :D

more ▼

answered Sep 26 '15 at 12:16 PM

avatar image

Raidfire.Net
637 61 54 116

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question