x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Mesh Animation Not Smooth

Hey all,

Exporting an animated mesh from Maya into UE4 and it's coming out a bit robotic. The animation keyframes are super smooth and perfect in Maya but in UE4 they lose some of the smoothness. Is there something going on that's converting my keyframes?

Other than a little less smooth things are fine but I'm being a perfectionist.

Thoughts?

Product Version: Not Selected
Tags:
more ▼

asked Jul 22 '15 at 04:30 PM in Using UE4

avatar image

reedandrader
270 26 41 164

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It might be compression. Can you post the Maya and FBX animation file per chance? Or a video showing the difference?

more ▼

answered Jul 23 '15 at 04:12 PM

avatar image

jmalaska
732 41 38 60

avatar image reedandrader Jul 23 '15 at 04:21 PM
avatar image jmalaska Jul 23 '15 at 08:50 PM

Thanks for posting the files. That definitely helped.

The temp fix: On importing the animation you'll want to check

However, I'd consider that a temporary fix :) The Maya file is set to animate at 24 fps. The game assumes all animations are done at 30 fps! So the game is probably trying to convert the 24fps animation to 30fps, but it's improperly converting all the curves to 'linear' so it gets that robot look you mention.

In Maya you can change the playback settings under Windows>Settings/Preferences>Preferences>Settings and change Time to NTSC/30fps. Then in that same Window under Time Slider, make sure it's set to 'Real Time 30 fps'.

Setting it to and animating with 30 fps should prevent any headaches in the future with this sort of thing.

If this answers your question feel free to mark as answered, otherwise let me know if you have any questions and I'd be happy to help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question