x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Imported models are not visible in game

Hi guys, I just started learning Unreal, so when I imported a model from Blender into Unreal, everything worked fine, but when I run the preview mode or launch the level, I could not see the model I just imported and placed in the world, it is just not at there, completely disappeared. I checked the visible mark, it is checked, and I m sure that I didn't invert the mesh in Blender. Could some one help me with this issue please?

Product Version: Not Selected
Tags:
more ▼

asked Jul 23 '15 at 07:26 PM in Using UE4

avatar image

ALTWang
42 23 22 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello

Just a question what version of blender are you using? If it is 2.73 or 2.74 then you must set your SCENE UNIT to Metric(see screenshot) then upon export using FBX exporter set your scale to 100 and use the SELECTED OBJECT option and select mesh(screenshot 02).

alt text alt text

Upon import into unreal engine 4 you should not change any options and it should be as simple as drag and drop from content browser to game. alt text

Note that in blender I use the Transform settings to confirm the dimension(hotkey N on the right of your screen) the cube size is 2m X 2m X 2m. Compare it to the character it is perfect size.

Now this is just one solution to many problems it can be. In blender 2.75a I noticed the setting scale is no longer required so it really depends on your version. Other problem could be that you have inverted normals or if it is a skeleton mesh there are even more problems that could be related to this.

You could share your blend file if you want then I could better understand the problem.

capture01.jpg (27.3 kB)
capture02.jpg (24.1 kB)
capture03.jpg (45.8 kB)
more ▼

answered Jul 25 '15 at 10:55 AM

avatar image

Paul Swartz
231 8 5 7

avatar image ALTWang Jul 25 '15 at 05:17 PM

Thank you! My Blender version is 2.74, I found an other way to solve this problem, tho I'm not sure if this is correct: I changed the Unit system to Metric, and change the scale below it to 0.1, when I exporting a model, I check "selected object" but keep the scale at 1.0 I guess your method is more appropriate, I will try it in the future. Thank you!

avatar image Paul Swartz Jul 25 '15 at 08:53 PM

That is a way to do it. One note there is when you are working with Bones and skeletal meshes in my experience upon import the 0.1 setting works for the mesh but not the skeleton. I am not sure why this happens that is why I just changed settings on export. But as I mentioned Blender 2.75a seems to have fixed the FBX exporter.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question