x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I was able to add a Class Settings interface to my player Blueprint earlier, but now I can't.

A few days ago I was making a health system for my game, and it was working fine other than the death system not working. I made a new character Blueprint to test the problem and fixed it, and that test character ended up being better than the previous one. Until I noticed that I couldn't add a Class Settings interface for the health bar; no error or anything, it just didn't work. I went back to the last character Blueprint that had a functional health bar, and I tried deleting the interface. I couldn't re-add it at all. Undoing the action didn't bring it back, and trying to add it back through the drop down menu didn't work either; once again no error or any indication of an error. I'm pretty stumped. I've only been using Unreal Engine 4 for around a week, and I have no idea what else to try. I remade the Blueprints too, but it didn't work anyways. Also, in case you're wondering, this was all done on the same UE4 version. I'm not sure if this is a bug or I'm just messing something up.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 24 '15 at 12:05 PM in Blueprint Scripting

avatar image

Turtleburgers
1 1

avatar image thenegaverse Sep 07 '15 at 02:40 PM

I'm having this issue as well with version 4.6.7. Bought JCInventory on the market and have spent months trying to integrate it into my project. It's all come down to this, selecting the JCInventoryPlayerInterface in my character pawn's class settings. It shows in the drop down menu but when I click it, nothing happens. I can add other interfaces, but not that one. I went into the demo character provided in the package and removed the interface from the class settings and it wouldn't allow me to add it back in. What stops an interface from being used in another pawn class settings or being added after it's removed?

I'm going to dig through the documentation because so far I can't find help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question