x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android lighting issue

Hi all, I've an issue with lighting a scene. I've already read the documentation about it https://docs.unrealengine.com/latest/INT/Platforms/Mobile/Lighting/index.html but it doesn't help. I want dynamic shadow for my character (My character is a bluebrint with a STATIC MESH inside), and my problem is: 1- In the engine mobile preview I have a correct lighting, but no shadows at all. 2- On my LG G3 I've the shadow ( YUUPEEE! ) but, as you can see in the image attacthed, the ground is not lighted till the end of it. It seems like there is some sort of clip plane on the camera, but the strange thing is that the earth object is much more distant than the end of the ground, but it has an unlit material, so I suppose it's an issue of the light. I have the same problem also if I set the light as movable. Does anybody have a clue about this?

Thank you. Zanna

Product Version: UE 4.8
Tags:
more ▼

asked Jul 25 '15 at 11:54 AM in Rendering

avatar image

Zanna3d
1 1 2 2

avatar image Zanna3d Jul 25 '15 at 02:25 PM

Ah, I forgot, if I uncheck "Cast Shadows" from the light, the ground appears correctly also on the device but, of course, I don't have any shadow...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

Default movable actor not have a dynamic shadow. But you can try this solution.

https://forums.unrealengine.com/showthread.php?70510-TIP-How-to-enable-Dynamic-Shadows-amp-Correct-Reflection-Maps-on-mobile

more ▼

answered Jul 27 '15 at 08:26 AM

avatar image

svv3dUDN
8.4k 254 42 399

avatar image Zanna3d Jul 27 '15 at 07:47 PM

Thank you for your reply. But, do you know anything about that sort of "far clip plane" in the lighting? Why does my groung is not lighted till the end as it should be?

avatar image svv3dUDN Jul 28 '15 at 07:50 AM

Tip about dynamic shadow is not officially supported. And this function may not work properly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question