x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Errors and crashes while Building Lighting

So every time I try and build the lighting for my world, I get this error (picture below text). This error page comes after ~30 minutes of my PC 'crashing' and freezing, which is apparently normal. The Lighting Build never passes 0%. I've added a Lightmass Importance Volume and I've scaled it to cover the size of my map (Should I not do this?), because I was getting a similar error and it suggested to add a Lightmass Importance Volume. Anyways, I'm not sure where to go from here or what to do, and I don't quite understand what the error page is asking of me. My map resolution is 1009x1009 I believe.

Picture of the error page: http://i.imgur.com/getVTmE.png

BTW: Building the lighting usually works on more basic scenes (when there is pretty much nothing except the basic terrain). I have a Nvidia 660ti graphics card, Intel i7, and 16 GB of ram.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 26 '15 at 07:55 AM in Using UE4

avatar image

Carbonology
5 5 5 7

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

You have pretty cool PC, but even I didn't expected, that lightning rendering will be so tough.
Error message says, that you ran out of memory: basicaly, your 16 GB of RAM isn't enough. That's all.
How to deal with it:
-Make lightmap resolution way smaller. Modify "Lightning info" in Build options menu (near Build All button) as you want. The goal is make lightmap smaller.
-Add string into DefaultEngine.ini: r.LightPropagationVolume = true
In properties of light (MOVABLE directional, or whatever you are using for global illumination) set as true tick "Dynamic Indirect Lightning" (in the Advanced expandable of the Light category). Now you have dynamic Indirect Lightning and you don't need to worry about lightmaps. But it have it own issues, like high perfomance cost, low percision, limited distance etc. Don't forget to restart editor, after editing ini.

more ▼

answered Jul 26 '15 at 05:14 PM

avatar image

HungryDoodles
490 29 23 40

avatar image Carbonology Jul 28 '15 at 03:06 AM

Also I set Static Lighting LOD to 2 under my Landscape lighting options, disabled 2 sided shadows, and switched to a mainly dynamic lighting system.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question