x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Black material instnce

hi,

i got a strange behavoir with one of my material instances.

I rendered a branch texture to a image. now i want to apply it to a a material instance, sadly the instance stays black, but does recive the alphachannel.

Here the mastermaterial and the instance: alt text

this is the material setup

alt text

This is the instance. the texture should be fine.

alt text

For reference, the grascluster is using the same Materialinstance and the texture was rendered exactly the same way

I am hoping for help :D

-siebencorgie

Product Version: UE 4.8
Tags:
mat_01.png (355.9 kB)
mat_02.png (298.1 kB)
mat_03.png (373.9 kB)
more ▼

asked Jul 28 '15 at 01:14 PM in Rendering

avatar image

siebencorgie
224 22 26 30

avatar image Lovecraft_K ♦♦ STAFF Jul 28 '15 at 03:30 PM

Hi siebencorgie -

Taking a brief look at your Master Material and your Instance for the branch, it looks like your roughness map may be passing values you do not want into the Roughness of your leaves on the branch. Try setting a hard value of 1 in the Master Material and see if the branches rendering correctly.

Thank You -

Eric Ketchum

avatar image siebencorgie Jul 28 '15 at 04:07 PM

I did so, but they are still black. :(

any other ideas?

avatar image Lovecraft_K ♦♦ STAFF Jul 28 '15 at 05:18 PM

Can you share the textures you are using?

avatar image siebencorgie Jul 28 '15 at 05:38 PM

shure :) Ill make her as attachmentalt text

pine_branch_d.png (391.5 kB)
pine_branch_n.png (655.4 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi -

It's the SpeedTreeColorVariation Node. The values here are hypersensitive so try using values between 0 and 1, going over 1 is okay but too much and you will get the black look again.

Thank You -

Eric Ketchum

more ▼

answered Jul 28 '15 at 06:22 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 701 254 732

avatar image siebencorgie Jul 28 '15 at 06:52 PM

The colorvariation node is at 0.03... I deleted her, that is the result: alt text as you can see it becam better, but everything in the shdows is still black.

maybe its because of the mesh and the textures in combination, because other textures and meshes are working well with the baseshader...

mat_04.png (908.8 kB)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question