x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Material light flickering on look.

Hello!

I have a little problem. Made a material with vertex animation, and when I changing the camera axis it starts flickering. But when I moving the character not. Dont know why. Any idea? Using FXAA, tried different AA, and without it, but same result with each.

Video: https://youtu.be/SXJk9xTfob4

Thanks! Máté

Product Version: UE 4.8
Tags:
more ▼

asked Jul 28 '15 at 09:07 PM in Rendering

avatar image

Laszwalker
2 1 3 4

avatar image Logan Bailey ♦♦ STAFF Aug 03 '15 at 01:42 PM

Hello vmworks,

In order to better understand how exactly you have created this material and how it is being implemented into your project, I would ask you to please post a screenshot of the Material.

Also if you would post a picture of how it is being applied and any settings that you have associated with this Material and Mesh.

I.E post processing, type of AA etc.

Thanks,

Logan

avatar image Laszwalker Aug 04 '15 at 01:32 PM

Hello Logan!

The material setup looks like this:

alt text

Made the vertex animation with the 3Ds Max script. The texture is a simple grid, masked out. Settings: alt text alt text

And just applied on to the mesh.

In a post process volume using FXAA as AA. With no AA a little better, but still pulsing/flickering when I change the players camera.

Thanks for replying! Máté

material01.png (256.8 kB)
material02.png (97.6 kB)
material03.png (80.0 kB)
avatar image Logan Bailey ♦♦ STAFF Aug 04 '15 at 05:32 PM

Hello vmworks,

Flickering is indicative of mesh distance fields.

  1. Do you have generate mesh distance fields enabled in project settings?

  2. Do you have all dynamic lighting in your scene?

  3. Temporal AA is usually the way to go for these things.

  4. World position offset can sometimes create this issue as well.

These are some of the areas to visit first and troubleshoot.

I would start start with these and look into our documentation on the Wiki and then if you are still experiencing this issue I will look into it further then.

Thanks,

Logan

avatar image Logan Bailey ♦♦ STAFF Aug 06 '15 at 02:27 PM

Hey vmworks,

I haven't heard from you yet. I was wondering if any of these troubleshoots worked or if you are still experiencing this issue?

Thanks,

Logan

avatar image Laszwalker Aug 07 '15 at 10:54 AM

Hello Logan!

Soryy, but I was a little busy. So, I enabled the mesh distance generation, but it not solved the problem. I have a directional light source, and a skylight, both set to movable. (That means they are dynamic?) If I switch in the post process volume to Temporal AA, it stops flickering, but that happens: alt text

Thanks for the advices! Máté

temporal.png (533.6 kB)
avatar image Logan Bailey ♦♦ STAFF Aug 07 '15 at 02:04 PM

Hello vmworks,

If you would send me your texture files so I am recreating exactly the material that you have created.

I want to make sure I eliminate as many x factors as possible when recreating a test for this.

Thanks,

Logan

avatar image Laszwalker Aug 07 '15 at 02:21 PM

Hello!

Okay, I attach the material, the static mesh, and the textures.

http://we.tl/xKbhRaZGHH

Thank you! Máté

avatar image Logan Bailey ♦♦ STAFF Aug 07 '15 at 02:55 PM

Hello vmworks,

Thank you for providing what I requested. However, the .uasset's are project specific. They reference files that are local to your machine.

What I need in order to use these are your content folder, your config folder, and your .uproject.

Thanks,

Logan

avatar image Logan Bailey ♦♦ STAFF Aug 10 '15 at 01:49 PM

Hello vmworks,

I haven't hard from you in a couple of days. I was wondering if you were still experiencing this issue or had a chance to follow the steps in the previous comment?

Thanks,

Logan

avatar image Laszwalker Aug 10 '15 at 08:30 PM

Hello Logan!

Sorry, but I'm at a festival and using this visual game. So now I have not too much time. I'll be write to you when this project ended. Thanks for your patient, and the help.

Thanks, Máté

avatar image Logan Bailey ♦♦ STAFF Aug 10 '15 at 08:31 PM

Not a problem have fun!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello vmworks,

Due to inactivity and tracking purpose I will be marking this thread as answered.

If you are still experiencing this issue please post again and I will continue to address this issue at that time.

Thanks,

Logan

more ▼

answered Aug 10 '15 at 08:26 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question