x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why Perspective Portrait Camera Does't work well on Android?

I'm trying to set the field of view from my Perspective Camera to 37 and Aspect Ratio 0.5625, but it is looking really odd on mobile device although it looks fine on Unreal Mobile Preview. (As you can see at attached files) Am I doing anything wrong?alt text

Product Version: UE 4.8
Tags:
02.jpg (39.8 kB)
03.jpg (106.5 kB)
04.jpg (85.4 kB)
more ▼

asked Jul 29 '15 at 01:02 AM in Bug Reports

avatar image

pedrodacruz
106 6 9 15

avatar image TJ V ♦♦ STAFF Jul 29 '15 at 01:15 PM

Hi perdrodacruz,

Thank you for the report. We have assigned one of our technicians to investigate your issue and they may post here with additional questions or comments.

In the meantime, could you provide the exact model of the Android device that you are using? And also provide thorough repro steps or a small test project for us?

avatar image pedrodacruz Jul 30 '15 at 01:28 AM

I have followed the steps of on Youtube Unreal Channel to create a 3rd person Game: 1. Attach SpringArm to CapsuleComponent (Loaction: X=0;y=0;Z=40/ Target Arm Length = 300); 2. Attach a Camera to SpringArm (Location: x=-450;y=0;z=70/ Projection Mode = Perspective/ Field of View 37/ Constrain AspectRation = true/ AspectRatio = 0.5625) 3.Finally, I have followed the steps of Youtube Unreal Channel to create the endless running mechanics...

It will take some time to elaborate something more detailed (if you need so).

avatar image Samantha Sutton ♦♦ STAFF Jul 29 '15 at 06:07 PM

Hey Pedro,

What type of mobile device are you pushing this project to? I have changed my Android project settings to 'portrait' and changed the camera settings to 37 with an aspect ratio of 0.5625. I pushed my project to a Nexus 5. The project came out proportionate without any black bars beside, above or below. Please keep in mind I also tested this in 4.8.3, as I can't downgrade to 4.8.2.

Looking forward to hearing back from you, thanks!

avatar image pedrodacruz Jul 30 '15 at 12:11 AM

My mobile device is Motorola XT910 and I am using Android 4.1.2 ....

avatar image pedrodacruz Jul 30 '15 at 01:15 AM

I have just tested on my mother's mobile device (Motorola Moto E) and it is happening the same problem (as the picture attached)alt text

avatar image Samantha Sutton ♦♦ STAFF Jul 30 '15 at 04:03 PM

Hey,

Thank you for testing this out on another device.

I have now tested it on a Samsung Tablet on Android version 4.1.2. I did not have the letter boxing around the game. I tried with the spring arm and without the spring arm with the settings that you provided previously.

I also went ahead and tested this on another device, the HTC One however this device is on Android version 4.4. I was unable to reproduce the letter boxing around this device either.

Have you looked into upgrading your version of Android to see if that changes the letter boxing? Keep in mind that upgrading your version of Android is something that is permanent so if you do not want to test that out, feel free not to.

Another suggestions that I have is to change your aspect ratio and size around, unless you're positive that's the size that's needed for your devices. It's possible that the sizing isn't working properly on the two devices that you're using.

If these two suggestions are not helpful, feel free to zip your project (with all files - - so there aren't any errors) for me and upload it on Google Drive or DropBox and provide it to me in a private message on the forums so that it's safe from the public.

Looking forward to hearing back from you, thanks!

avatar image pedrodacruz Jul 30 '15 at 10:31 PM

Hey, Samantha!

I didn't understand what you meant with "size around"... I am trying to send you my project.... I am afraid of need to make a new project... Thank for your attention!

avatar image Samantha Sutton ♦♦ STAFF Jul 31 '15 at 03:33 PM

Hey Pedro,

Thank you for sending me your project. It looks good in my opinion by the way. :)

I have tested your project on the Nvidia Shield, Nexus 5 and the HTC One. Each of these loaded up your game just fine. The only one that ran into the letterboxing issue was the HTC which is on Android version 4.4. On the HTC, the screen was shifted more to the left, so the letterboxing appeared on the right side of the screen. It was less than a 1/2 inch in width, to give you an idea.

I believe what's happening is it's coming down to the size restraints of the devices that you're using. But I did want to let you know that I looked further into your character blueprint and noticed that the camera was set to 17, not 37. I changed it back to 37 and saved the changes. I also set the portrait to sensor portrait. Once I launched the game back onto the HTC One, the letterboxing had vanished.

Could you please check your settings again on your project settings within 'Mirtilo Character' and ensure that the camera settings are correct?

Looking forward to hearing back from you, thanks! :)

avatar image pedrodacruz Jul 31 '15 at 11:30 PM

Sorry Samantha! I forgot to set the camera's Field of View... The project that I have sent you is the same I have released on Google Play... but now I am trying to set Field of View to 37 because I think it gives an better sense of speed... Have tested everything with 37?

Oh! I forgot to say: My mother's mobile phone is Android 4.4.4.

I have setted the option "Sensor Portrait" but it didn't have any effect.

avatar image Samantha Sutton ♦♦ STAFF Aug 03 '15 at 02:17 PM

All devices tested with your project, or a similar set up have worked correctly unless otherwise noted. Unfortunately, the two devices that you are referring to, we do not have access to. Have you tried changing the size of the camera's field of view and possibly the aspect ratio? It's possible that those specific phones are set up slightly different than the ones tested. Do you have any other mobile device you're able to test with?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Thank you very much, Samantha! This week I am having no free time (my main job is not game development...unfortunately), but I will open a new question as soon as I can... but for the current question is the answer:"this problem cannot be reproduced on epic games device"?

more ▼

answered Aug 05 '15 at 02:54 AM

avatar image

pedrodacruz
106 6 9 15

avatar image Samantha Sutton ♦♦ STAFF Aug 05 '15 at 04:34 PM

Hey,

Please contact us back when you have more time to look into this. I have verified that the iOS devices do not show the letterboxing. I did notice that your game was sent to the view of 17 and not 37. I changed that of course, as that's how you mentioned it was suppose to be set up previously. Have you tried that on your end?

Thank you!

avatar image pedrodacruz Aug 05 '15 at 04:56 PM

Yep! The screenshots were taken in a view of 37!

avatar image Samantha Sutton ♦♦ STAFF Aug 06 '15 at 08:03 PM

I have not been able to reproduce this. I'm not quite sure yours are showing up differently than when I push the game to the devices. Have you tested this out in 4.8.3 and 4.9.0 Preview 2?

avatar image pedrodacruz Aug 07 '15 at 11:17 PM

I have tested this out in 4.8.3, but now I will try the 4.9.0 Preview 2. As soon as I download it and run it I will post the results.

avatar image pedrodacruz Aug 08 '15 at 02:04 PM

I have originally tested it in 4.8.3 and I've just tried to test it on 4.9.0 preview 2 and Hit Box is not working (it has also happened on 4.6 version, but was solved on 4.7) so... once my game is already released I can't even try to use this preview (I have suffered enough with Unreal previews - I hope to have learned my lesson)...

avatar image Samantha Sutton ♦♦ STAFF Aug 11 '15 at 04:44 PM

Hey Pedro,

So in the end, were you able to resolve the issue with your project? Previews are basically just snapshots of the newest version of the editor that we're planning on releasing. When you 'upgrade' to a new version, it doesn't take your whole project and convert it unless you ask it to. All you need to do is press 'copy' on a newer version and it'll create a copy, not destroying your other version of the project in the process.

Looking forward to hearing back from you, thanks.

avatar image pedrodacruz Aug 12 '15 at 01:48 AM

Hey Samantha! Sorry for my bad explanation (I don't know to explain things in Portuguese and in English I am worst...) I have created a copy, but hit box is not working in the copied project, thus I can't even start the game :)

avatar image Samantha Sutton ♦♦ STAFF Aug 12 '15 at 04:04 PM

I just opened your project from 4.8 to 4.9. Once it loaded, 245 ActiveClassRedirectors which contained collision with multiple redirectors threw errors. To fix this, you'd have to go through these files and make sure that they're directed correctly in your project.

The error messages tell you exactly which files that would be. You can look at the error log by going to: Window > Developer Tools > Message Log

avatar image pedrodacruz Aug 15 '15 at 07:16 PM

Sorry,Samantha... could you please give more details how to fix these errors (I know to work only with blueprint so far...)? :/

avatar image Samantha Sutton ♦♦ STAFF Aug 19 '15 at 06:00 PM

Hey Pedro,

The activeclassredirectors issue is actually something known in 4.9 Preview 3, I don't think it's fixed in 4.9 Preview 4 however there is a workaround. If you do not want to see these activeclassredirector errors, you can migrate your project to a new project, but that will more than likely require more work than it's worth.

If you have any other errors that are not related to activeclassredirectors, you'll need to look at where those files are pathed, and look into those blueprints/assets/etc further.

Feel free to post any logs if you're unsure of anything, thanks!

avatar image pedrodacruz Aug 19 '15 at 10:32 PM

Thank you Samantha! I think I will wait for the next preview... ;)

avatar image pedrodacruz Sep 02 '15 at 01:59 PM

Hey Samantha, I have created a new Question talking about the this new issue: https://answers.unrealengine.com/questions/281819/how-to-solve-activeclassredirects-error.html

Do you think I did it right?

avatar image Samantha Sutton ♦♦ STAFF Sep 02 '15 at 06:28 PM

Hey Pedro,

The ActiveClassRedirects issue should be fixed as of the release of 4.9. However, if you're still getting that, a sure way to fix the issue is to migrate your folders from 4.8 over to the project in 4.9. The migration tool is available in the editor, please do not just simply copy and paste the folders over - - that causes so many issues.

If you have any further questions, please let us know.

Thanks!

avatar image pedrodacruz Sep 02 '15 at 09:59 PM

Thanks, Samantha! I have tried to copy the folder the last time... now I will try to find this migration tool you have told ...despite I have no Idea where it is...

Some hours later:

I have just tried to do what you said... could you please check if my steps were correct?

  1. Create a new Project in Unreal 4.9.0 (mobile project in my case);

  2. Open the 4.8.3 version;

  3. Right click on Content Folder (4.8.3 project);

  4. Select Migrate;

  5. Select Game Folder and click on "OK" button;

  6. Select Destination folder (in this case: ...My Documents\ Unreal Project\ Mirtilo\ Content)

  7. Opena Unreal Engine 4.9 again and configure some settings to Android);

  8. Run Game in Mobile Preview....

  9. Hit box is not working......

Could you please say what I have done wrong????

avatar image Samantha Sutton ♦♦ STAFF Sep 03 '15 at 07:43 PM

Hey!

Make sure that you set the migration destination to the new project 4.9.

You may also need to reconfigure the hitbox. If that does not work, I will need to request that you submit a new AnswerHub post and clearly detail all of the information about what you've done. I'd also suggest providing any screenshots of the changes you've made, or that have been made on your hitboxes.

Good luck! :)

avatar image pedrodacruz Oct 22 '15 at 11:32 PM

I migrated my project and the problem is solved! Thanks! ;)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Pedro,

There is a bug entered for these error messages in 4.9, you can check on this bug at any time by contacting us back through here and referencing: UE-18229.

If you have any further questions, please let us know. Have a great day! :)

more ▼

answered Aug 17 '15 at 05:39 PM

avatar image pedrodacruz Aug 17 '15 at 10:09 PM

Thanks... :´(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey, Samantha! Thank you for existing! Actually, this weekend I've tried to create the iOS version of the game, but my iphone 4 and my iPad 2 are presenting a similar problem, but vertically (it is showing two black stripes on both sides of screen)... should I create another question to iOS?

more ▼

answered Aug 03 '15 at 03:56 PM

avatar image

pedrodacruz
106 6 9 15

avatar image Samantha Sutton ♦♦ STAFF Aug 03 '15 at 06:22 PM

Hey Pedro,

Go ahead and create a new question for iOS and address the question towards me and I will be more than happy to look into this further for you. I have a plethora of iOS devices to test.

In the first question, please include the type of iOS device and what version of the OS it's on.

Thank you! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question