x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Vehicle Trigger Collider Bug

Hi! I have recently found out a bug with Colliders if i put them on a car. I want to make my car to detect if it's on the ground or is it flipped upside down, so i wanted to make two Triggers one at it's bottom and another one on it's top. After that i hit play to test it unfortanately the car floated, so the collider behave like it was a normal collider but i changed it to Trigger. Also for all option it works the same if i switch to No Collision of course it doesn't work. What could possibly go wrong? Thanks in advance!

At this forum link i have several images of my problem :

https://forums.unrealengine.com/showthread.php?78106-CarTest-Advanced-Vehicle-Kit&p=343443#post343443

Product Version: UE 4.8
Tags:
more ▼

asked Jul 30 '15 at 11:32 AM in Bug Reports

avatar image

Balint3DDesign
42 8 14 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Balint3DDesign,

We've recently had another user bring this issue to our attention where collision triggers that were set to no collision (or no physics collision) would still collide if parented to a vehicle. This issue has been fixed but the earliest build that has the fix integrated is the 4.9 Preview 1 that was just released. The thing that is different is that the options for Collision Enabled have been changed to have the following options:

Query Only (No Physics Collision) Physics Only (No Query Collision) Collision Enabled (Query and Physics)

To get your desired effect, you'd want the first option and you'll also want to set the box to Simulate Physics but not Enable Gravity. If the box isn't simulating physics, it will cause some issues with the vehicle's center of gravity.

Hope this helps!

Matthew Clark

more ▼

answered Jul 30 '15 at 06:32 PM

avatar image Balint3DDesign Jul 30 '15 at 06:53 PM

Thanks for the info! Also on the Forum, dcyoung give me a tip, to uncheck the autoweld option of the collider, under Physics Details, and that solved my problem!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question