x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Oculus Rift DK2 Unreal Engine 4.8.3 oppps

So oculus in windows was working fine. There were some problems in 4.8.1 but they were mostly fixed in 4.8.2... So today I get to work, fire it up and start working on parallax mapping... Load VR preview to check the work and low and behold the rift is now suffering from the plague that is the rift.

This problem is the silliest unprofessional problem I can find concerning the rift. It no longer will go over to the oculus. It just renders on the main monitor alt enter don't work... Nothing does... (w0hich I am not sure why anyone would really want to see the oculus on a 2d monitor unless they are bug testing)... This problem has plagued the oculus since I got one... where it is like swimming through a tank of piranhas to get it on the rift... UE has never had that problem for me.

Please advise....

Product Version: UE 4.8
Tags:
more ▼

asked Jul 31 '15 at 02:41 AM in Bug Reports

avatar image

Drixil
134 6 11 17

avatar image Immersive Aug 11 '15 at 10:27 AM

same problem here. EPIC FAIL!

FYI, not working on 4.9 preview2 neither

![well done!][]

[1]: /storage/temp/53691-ww1dh66.gif

ww1dh66.gif (173.0 kB)
(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi Immersive,

I am sorry to hear that your other machine's graphics card is not supported by oculus.

As you stated this is a support issue that was released by the oculus team.

There isn't anything that we can change internally to the engine for hardware compatibility with oculus.

Oculus use to support mac, however, they released a statement to say that they would not longer be supporting mac at this time.

I can put in a feature request to see if at a later version that we can support a "legacy" type option for oculus that would run with older graphics cards.

However, I do not see this being implemented anytime soon.

Let me know if this is what you would like me to do.

Thanks,

Logan

more ▼

answered Aug 13 '15 at 01:35 PM

avatar image Immersive Aug 13 '15 at 02:51 PM

Hi Logan,

If Epic guys could do it, it woud be great, as it would make UE more universal. However, now that we know the problem, in my opinion there are much more important things to do first (like mobile ad network integration or HTML5 easy packaging).

In our particular case we'll finish this project with UE4.7.6

At least I hope this post is useful for other developers: for GPUs under GTX 600 use UE4.7.6

thanks for your proactivity!

(comments are locked)
10|2000 characters needed characters left

Hello Drixil,

Here are the steps I implemented to recreate your issue.

I am working in 4.8.3

  1. Create a test project with the minimal default level.

  2. Played in VR Preview mode

  3. Observed no issue with the transferring of the preview to the occulus head set.

  4. Exited preview

  5. Saved Scene

  6. Closed Project

  7. Opened Project again

  8. Played in VR preview mode again

  9. Again observed no issue.

Troubleshooting for the occulus :

As a disclaimer I have had many issues with the occulus running smoothly as well.

My occulus runtime will crash periodically if it sits for long periods of time without being used.

  1. Make sure you have the latest runtime installed on your machine.

  2. Unplug your oculus and plug it back in. ( Not really sure why this works but hey it's worked for me.)

  3. Uninstall you oculus runtime and reinstall it. ( This will also require you to restart your machine a couple of times so you may want to hold off on restarting your machine until this step.)

As occulus is still in it's early experimental steps the device and it's software still has many bugs that are being discovered.

Not a fault by epic.

Here is a link to the oculus development page which has volumes of information. Everything from troubleshooting to compatibility and licenses.

Here is also a link to the oculus best practices guide.

http://static.oculus.com/sdk-downloads/documents/Oculus_Best_Practices_Guide.pdf

I was not able to recreate your issue however I had to troubleshoot the oculus device before being able to see a picture at all.

Again not a fault by epic.

I recommend going through these steps and looking through some of this documentation to see if in fact the problem lies with the oculus device that you are using.

Thanks,

Logan

more ▼

answered Aug 12 '15 at 02:01 PM

avatar image Immersive Aug 12 '15 at 03:25 PM

Hi Logan,

I already tried all that (and more) yesterday and all that I got with 4.8.3 was a black screen (both on oculus and pc) when pressing vr preview.

Same happened when running a packed version of the project.

Most impressive of all is that it still runs perfectly with UE 4.7.6, so if it's not a fault by Epic I don't know what else it could be.

I've tried it on two different computers with different runtimes (0.6.0.1 and 0.4.4) with same results: UE4.8.3 + oculus = fail // UE4.7.6 + oculus = success

In my opinion, engine updates should improve everything instead of having things broken, which unfortunately happens too often, so know that Epic is preparing 4.9, I guess it might be a good idea to be sure that everything is working great before delivering the update.

Best regards

avatar image Logan Bailey ♦♦ STAFF Aug 12 '15 at 03:44 PM

Hello Immersive,

I will need your DxDiag for both computers.

What I want you to do is to test this in a project. Open a project in 4.8.3 with the first person shooter template with no starter and then try and play the project in VR preview.

Thanks,

Logan

avatar image Logan Bailey ♦♦ STAFF Aug 12 '15 at 03:58 PM

The other thing that you can try is to test the steps in the previous post in 4.9.3.

This just came out yesterday.

The other thing is I have come across other users experiencing this issue. A troubleshoot that has worked as well is to play in stand alone. Then close that stand alone preview. Then launch again.

  • Logan

avatar image Logan Bailey ♦♦ STAFF Aug 12 '15 at 04:13 PM

The absolute last troubleshoot that I can possibly think of is to install your oculus with the 0.6.0.0 and see if that solves the issue.

-Logan

avatar image Immersive Aug 12 '15 at 04:39 PM

Hi again Logan,

I have managed to solve the issue in the most powerful computer. In this one I was using firmware 0.4.4 and VR preview wasn't even available in UE4.8.3. I updated to 0.6.0.1 and worked.

On the less powerful computer I already had the last firmware and there's where the black screen appears with UE4.8.3. Again, it works with 4.7.6, so I can't imagine where the problem can be, but seems to be related to last UE4 update and system requirements.

Also tried 4.9.3 and no luck

I'll make some more tests tomorrow.

Best

avatar image Immersive Aug 13 '15 at 10:21 AM

Hi again.

I attach both Dxdiag logs.

I have been investigating some more and found this greatness from oculus team: Only Nvidia GTX 600 series and above will be supported (just great)

As you'll see in the dxdiag log, the two computers where I tried it have these GPUs:

  • GeForce GTX 670 - works on UE 4.7.6 and 4.8.3

  • GeForce GTX 580 - works on UE 4.7.6. Doesn't work on 4.8.3

So, although we might be tempted to blame Oculus people for this (quick "solution"), something in UE 4.7.6 made it work. If Epic guys find out what it is and recover it, me and probably other developers would be so happy and grateful!

Thanks!

link text

dxdiag_bad.txt (41.2 kB)
dxdiag_good.txt (43.9 kB)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question