x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Missing Blueprint Nodes in 4.8.3.

Prior to 4.8.3, every time my editor would have these missing blueprint nodes, my editor would crash. With 4.8.3, it no longer crashes, but keeps the nodes missing.

alt text

alt text

Product Version: UE 4.8
Tags:
capture.jpg (206.2 kB)
capture2.jpg (247.8 kB)
more ▼

asked Aug 01 '15 at 07:02 PM in Bug Reports

avatar image

ProlixLegend
51 1 5 8

avatar image Adam Davis STAFF Aug 03 '15 at 03:15 PM

Hi ProlixLegend,

Does this occur in a clean, blank project with no additional content or is it limited to one project? What specific nodes are going misssing and what type of blueprint class are they implemented in?

avatar image ProlixLegend Aug 03 '15 at 11:34 PM

Hey Adam,

I tried to recreate the bug in a blank project but was unsuccessful. This issue has occurred in more than one project for me, but it occurs at rather random times so I'm having a difficult time tracking down what could cause it. It does seem to only occur in blueprints that derive from Character and most of the nodes that I'm zoomed in on go missing. The nodes that disappear seem to range from input actions, for-loops, branches, variable gets and sets, as well as several others.

avatar image Adam Davis STAFF Aug 04 '15 at 06:20 PM

What steps are you taking just before you see this occur?

avatar image ProlixLegend Aug 05 '15 at 11:23 AM

From the few times this has occurred to me so far, it has happened both briefly after switching tabs into my Character blueprint and after I compile my blueprint.

Edit: Now that I think about it, I've always had many tabs open when this has occurred so that may have something to do with it.

avatar image Rudy Q ♦♦ STAFF Aug 04 '15 at 06:27 PM

Hello ProlixLegend,

I have a couple of questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. If you go to file > Refresh all nodes for your blueprints does this bring back the nodes for that blueprint?

  2. Was this project upgraded from an older version of the engine?

avatar image ProlixLegend Aug 05 '15 at 11:27 AM
  1. I was not aware this option existed so I would need to try it when it occurs again. The work around I found is to close out of all the open tabs and restart the editor.

  2. The project was originally created for 4.5 and upgraded since to the current 4.8.3 version.

avatar image Adam Davis STAFF Aug 10 '15 at 05:29 PM

Hi ProlixLegend,

Has the error occurred after your most recent post?

avatar image John Alcatraz Aug 10 '15 at 06:09 PM

I also once or twice get this bug, but restarting the editor fixes it.

avatar image Adam Davis STAFF Aug 10 '15 at 07:11 PM

Hi John Alcatraz,

Does this occur with specific nodes or is it random? Do Rudy's steps help when you experience this error?

avatar image ProlixLegend Aug 10 '15 at 07:16 PM

This issue does still occurs for me every now and then. Restarting the editor is the only workaround that has worked for me. Refreshing the nodes like Rudy suggested doesn't fix the issue on my end.

avatar image Adam Davis STAFF Aug 11 '15 at 03:13 PM

Hi ProlixLegend,

Do you have a sample project displaying this behavior you'd be willing to share? I'll happily take a look to see if I can reproduce this on my end.

avatar image ProlixLegend Aug 11 '15 at 10:44 PM

Sure, I can let you test out the project I've experienced this issue most in. Is there a way to private message you on the forums here? I have the project on google drive, but it's something I'm working on for the marketplace so I'd prefer not to post the download link here.

avatar image Adam Davis STAFF Aug 12 '15 at 03:58 PM

If you upload it to a dedicated FTP service like dropbox and send me the link in a private message on the forums I can grab it there.

avatar image ProlixLegend Aug 13 '15 at 12:28 PM

Sent you a PM on the forums.

avatar image Adam Davis STAFF Aug 13 '15 at 02:17 PM

Hi ProlixLegend,

I looked through the blueprints in the project but did not see any missing nodes. What steps can I take to repro this with the project you sent?

avatar image ProlixLegend Aug 14 '15 at 01:18 AM

The missing blueprints occur to me when switching tabs into my character blueprint. I usually have many tabs open in the editor as I work across several corresponding animation and UMG blueprints and am constantly compiling and saving the project. As I switch between tabs, do ~30 seconds of work, compile, save, and switch back into the character blueprint, they go missing.

avatar image Adam Davis STAFF Aug 14 '15 at 03:37 PM

I haven't been able to reproduce this on my end. Are there any other steps that might be needed to recreate this on my end?

avatar image ProlixLegend Aug 16 '15 at 07:11 PM

There aren't any other steps that I can think of.

avatar image Adam Davis STAFF Aug 17 '15 at 05:38 PM

Can you post a copy of your dxdiag here so I can take a look?

avatar image ProlixLegend Aug 17 '15 at 11:16 PM

Here you go: link text

dxdiag.txt (72.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi ProlixLegend,

Unfortunately, we haven't been able to reproduce this on our end. We've tried on 4 different computers including both a macbook and a windows laptop with comparable hardware to your dxdiag. The last suggestion I can think of would be to make sure that your computer is not utilizing an integrated card when you open the editor instead of using your other video card. I'm going to mark this as answered for tracking purposes. If you find anything that can help to reproduce this on my end, I'll be happy to take another look.

more ▼

answered Aug 18 '15 at 06:00 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have same issue every time when i open blueprint if i do it very fast after project loaded and before assets was discovered. Also with visual bugs all over the place, like video artifacts, weird icons and stuff, but thats gone in one sec lag, i think its because im working on a laptop with integrated video (i dont have those issues on a pc), so this issue might be a hardware based.

more ▼

answered Aug 16 '15 at 07:24 PM

avatar image

CriErr
1.2k 57 21 58

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question