x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Add new supported culture (Hebrew)

I'm trying to make a game that supports Hebrew as a selectable language. I'm using Localization macros (LOCTEXT) and the Localization Dashboard, but in the "Add new cultures" menu it doesn't display Hebrew as an option. I even manually modified DefaultEditor.ini to have

 SupportedCulturesStatistics=((CultureName="en"),(CultureName="he_IL"))

It doesn't display the culture name properly but it does add the appropriate folders/files when gathering text/counting translations/compiling. However when I switch the current culture to he_IL it doesn't work, stays in English. I also see when packaging you have to select what to cook, and once again Hebrew isn't an option.

If I understand the Engine's code properly, it uses a 3rd party tool called icu4c, correct? Their website indicates it natively supports Hebrew (and other right-to-left- languages). Why doesn't Unreal support it? Is there something I can fiddle with so that it does?

Thanks

Product Version: UE 4.8
Tags:
more ▼

asked Aug 02 '15 at 05:46 AM in Using UE4

avatar image

repwolfe
56 2 7 11

avatar image repwolfe Aug 02 '15 at 12:41 PM

Work in progress: I managed to get Hebrew to be a recognized culture by adding all of the "he.res" references from Engine\Content\Internationalization\All\ to Engine\Content\Internationalization\icudt53l. It now correctly displays "Hebrew" in the Localization Dashboard as one of the cultures I'm translating, and the translation editor works fine. However I still can't

  1. Pick Hebrew from the list of available cultures in the Localization Dashboard or Packaging Settings menu

  2. Most importantly, **display hebrew tex**t. All characters appear as the same image (see screenshot below). This is true in the Editor and in the game itself.

avatar image repwolfe Aug 02 '15 at 12:43 PM

Screenshot of Hebrew Text

hebrew.png (64.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question