x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Steam is gone after packaging shipping build?

Hi. I have been trying to figure out whats wrong here. Development builds work great, and steamworks functions as expected. But when packaging a shipping build, steam just dissapares and will not work with the game. Ive added the app_id and DLLs to every directory there is with no results. I found this on the wiki:

"Module Setup

Make sure to include the Unreal Engine Steam module as part of your project. (see Unreal Build System Target Files for additional help)

Adding the following should be enough to make sure that the Steam module is built along with your game. It goes inside the constructor of mygame.build.cs

DynamicallyLoadedModuleNames.Add("OnlineSubsystemSteam");"

(source) https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/index.html

But when adding the above line to the game.build.cs it just generates compile error:

 Error    1    error CS0103: The name 'DynamicallyLoadedModuleNames' does not exist in the current context    c:\Users\Fox\Documents\Unreal Projects\game\Source\game.Target.cs    13    9    game
 Error    2    error : UnrealBuildTool encountered an error while compiling source files    C:\Users\Fox\Documents\Unreal Projects\game\Intermediate\ProjectFiles\EXEC    game
 Error    3    error CS0103: The name 'DynamicallyLoadedModuleNames' does not exist in the current context    c:\Users\Fox\Documents\Unreal Projects\game\Source\game.Target.cs    13    9    game
 Error    4    error : UnrealBuildTool encountered an error while compiling source files    C:\Users\Fox\Documents\Unreal Projects\game\Intermediate\ProjectFiles\EXEC    game
 

At this point im stuck and I cant get steam to work with a shipping build, forcing me to use development builds for the time being. I would greatly appreciate any help! Thanks.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 02 '15 at 06:11 PM in Packaging & Deployment

avatar image

MADHOUSE
375 22 37 58

avatar image TerryTheHammer Aug 06 '15 at 03:38 AM

I am having the same problem! Only working in development build. Have also attempted placing steam_appid.txt and dll to no avail. 4.8.3

avatar image Dannyk90 Sep 11 '15 at 08:56 AM

when you do it in dev mode, are you able to browse games ?

avatar image MADHOUSE Nov 22 '15 at 12:34 AM

On my end atleast development build works perfectly fine, online games can be client-side hosted, discovered in server list, and joined.

avatar image sgehrman Dec 24 '15 at 11:09 AM

Anyone ever figure this out? 4.10.1 still has the same problem.

avatar image Rama Apr 05 '16 at 09:44 PM

https://answers.unrealengine.com/questions/199746/steam-overlay-not-working-in-shipping-build.html

hmm, well it definitely doesn't work, even though the steam dll is in thirdparty of engine folder.

edit see my answer

Rama

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Solution steam_appid.txt

https://answers.unrealengine.com/questions/199746/steam-overlay-not-working-in-shipping-build.html

I've tested as of 4.11, if you do a shipping build, the thirdparty steam .dll is included, but you have to add the following file to YourGame/Binaries/Win32

steam_appid.txt

and in that file put just your app id with no whitespaces

Then when you launch the steam overlay will appear :)

Wiki Updated

https://wiki.unrealengine.com/Steam,_Using_the_Steam_SDK_During_Development#Packaging_w.2F_Steam_for_Shipping_Builds

Rama

more ▼

answered Apr 05 '16 at 11:21 PM

avatar image

Rama
10.6k 445 343 1083

avatar image MADHOUSE Apr 12 '16 at 07:46 PM

Hi Rama, thanks for the update on the situation. I can confirm that steamworks now work in shipping builds using the latest 4.11.1 build.

I add the steam_app.txt to Win64 folder instead, (using win64 builds) cheers!

avatar image TheoT Mar 02 '17 at 12:05 AM

Hi!

I am having the same problem but following this did not solve it.

Could you give me the exact location where to put the steam_app.txt, is it as Rama said to "YourGame/Binaries/Win32" (in which case I would have to create those new folders) or is it that he refers to YourGame/Engine/Binaries/ThirdParty/Steamworks/Steamv132/Win64 folder? I take it that adding the txt file is done before compiling the shipping version of the game? Thanks!

avatar image MADHOUSE Mar 02 '17 at 02:42 AM

Greetings. Make sure to place the steam_appid.txt next to the executables of your packaged build. (For example, a win64 build would have its executables here: TheGame\Binaries\Win64) Also make sure steam online subsystem is activated in the plugins browser in the editor etc.

The steam_appid.txt file is added after you have compiled and packaged your game, so the folders are already created and it needs to be placed next to the games main binary/exe files.

I hope this helps. Best Regards!

avatar image TheoT Mar 02 '17 at 03:34 PM

Thanks that helped!

avatar image TorQueMoD Nov 08 '17 at 08:09 AM

Glad there's a simple fix. Strange that the engine doesn't create this file for you though.

avatar image TorQueMoD Nov 08 '17 at 11:32 PM

Ok this is strange. Yesterday when I did this, it fixed the problem with Steam not loading. I updated my game via Steamworks and released. Now when I launch the game, it no longer fixes the problem. I've got my steam_appid.txt file in the binaries folder along with the exe but when you launch the game, Steam's overlay doesn't work anymore. I'm very confused.

avatar image TorQueMoD Nov 08 '17 at 11:40 PM

Nevermind. Turns out Fraps was disabling the Steam overlay. Strange, but I guess it's part of the program. I quit Fraps and it started working again.

avatar image Ethan_Sherr Nov 13 '18 at 02:07 AM

In the case of mac, would I add steam_appid.txt to ./MyProject/Binaries/Mac/ ? because what I find is doing so makes the file literally disappear when I run the app!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question