x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Textures too bright, am I missing something?

Okay I seem to remember having this problem before, but I never wound up finding a fix for it. I'm at a point where it needs to be fixed. I've looked around and tried the sRGB checkbox both on and off in the texture editor as well as changing from color to linear color and back in the texture sampler. When I have sRGB unchecked and linear color enabled it shows the right color in the thumbnail but then the wrong one in the texture sampler and level.

I assume I'm missing some small detail. Problem is that I've searched and people just mention switching to 8 bit textures to fix it or just fiddling with the sRGB and linear color/color settings. I'd like to not have to reformat all my textures to 8-bit because I have a lot that I've generated so if there is another way I'm all ears.

alt text

Product Version: UE 4.9 Preview
Tags:
more ▼

asked Aug 03 '15 at 11:11 AM in Rendering

avatar image

JoshieZombie
271 22 20 26

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello JoshieZombie,

You could try checking sRGB to true inside of your texture editor.

Changing to an 8-bit image is the tried and most effective method for fixing this issue.

If you are looking for a quick work around, there is also the option :

1.Create constant vector

2.Add multiply Node

3.Add your Texture sample into the A of your multiply node

4.Add your constant vector to your multiply node

5.Plug that into your Base/Diffuse Channel

For more control after the multiply node add a clamp node and set the min to 0 and max to 1 ( This will set a value that cannot be exceeded for any values higher than 1.

Thanks,

Logan

more ▼

answered Aug 03 '15 at 01:54 PM

avatar image weberl Feb 07 '16 at 02:36 PM

I had the same issue. Exporting the textures as .tga files solved it for me.

avatar image RomuloFerreira Jun 23 '16 at 06:44 AM

Thanks, I was trying so hard to solve this issue, the only thing that worked, was saving the texture in 8-bit.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question