x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Static dir lights work with ES2 but not with Shadel Model 5.

Hi! I'm working on a game that it's aimed for mobile and had a question about lighting. I have 3 directional lights in a scene: 1 for the sun and 2 as a sky fill. The sun dir. light is set to moveable, light intensity 8 and casts shadow. The 2 sky fill dir. light are set to static, light intensity 0.5 and don't casts shadows. (I also have global illumination set to 0). If I set the Preview Rendering Level to Shader Model 5 and build lighting, it looks like the 2 static lights are not working: alt text And if I set it to Mobile and build lighting, they appear to work just fine: alt text So, just to understand how all of this works, I was wondering why the 2 static lights are not working with Shader Model 5. Is there an option I might have messed with? Thanks.

Product Version: UE 4.8
Tags:
1.jpg (82.9 kB)
2.jpg (86.1 kB)
more ▼

asked Aug 05 '15 at 03:36 PM in Rendering

avatar image

AntonioE
21 2 4 6

avatar image Logan Bailey ♦♦ STAFF Aug 05 '15 at 06:59 PM

Hello AntonioE,

Typically inside of an environment there is one directional light for casting shadows, as you mentioned, and a sky light for fill.

What I imagine is happening is that your directional lights are competing with each other.

You mentioned that your first light is set to 8 and the other two are set to .5.

That dominant light is overpowering the other two.

What you can do is create a test project with three directional lights and set them all to a value of 8. Then gradually dim two until you are unable to see them anymore.

You can also try the above mentioned and add a sky light while eliminating the two directional lights.

There are different render settings for each rendering level.

You may have to tweak your settings inside of your lights to achieve the affect that you want.

Lighting builds calculate everything from light angles/bounce/falloff and of course shadows.

The other test you could perform is to turn the shadows on, on your static lights and then build lighting again.

Thanks,

Logan

avatar image AntonioE Aug 05 '15 at 09:12 PM

Thanks a lot for the reply!
Yeah, I think I will definitely use a skylight instead of the 2 extra directional lights.
Just for the sake of it I did a test in a new project: 3 directional lights, same intensity and they all have shadows on. Also Global illumination is set to 0 and Preview Rendering Level to Shader Model 5. Here is how it looks just with 1 moveable directional light: alt text 3 directional lights, 1 set to movable and the other 2 to stationary and click build: alt text 3 directional lights, 1 set to movable and the other 2 to static and click build: alt text 3 directional lights, 1 set to movable and the other 2 to static, Preview Rendering Level set to Mobile and click build: alt text So the 2 dir. lights set to static are not doing anything in the third picture. It looks like the first picture. I want to understand if I'm just not allowed use dir. lights this way or I'm doing something wrong and why it does look ok with Preview Rendering Level set to Mobile. I'm still switching to a skylight though. Thanks.

a.jpg (116.3 kB)
b.jpg (125.3 kB)
c.jpg (122.8 kB)
d.jpg (102.3 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey AntonioE,

I was able to recreate what you were experiencing with the workflow that you used.

First, global illumination refers to the intensity of static lighting being processed inside of your scene. It does not refer to a light being created that effects the entire world.

Think of global illumination as dimmer switch. Turned all the way down to 0 you will not see the light. Set to max you will see the full intensity of the light.

Recreate this test, or if you saved use the on you had, and set the global illumination to 1. You can set it higher but for this test 1 will do. This tells the engine to multiply all of the static light values and multiply them by 1.

Thanks,

Logan

more ▼

answered Aug 06 '15 at 02:12 PM

avatar image AntonioE Aug 06 '15 at 02:39 PM

Wow... everything makes sense now. Thanks a lot Logan!. Sorry for the newb questions.

avatar image Logan Bailey ♦♦ STAFF Aug 06 '15 at 03:05 PM

Not a problem,

That is what we're here for.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question