x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot for the life of me make a completely dark map!

I am trying to make a completely dark forest level with only a few torches as light sources. However, the floor material seems to give off light! The mountain textures off in the distance are completely visible along with all the textures in the world. I would really appreciate some help. Even if I go into the unreal editor sample maps and delete everything except one floor including the skybox, source light, etc all the materials are still completely visible! argh! What am I doing wrong?

Side question: Also, the skybox in general seems to give off light. According to the coding when the sun is at a certain point it should fire off the part of the script where the stars come out but no mater where I place the sun it only gets to dusk even if it is directly below the map.

Product Version: Not Selected
Tags:
more ▼

asked Apr 10 '14 at 03:45 AM in Using UE4

avatar image

DeDareDevil
16 2 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This took me awhile too. I eventually went to 'World Settings' which is next to details; The 'Environment Intensity' value might be the missing piece of your puzzle, it was for me. I lowered that value and rebuilt the level to finally get darkness.

more ▼

answered Apr 10 '14 at 04:30 AM

avatar image

ruBOT
174 4 5 11

avatar image DeDareDevil Apr 10 '14 at 05:06 AM

OMG dude you saved me! There was the missing piece! Thanks again man I really appreciate you taking your time to help me out. =D

avatar image ruBOT Apr 10 '14 at 05:25 AM

Awesome! I'm very glad I was able to help.

avatar image xbelanch Aug 04 '14 at 12:15 AM

Sorry guys, but I have a similar problem. Thanks to thread I solved the "lighting environment" at night, but as you can see at the next captures I have another issue: the stones (imported from Blender as fbx) that shape the landscape (as a foliage) revels its bottom side (fully and hard illuminated!). Any ideas? Thanks in advance!

alt text

alt text

cap1.jpeg (170.1 kB)
cap2.jpg (164.6 kB)
avatar image TJ V ♦♦ STAFF Aug 04 '14 at 07:37 PM

Hi xbelanch,

The Light Source (Sun) is shining though the landscape. Our developers are aware that night-time light can be an issue and are looking into it. Try turning the Intensity of the Light Source to 0.

If you have a dynamic day/night cycle you can do this in blueprints to turn the intensity down at dusk and back up at dawn.

Thanks, TJ

avatar image xbelanch Aug 04 '14 at 10:48 PM

Thanks TJ! meanwhile I used this Blueprint to deal with it: https://wiki.unrealengine.com/Tutorial:_Time_of_Day I recommended it (and helps a bit to understand the logic behind the Blueprint system)

avatar image DeDareDevil Aug 04 '14 at 01:43 AM

Hmm, I am not quite sure. I hope someone finds this thread and can help you out. Perhaps mess with the settings a bit more. I am glad this thread help with the nighttime lighting.

avatar image DeDareDevil Apr 10 '14 at 05:31 AM

Hey ruBOt this worked PERFECT on my little test map. I then added, instead of a box brush, the landscape and the landscape is bright regardless of world settings.

avatar image ruBOT Apr 10 '14 at 05:47 AM

Each time that happens I think you have to click build. I've personally deleted every light and use only a 'Directional Light' set to a low/dark value to control my light settings. I set the directional light to about 20-40 intensity and pump it up to 100 for visibility while editing.

avatar image DeDareDevil Apr 10 '14 at 06:38 AM

Ok ruBOT, first of all thanks SOOO much for your initial help it was an relief to finally get that part fixed. On a regular map with normal box brushes and what not your way works EXACTLY how I want it to. But once I add a terrain brush even when I click build it still doesn't work. It acts as if the intensity is still at 1 in world setting when it is actually at 0.1

I feel really bad for asking questions and I never do but this just feels like when you have a word on the tip of your tongue. I know it's such an easy fix but it is just something super small I am overlooking!

alt text

alt text

avatar image Jacky Apr 10 '14 at 06:44 AM

You need to play with Auto Exposure settings(and maybe even with contrast a little bit) in the post process volume. Adjusting the environment color and intensity helps only with static shadows after building lights.

avatar image DeDareDevil Apr 10 '14 at 07:05 AM

I can't seem to find the right setting. Auto Exposure did make it darker but more like I was wearing sun glasses. The texture however still seems to be giving on "light" =(

avatar image DeDareDevil Apr 10 '14 at 08:00 AM

FIXXXEEED! Soo simple! And my girlfriend who was sitting next to me pointed it out lol. Go to "World Settings" located near the build button Scroll down to "Lightmass" Change the environmental color to black!

avatar image jonbellini Jan 08 '16 at 06:17 PM

I had this same problem but in addition to changing the "Environment Intensity", I also had to lower the "Num Indirect Lighting Bounce" (to zero to make darkness).

avatar image jonbellini Jan 18 '16 at 10:13 PM

also 'World Setting' is in the Window Menu Item..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question