x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AI doesn't move in packaged game

Hello guys. I've recently upgraded my project to 4.8 from 4.7 and now my ai character just doesn't want to move in the packaged game. There is no problem when playing in the editor. I tried to visualize the navmesh in the packaged game by executing the blueprint node "Execute Console Command" with command "show navigation" but doesn't show anything (btw I don't know if this is available in a game packaged with shipping configuration).

Thanks,

Gabor

Product Version: UE 4.8
Tags:
more ▼

asked Aug 06 '15 at 09:33 PM in Packaging & Deployment

avatar image

Gabor D.
31 1 3 7

avatar image Samantha Sutton ♦♦ STAFF Aug 07 '15 at 03:28 PM

Hey EasternWize,

Thank you for bringing this to our attention. Are you using custom AI or are you using AI from one of the templates or learning projects we have available? Are you able to replicate this AI issue with a regular Unreal Engine 4 template? Have you tried copying your project to a 4.9 Preview 2 version to see if the same issue persists?

Looking forward to hearing back from you, thanks!

avatar image Gabor D. Aug 07 '15 at 08:08 PM

Hi Samantha,

Thanks for the quick response! I'm using custom AI. Tried it with 4.9 preview 2 with same results. Works in editor, doesn't work in packaged game. I also tried packaging the example project posted here: Behaviour trees support stream and it seems that it's fine. I think I'm gonna check my behaviour tree.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

So, in the project settings under Navigation Mesh I checked Forced Rebuild on Load and changed Runtime Generation to Dynamic (same as in my RecastNavMesh-Default) and tadaaaa... now my AI started to move in the packaged project.

more ▼

answered Aug 07 '15 at 09:13 PM

avatar image

Gabor D.
31 1 3 7

avatar image Samantha Sutton ♦♦ STAFF Aug 11 '15 at 06:08 PM

Glad to see that your AI is finally working. If you happen to have any further questions, let us know!

Have a great day!

avatar image TonyCrusher Dec 18 '18 at 06:09 PM

I did the sam ething but did'nt worked for me and I'm using UE4 4.21

avatar image dark marvado Oct 24 '18 at 03:51 AM

I might have a similar issue, AI moves fine on editor, but when I launch the game the issue comes, sometimes in the first level, but sometimes the first level works, then the AI will be freezed on the second level, if I change the project settings, Runtime Generation to Dynamic and check forced rebuild on load, the AI moves, but spinning like crazy, with difficult to continue towards the player as it does fine in the editor. I need help!

avatar image DaGaffer Nov 24 '18 at 07:36 PM

There is apparently a bug with Navmeshes in packaged builds in 4.21.0 that may be what you are seeing.

There are gaps on the edges of every tile that the AIs cannot path over. One hopes this will get fixed rapidly - unfortunately there is apparently no way to see the bugs that have been submitted on this right now, but you can see the problem discussed here:

https://answers.unrealengine.com/questions/847685/view.html

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question