x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

TextRender not visible on ios

I've built a project where I am using TextRenderActor to display some text but when I run it on the iPhone device and on the Mobile Preview, the text is not visible.

What is going on and how can I fix it.

Cheers, Andrew

Product Version: Not Selected
Tags:
more ▼

asked Apr 10 '14 at 02:14 PM in Bug Reports

avatar image

adoug
11 3 4 7

avatar image codingfornirvana Sep 14 '14 at 10:54 PM

I have started to get this issue since i updated to 4.4.2. I updated to 4.4.3, but the issue still exists.

Can someone please confirm?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

7 answers: sort voted first

Hi everyone,

I was able to reproduce this on my end and have entered in a bug report, TTP#347624 to be assessed by the development staff. Thank you and have a great day!

more ▼

answered Sep 24 '14 at 07:03 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi adoug,

This is a known issue that is currently being assessed by the development staff. Thank you and have a great day!

more ▼

answered Apr 10 '14 at 08:24 PM

avatar image adoug Apr 11 '14 at 09:18 AM

Is there any text rendering functionality that is available on ios? Is there a minimal working implementation of TextRenderActor that I can use while this issue is being resolved?

avatar image Thomas Ingham Jul 09 '14 at 09:28 PM

What's the status of this feature?

avatar image Awdogsgo2heaven Jul 10 '14 at 11:58 PM
  1. This is still an issue, what is the status of this? Hardly can make a game with out 'Text'

avatar image Adam Davis STAFF Jul 11 '14 at 03:21 PM

Hi everyone,

When specifically is the error occurring? Can you see the text in mobile preview but not in a packaged product? Does it show up in standard viewports? Has this occurred in a clean project with no additional content? Thank you!

avatar image Awdogsgo2heaven Jul 11 '14 at 08:10 PM

I'm not seeing it in the mobile preview. I haven't tried recreating my project in 4.3 , I created it in 4.2. Though I hope that's not the solution, I'll try it. I guess this implies the issue has been fixed at some point?

avatar image Adam Davis STAFF Jul 11 '14 at 08:42 PM

Hi Awdogsgo2heaven,

Yes, if it works in 4.3 that means that most likely it was altered or fixed at some point. What devices are you currently packaging for?

avatar image Awdogsgo2heaven Jul 12 '14 at 06:59 AM

iOS primarily.

avatar image Adam Davis STAFF Jul 12 '14 at 06:03 PM

Hi Awdogsgo2heaven,

I mean what specific phone or table models are you working on? This can help us to see if there are specific devices this is not working properly on.

avatar image Awdogsgo2heaven Jul 12 '14 at 10:15 PM

I tested this on iPhone 5, and iPad 4, in both the Text from Text Renderer will not show, It won't show in the Mobile preview either. I also tried creating a 'Blank' project, add a Text Render Actor to it, and then use Mobile Preview and it didn't show.

avatar image Adam Davis STAFF Jul 15 '14 at 10:21 PM

Hi Awdogsgo2heaven,

I was able to reproduce this on my end and have entered in a bug report to be assessed. Thank you!

avatar image Awdogsgo2heaven Jul 16 '14 at 11:27 PM

Thanks Adam. Do you guys have a public bug tracker so we can watch the progress on these bugs?

avatar image Adam Davis STAFF Jul 17 '14 at 12:57 PM

Hi Awdogsgo2heaven,

Currently we don't have a public bug tracker.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

hi,

in 4.2 version same issue.....

,Hi,

In unreal engine 4.2 this the same problem.... the text is not visible.

more ▼

answered Jun 06 '14 at 09:21 AM

avatar image

Cyril
6 1

avatar image Zaeran24 Aug 04 '14 at 02:30 PM

Doesn't work for me on 4.3 either.

avatar image Alexander Paschall ♦♦ EPIC Aug 04 '14 at 04:14 PM

Hello,

You are correct, this has not been fixed for 4.3, 4.3.1 or 4.4 preview, however the report has just recently been updated as fixed and verified by our internal QA. The fix will go to the public binary in an upcoming release soon.

Thank you,

Alexander

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Had the same problem and fixed it by setting the font material to "Unlit and Transluscent". (works on my Android device), also you can check the TappyChicken sample.

Again, I'm not sure if it works on iPhone devices, you can try and tell us the result ?

Cheers

more ▼

answered Jun 06 '14 at 11:51 AM

avatar image

Singleton
61 2 6 9

avatar image Cyril Jun 06 '14 at 02:16 PM

I change to Until and translucent. doesn't work...

But with TappyChicken the texture material work fine.

Have a special font texture ? or you use the system engine font ?

avatar image Singleton Jun 06 '14 at 02:22 PM

Tried with a new Font (you can easily create one within UE)

avatar image Singleton Jun 06 '14 at 08:04 PM

Be aware that in 4.1 (haven't tested it on 4.2), anytime you make a modification on a font, you'll have to compile it, close it and re-open it to see the modification applied.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I still have this issue on 4.10.4. My text is not displaying on my iphone6. It does display in my preview.

Another weird thing is that if I build my project from unreal installer, it shows up on my device. But if I build from unreal source on github, my font does not show up on my device.

I also get this message in my xcode console:

Feb 26 22:59:39 Joshs-iPhone SWShooting[1612] : [2016.02.27-05.59.39:245][ 0]LogSlate:Warning: 'Roboto' does not provide a composite font that can be used with Slate. Slate will be forced to use the fallback font path which may be slower.

more ▼

answered Feb 27 '16 at 06:31 AM

avatar image

joshmmo
23 4 11 12

avatar image Adam Davis STAFF Mar 01 '16 at 07:13 PM

HI joshmmo,

This specific error is from several years ago and as such the editor has gone through significant changes. Please open a new answerhub post in the bug reports section so we can assist you more in depth.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have started to get this issue since i updated to 4.4.2. I updated to 4.4.3, but the issue still exists.

Can someone please confirm?

more ▼

answered Sep 14 '14 at 10:56 PM

avatar image

codingfornirvana
6 2 3

avatar image Alexander Paschall ♦♦ EPIC Sep 15 '14 at 02:52 PM

Hi,

I am a bit confused by this, we have not created a 4.4.3 build for UE4. Do you mean you using a source build of 4.5? If you can clarify that, we will be able to test the issue and investigate further.

Thank you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Alexander ,

Thanks for your quick reply. I checked out from the git source branch 4.4 and tagged as 4.4.3. I found it had bunch of problems when trying to run it on the iPhone 5s device.

The other problem was the papersprite won't be visible on the device, but will be visible in the mobile preview. The lightning was completely different on device that from the preview.

So to confirm, I created a production package and installed on my phone from iTunes. But, the issue still existed.

Please let me know if you further need more information.

more ▼

answered Sep 15 '14 at 03:01 PM

avatar image

codingfornirvana
6 2 3

avatar image Adam Davis STAFF Sep 15 '14 at 05:40 PM

Hi codingfornirvana,

Does this occur on a clean project with no additional content? Additionally, does this occur in the mobile preview mode or only after packaging and launching on an iPhone device?

avatar image codingfornirvana Sep 15 '14 at 06:23 PM

When u say additional content , do u mean third party content ? The only additional content I added was a static mesh from blender. This only happens after packaging and launching on the device. The preview mode works great.

avatar image Adam Davis STAFF Sep 15 '14 at 06:25 PM

Hi codingfornirvana,

What I mean is, if you create an absolutely blank project and add nothing to it (including the starter content from the editor), then you create a text render actor and launch to a device, does this bug still occur?

avatar image codingfornirvana Sep 15 '14 at 07:20 PM

Let me try it tonight once I reach home.

avatar image codingfornirvana Sep 16 '14 at 02:17 AM

So i tried in Unreal 4.4.2 , since i checked out 4.4.2 from repo as 4.4.3 wasn't working for text. I did a fresh start and completely new project.

Here is how it looks like on the device. alt text

The vertical boxes are suppose to be text.

photo.png (681.3 kB)
avatar image Adam Davis STAFF Sep 17 '14 at 06:52 PM

Does this occur when you change the font style?

avatar image codingfornirvana Sep 17 '14 at 06:54 PM

Its the default style. I never changed the style or font. It works fine in the preview, but happens when i install on the device.

avatar image Adam Davis STAFF Sep 17 '14 at 06:57 PM

try changing to a different font. To access them you may have to enable engine contents in the view options menu of the content browser.

avatar image codingfornirvana Sep 17 '14 at 06:58 PM

ohh i did not try that. Let me try it tonight. Thanks.

avatar image codingfornirvana Sep 18 '14 at 12:06 AM

alt text

I tried to use the fonts from the engine, but the other fonts are completely busted. They are not properly visible in Preview except "RobotoDistanceField", which works only in preview.

avatar image Adam Davis STAFF Sep 23 '14 at 01:36 PM

Hi codingfornirvana,

I just tested on an iphone 5S and was able to see the textrender actor in tappy chicken. What model of iOS device do you have? This may be device specific.

avatar image codingfornirvana Sep 24 '14 at 07:22 PM

Phew !! I thought i was doing something wrong.

Thanks :)

avatar image codingfornirvana Sep 23 '14 at 06:34 PM

I am having iPhone5s, iOS 7. I remember seeing the text working fine when the text was loaded directly from the project.

The text renderer was not working when i was trying to create one.

avatar image theonecalledtom Jun 26 '15 at 06:05 PM

Hitting this now (textrender works fine on PC and MAC but not visible on iOS8 loaded iPhone5 NOR in mobile preview. Can't see a solution in the above thread - there must be one but what is it?

avatar image theonecalledtom Jun 26 '15 at 07:16 PM

And then it appeared (in preview at least) ... For a bit I thought this might be because I branched the material and moved to translucent but then I realised that text I hadn't swtiched over had started working.

Other changes I made in the meantime included switching on HDR for mobile (which I think got my particle effects working, at least in preview) and enabling metal.

avatar image theonecalledtom Jun 28 '15 at 04:54 AM

Didn't appear on the device, until I deleted all intermediate data, then a few builds after showed the text, and now it's gone again.

avatar image Adam Davis STAFF Jun 28 '15 at 02:00 PM

Hi theonecalledtom,

This should be fixed as of 4.6, what version of the editor are you currently using? Additionally, what font and scale are you using in your text render actors? You said they appear if you delete the intermediate data but disappear again once you have intermediate data once more? Do you have anything that could be overriding the text render information?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question