x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't reinstall UE4 or EpicGamesLauncher, due to older version

I just upgraded from Windows 7 to 10, retaining my previous files and applications. I tried launching the EpicGamesLauncher but had an error, so I tried reinstalling the entire engine from scratch instead.

It won't let me, because it gets stuck trying to remove the older installation. It gives me the following error:

alt text

I've tried to uninstall and delete all traces of both the launcher and Unreal Engine, but for some reason, the latest installer still thinks the launcher is already installed, even after removing every trace I could find of the engine. The latest installer gets stuck at the "Removing applications" step where it tries to remove previous versions.

I've tried force-uninstalling all previous versions using programs like CCleaner and Revo Uninstaller, but no luck. They just give me the same error as above.

Is there a chance that someone at Epic has this .MSI file somewhere in their archives? If I can just supply the msi it's looking for, I think it will finally remove the old version. Or is there a way to "force" the installer to continue by making it ignore previous versions?

Product Version: Epic Games Launcher
Tags:
untitled.png (9.0 kB)
more ▼

asked Aug 08 '15 at 05:58 AM in Installation & Setup

avatar image

pvalencia
46 3 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Can't believe it, but I managed to fix the issue, and it didn't require formatting my drive (phew!).

Basically, the Microsoft Installer stores a record of all previous MSIs that have been installed in C:\Windows\Installer.

I went into my "Windows.old" backup directory (created by the Win10 upgrade process), went into Windows\Installer, and copied over the directory to my new Installer folder (made a backup of the existing directory just in case)

Then I re-ran the latest UE4 installer, and it worked! It managed to find the MSI it was looking for, and proceeded with the installation as normal.

So if anyone else out there has this issue too, go into your C:\Windows.old\Windows\Installer folder, and copy all of the folder's contents to your C:\Windows\Windows\Installer folder. This will ensure that the newest UE4 installer will find all past versions of the engine/launcher and remove them properly.

more ▼

answered Aug 08 '15 at 08:09 AM

avatar image

pvalencia
46 3 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question