x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VERY Slow UI after updating to windows 10

So recently, since i upgraded to the retail version of windows 10 (x64 ), I noticed that whatever i try to use any of the user interface elements in the UE4 Editor everything will slowdown to crawl, If my mouse is not on any UI element the editor goes back to normal speed but anything from hovering A Button or element in the content browser or any of the editor UI Elements makes the engine slowdown a LOT to the point where its almost unuseable Kinda feels like the engine thinks i have alt-tabbed out / minimized the engine window and it slowdowns...

Product Version: UE 4.8
Tags:
more ▼

asked Aug 10 '15 at 12:54 PM in Bug Reports

avatar image

alvarofer0020
90 15 17 23

avatar image Matt.Williams Aug 12 '15 at 08:22 PM

Hi alvarofer0020,

We've had reports of poor performance with outdated graphics drivers. Have you updated your drivers since moving to Win10? Can you send along your dxdiag?

-Matt W.

avatar image alvarofer0020 Aug 12 '15 at 08:30 PM

Hey, Yes i do have updated my drivers and sure here is my dxdiaglink text

dxdiag.txt (81.8 kB)
avatar image Matt.Williams Aug 14 '15 at 06:49 PM

Dxdiag indicates that you're not on the absolute latest drivers. Please update to these drivers.

-Matt W.

EDIT: Could you also try downloading the 4.9 Preview build and tell me if the same issue is still occurring?

avatar image alvarofer0020 Aug 15 '15 at 04:09 PM

Hey, i tried both updating my drivers and using the 4.9 Preview and still the issue persists, it even happens with the Tooltips on the Launcher

I even tried a clean install of windows and the result is still the same

avatar image Saphir88 Oct 28 '15 at 05:54 PM

Hello guys ! I've the same problem. My viewport is very fast but the Unreal engine UI (Modes, World Outliner, Content Browser, ...) is slow.

My Dxdiag

Can you help me ? I have tried to clean the windows notification but nothing change.

Thank you ;)

dxdiag.txt (71.0 kB)
avatar image Matt.Williams Nov 04 '15 at 04:22 PM

Hi Saphir88,

Could you open up a new AH thread for this issue? If the same fix doesn't help you then it's a separate bug. We'll be able to investigate it more thoroughly without cluttering up this thread.

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Ok so i think i might have found the source of the issue, cleaning the all of the Windows Notifications from the Notifications Windows before opening the Launcher and the Engine seems to fix the issue, no more tooltip slow downs!

more ▼

answered Aug 16 '15 at 11:55 AM

avatar image

alvarofer0020
90 15 17 23

avatar image Matt.Williams Aug 21 '15 at 01:55 PM

Thanks I've added this info to our Software Conflicts wiki. I'll try to repro in house and if I can, I will enter a bug. No guarantee though that this is an engine bug and not a Win10 bug.

-Matt W.

avatar image Affebonbons Jan 12 '16 at 06:30 AM

Having the exact same problem (extremely slow response with everything except the viewport) after upgrading; tried to clean notifications, but there are none. Tried fresh install of Epic Launcher and UE4, absolutely the newest drivers for sure, didn't have this issue before upgrading. Any help is much appreciated, thanks. Asus G75VX 670MX 3GB GDDR5 18GB DDR3 3.2 Intel i7; had no issues before this

avatar image Matt.Williams Jan 13 '16 at 06:25 PM

Hey Affebonbons,

Can you check the Software Conflicts page(see my previous comment) for some of the issues that Keiyentai has mentioned. If none of those issues are present, please open a new Answerhub thread as this one is rather old.

-Matt W.

avatar image Keiyentai Jan 12 '16 at 10:07 AM

One thing I have noticed since upgrading to Windows 10 is if you use any program like MSI AfterBurner or EVGA Precission X the OSD for the RiviaTuner/Server will mess with UE4 4.9+ you either need to uinstall them or turn them off and shut down the RiviaTuner Server if it's up which it normally has it's own icon that looks like a monitor with purple number in the corner. Apparently how Windows 10 handle graphic hooks conflicts with On Screen Display and UE4 mainly for those programs. I have an i7 950 3.06Ghz (3.3 Boost), 24GB DDR3 G.Skill RAM and a Titan X 12GB so ya even with that machine just having AfterBurner/Precission X/RiviaTuner on/running really kills performance. Hope it helps some.

avatar image Ian_Tetrault Feb 14 '19 at 01:36 AM

Very good Alva! Notificayions is what causes it! Thanks...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For those coming here from google, here's what I did (based on the software conflicts page):

1) Disabled the action (notification) center altogether. I added a 32 bit DWORD key in regedit:

 [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\Explorer]
 name: DisableNotificationCenter
 value: 1

...you can set this to 0 or delete the key if you want your notifications back. This only marginally improved performance. The real fix was:

2) Found Sonic Suite 2 running in my system tray. Right click / Exit. This alleviated all UI-based performance issues for me.

Icon: alt text

On a related note, it also fixed this:

  • Created a simple 1st person project and opened it.

  • Double clicked the HUD blueprint to edit (and moved the tab to the main window).

  • Clicked Play (with the blueprint editor open the play begins in a new window instead of the 3d viewport).

  • Game began playing but at like 2 frames per second.

  • Hit escape and switched back to the 3d editor window, game plays fine in the 3d viewport.

Shutting down "Sonic Suite 2" solved this as well.

FWIW,

-Mike M

sonicstudio2.jpg (18.4 kB)
more ▼

answered Feb 10 '16 at 02:56 AM

avatar image

zorque
36 1 72 5

avatar image Matt.Williams Feb 10 '16 at 07:24 PM

Hey Mike,

Thanks for adding this!! I'll still be accepting the other answer, but I've added a link to this Answerhub thread to the Software Conflicts page as a more permanent solution to the Windows10 notifications issue.

-Matt W.

EDIT: Throwing some karma points your way since we can only accept one answer

avatar image dvine Dec 16 '16 at 11:28 PM

Part 2, quitting "Sonic Suite" fixed this for me on my clean install of Windows 10 and Unreal Engine 4.14.1.

I would have not found the solution otherwise, thanks for the fix Zorque.

avatar image rathborne May 10 '17 at 09:52 AM

Thanks, zorque, for that regedit tip. It transformed my editor from an unusable 25fps/40ms to 120fps/8ms :) . I still get a huge performance drop when hovering over UI elements but disabling the Windows 10 notification centre has made a massive difference for me. Update: Seems that was part of the issue. The other thing that I need to do if I want to see usable performance in the editor is to turn the machine on, close down everything in the taskbar (eg Razer Surround, Duet, Steam, Nvidia), not open other programs, then open the Unreal Editor. If I do all this I get my 120fps/8ms editor performance.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

How to Make Windows 10 PC fast

  1. Disable Background Apps Go to Settings -> Privacy -> Background apps and disable all unwanted apps running in background consuming your precious data and CPU.

  2. Disable unwanted Startup Programs

  3. Delete Temp Files

  4. Delete Prefetch Files

Source:- http://merabheja.com/make-your-windows-10-pc-ultra-fast/

more ▼

answered Nov 09 '17 at 06:35 AM

avatar image

winmaster121
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question