x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project not compiling

Hello,

My project suddenly refuses to compile after I made some slight changes to a couple of classes. After starting the build it will get stuck at "Build started" or "Parsing headers". Even after 30min of waiting no progress, while the compile usually takes about 2min at most! Looking at the performance statistics it seems like VS isn't really doing anything with the CPU usage being < 20% and GPU usage < 5%.

alt text

I am really clueless as I didn't touch anything else than my own classes!

Thanks for your help!

Product Version: UE 4.8
Tags:
screenshot.png (117.0 kB)
more ▼

asked Aug 11 '15 at 11:31 AM in Bug Reports

avatar image

Fluppi393
457 36 33 54

avatar image Fluppi393 Aug 11 '15 at 12:41 PM

Also when I cancel the build process, I get the following error message:

 MSBUILD : error MSB4166: Child node "2" exited prematurely. Shutting down. Diagnostic information may be found in files in the temporary files directory named MSBuild_*.failure.txt.
avatar image Doug E ♦♦ STAFF Aug 11 '15 at 03:37 PM

Hey Fluppi393-

What code was added before this started to occur? If you create a new code project and try to compile does it hang at the same places? Let me know if there are any steps I can follow to try to reproduce the behavior on my end.

Cheers

Doug Wilson

avatar image Fluppi393 Aug 11 '15 at 04:43 PM

I just tried to compile a different project and the error still occurs! So does it have anything to do with my VS or Unreal Build setup (wich I didn't touch) ?

avatar image Doug E ♦♦ STAFF Aug 11 '15 at 05:27 PM

Was it a brand new project or another project you were working on? Also, let me know if you have the same issue when building a non-UE project. Looking at the screenshot you may also want to try building Development Editor rather than DebugGame/DebugGame Editor.

avatar image Fluppi393 Aug 11 '15 at 06:32 PM

I can compile non-UE projects without problems. Also I tried to create a new code project, the result is that it is stuck on the "Creating project..." popup at 0%.

avatar image Fluppi393 Aug 11 '15 at 06:49 PM

In case that helps I just tested and I can compile old 4.7 projects, so it has to do something with my 4.8 engine.

avatar image Doug E ♦♦ STAFF Aug 11 '15 at 07:08 PM

If you are using the binary version of the 4.8 engine from the launcher I would suggest trying to verify the engine version by clicking on the drop down arrow next to the engine version in the Library tab of the Launcher. If you are using a source built version of the engine you may want to try rebuilding the engine or re-downloading the source code and rebuilding from scratch.

avatar image Fluppi393 Aug 11 '15 at 07:49 PM

I verified the binary version but still no success...

avatar image Doug E ♦♦ STAFF Aug 12 '15 at 08:29 PM

Let me know if the project compiles under a different solution configuration. If you switch from DebugGame to Development Editor are you able to compile then? Additionally, are you able to compile code changes by clicking the Compile button inside the editor?

avatar image Fluppi393 Aug 12 '15 at 09:11 PM

No I can neither compile with Develoment Editor configuration. Hot Reload will not leave the "compiling..." state.

avatar image Fluppi393 Aug 15 '15 at 05:59 PM

In case version 4.9 doesn't get released soon I still need help with this :)

avatar image Doug E ♦♦ STAFF Aug 18 '15 at 03:28 PM

Hey Fluppi393-

If this is only happening for projects using the 4.8 engine version then you may want to remove/re-install that version. Also, if you have more than one version of VS on your computer (such as 2010 or 2012) then uninstalling them may help. Searching the error code you mentioned (MSB4166), it appears the problem could be a lack of memory. If you post your DXDiag we can see if this is a likely cause.

avatar image Fluppi393 Aug 18 '15 at 04:11 PM

I am re-installing the engine right now. Here is my DxDiag:link text

dxdiag.txt (36.4 kB)
avatar image Fluppi393 Aug 18 '15 at 09:24 PM

Tested it with the fresh installation of 4.8.3 version and it didn't work neither...

avatar image Doug E ♦♦ STAFF Aug 19 '15 at 03:26 PM

Hey Fluppi393-

Just to double check, are you using the engine from source code or the binary version? Also, what classes were changed in your original post? Do you have the same problem trying to compile projects using the 4.9 preview?

avatar image Fluppi393 Aug 19 '15 at 06:07 PM

I am not using source control but the default UE4 code. To be honest I am not 100% anymore what classes I changed back then but I know that I added some UDamageType classes and apart from that nothing special. I will download the 4.9 preview and test with it.

avatar image Fluppi393 Aug 19 '15 at 10:18 PM

Compiling with 4.9 preview works.

avatar image Moss Aug 19 '15 at 10:34 PM

and a clean 4.8.3 install does not?

avatar image Fluppi393 Aug 19 '15 at 10:36 PM

No, neither a verify nor a re-installation works.

avatar image Matthew J Aug 25 '15 at 09:20 PM

Hello Fluppi393,

I would like to clarify a few things to be sure that everything is correct.

  • You're able to build a C++ project in 4.7 and 4.9, but not with 4.8

  • Your 4.8 version of the engine is a version that you have downloaded from the Epic Games Launcher.

  • You have tried building in both DebugGame Editor and Development Editor configurations

  • You've also attempted reinstalling 4.8 and verifying the installation.

I saw that you mentioned that when you attempting to build for Development Editor, it became stuck on Hot Reloading. Have you tried compiling a UE4 C++ project while the editor is closed? This should skip the hot reload feature and could possibly help identify the problem.

avatar image Fluppi393 Aug 29 '15 at 09:14 AM

All points you mentioned are correct. And I always compiled with the editor closed except the one time I tried hot reload. Also some days ago I wanted to open the project in 4.7 and 4.9 preview, but the compile during conversion for the copy got stuck in both.

avatar image Fluppi393 Aug 31 '15 at 04:54 PM

A quick update: I downloaded 4.9 and tried to open a copy of my 4.83 project. The engine crashed probably while it was compiling, so I opened the solution file and tried to compile it. Now I get the same error (MSB4166) like when building this project with 4.8.

avatar image Matthew J Aug 31 '15 at 09:14 PM

When using 4.9, does this only happen with the project that you copied over from 4.8.3 or does it also occur with fresh C++ projects created with 4.9?

avatar image Fluppi393 Sep 01 '15 at 09:12 AM

I could compile new projects in 4.9 preview and successfully converted a 4.7 project with release version.

avatar image Moss Sep 01 '15 at 09:20 AM

So for now the issues are solved on your side?

avatar image Fluppi393 Sep 01 '15 at 09:25 AM

No not really as I still cannot open my main 4.8 project.

avatar image Moss Sep 01 '15 at 09:31 AM

have you tried it on another machine?

avatar image Fluppi393 Sep 01 '15 at 10:25 AM

No, I don't have another machine capable for the UE4.

avatar image Matthew J Sep 01 '15 at 01:43 PM

As it seems that the issue could be project specific, would it be possible for you to upload a copy of this project that is giving you issues to see if it can occur for me as well? If you'd like to keep the project itself private, you could send a link to the project to me in a private message on the forums. Here is my profile

avatar image Fluppi393 Sep 01 '15 at 02:27 PM

The issue is not project specific as I neither could compile a new 4.8 project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I found the solution!

Today I pasted some classes of my corrupted project into a new project to save time, when I noticed that I suddenly received the same error as with my old project. After some testing I figured out what files were causing the problem and when I had a closer look at them I realized that I accidently created a circular inheritance. Once I changed the according file the project compiled again for the first time after almost 1 month!

I don't know though why also a new 4.8 project didn't compile back then, maybe it would have worked if I restarted my computer before trying a new project.

Anyways thanks for the help!

more ▼

answered Sep 05 '15 at 01:30 PM

avatar image

Fluppi393
457 36 33 54

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you tried to clean and build your project?

more ▼

answered Aug 11 '15 at 12:12 PM

avatar image

Moss
6.4k 127 98 607

avatar image Fluppi393 Aug 11 '15 at 12:23 PM

Building has the same result as recompiling. I already cleaned the project but it didn't fix the problem. I just wanted to clean it again but now the clean process will also not progress after the first step...

avatar image Moss Aug 11 '15 at 12:54 PM

Check if there is any instance of UnrealBuildTool already running

avatar image Fluppi393 Aug 11 '15 at 12:59 PM

Yes Build and Header tool are running.

avatar image Moss Aug 11 '15 at 01:22 PM

I mean when you are not building, they might be crashed in the background and now failing.

avatar image Fluppi393 Aug 11 '15 at 01:25 PM

They are actually still running even though I closed VS. I already restarted my PC with no success.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question